GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

P0413 code

worldacgti

Go Kart Champion
Anyone run into this code? Checked hoses and wiring and everything seems to be intact. I clear it and it pops right up again...

Sent from my SM-G965W using Tapatalk
 

launchd

Drag Racing Champion
Location
New York
Car(s)
2021 M340xi, 2021 A7
P0413 - Secondary Air Injection System Switching Valve "A" Circuit Open

Can you tell if the SAI pump is running on cold start?
 

nkresho

suck, squish, bang, blow
Location
Pittsburgh
Car(s)
2022 Q3
I had to replace the SAI valve in my 2016 a few months ago. Grabbed a used one and it's g2g now. It sits right under the vacuum pump on the drivers side of the motor.

Code with no light came and went for me. Sometimes i'd go a day or two after clearing it, other times it came on first cold start.

Pull the turbo outlet boost pipe if/when you install it. I tried to convince myself I could install it without. Spent a good hour fighting it before I gave in.

There's a gasket too. Cheap, like a buck or two. Grab that when you get the valve.
 

nkresho

suck, squish, bang, blow
Location
Pittsburgh
Car(s)
2022 Q3
Code is back for me as of this past weekend.

Thankfully, it stayed away long enough to get the car inspected.

I can hear the pump (i think that's what it is) on cold start. I park in my garage at home, so it's pretty evident when it opens then closes. Opens a few seconds after startup and runs for 5-10 seconds then stops.

More investigating needed, i guess. New (used) pump was put in last month.

Odd that the OP and I have very similar mods (autotech intake, uni IC, CTS TIP, moosetuned is38, and meth) I wonder if one or a combination of them is causing the fault.
 

Diggs24

Autocross Champion
Location
de plains! de plains!
Car(s)
2015 GTI
Code is back for me as of this past weekend.

Thankfully, it stayed away long enough to get the car inspected.

I can hear the pump (i think that's what it is) on cold start. I park in my garage at home, so it's pretty evident when it opens then closes. Opens a few seconds after startup and runs for 5-10 seconds then stops.

More investigating needed, i guess. New (used) pump was put in last month.

Odd that the OP and I have very similar mods (autotech intake, uni IC, CTS TIP, moosetuned is38, and meth) I wonder if one or a combination of them is causing the fault.

Which code? Pretty sure there's a valve that opens and closes when SAI pump kicks on that is controlled by ECU. The valve might be bad instead of the pump. Also, pretty sure it's supposed to run for more than 5-10 seconds.
 

jimlloyd40

Autocross Champion
Location
Phoenix
Car(s)
2018 SE DSG
Which code? Pretty sure there's a valve that opens and closes when SAI pump kicks on that is controlled by ECU. The valve might be bad instead of the pump. Also, pretty sure it's supposed to run for more than 5-10 seconds.

Doesn't it run for how ever long it takes to preheat the catalytic converter sufficiently?
 

nkresho

suck, squish, bang, blow
Location
Pittsburgh
Car(s)
2022 Q3
I'll pull the code again after my trip home from work.

I think it was the 0413 again, but i'll look.

I misworded above, i replaced the valve last month, not the pump. Combi valve, PN 06K131097K

I'm just assuming it's sai noise, as it sounds much like intake noise, but louder, kinda like putting your ear closer to an open element intake at idle. Definitely intake noise of some sort.

Edit: yup 0413 it's back again.
 
Last edited:

mchladkins34

Passed Driver's Ed
I’m having similar issues. Anyone figure it out yet? I was told by a trusted tech friend to replace the combo valve.


Sent from my iPhone using Tapatalk
 

Bjenkins087

Passed Driver's Ed
Location
Md
I'll pull the code again after my trip home from work.

I think it was the 0413 again, but i'll look.

I misworded above, i replaced the valve last month, not the pump. Combi valve, PN 06K131097K

I'm just assuming it's sai noise, as it sounds much like intake noise, but louder, kinda like putting your ear closer to an open element intake at idle. Definitely intake noise of some sort.

Edit: yup 0413 it's back again.
Where exactly is the combi valve located? Pics?
 

nkresho

suck, squish, bang, blow
Location
Pittsburgh
Car(s)
2022 Q3

bluedoggiant

Ready to race!
Location
MD/GA
I’ve been having this issue for years. My tech redoes the wiring to the combi valve and fixes it for few months before I need to return
 

RecycledDonuts

Ready to race!
Location
Alabama
I want a damn block off plate for this valve. Take it out instead of replacing over and over.
 
Top