GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

[HOW TO PATCH Component Protection] MIB2/MST2 Delphi HeadUnit (MST2_VW_xxxxxD) patch [FEC/SWAP/CID/CP]Android Auto,CarPlay and many more

Latron

Master of oil top off
Location
Dallas, TX
Car(s)
2015 GTI DSG
Ok so I did the Congo and Duke activator, it didn't remove CP. I have MST2_US_VW_P0890D software in the Radio. I found the patch delphiin.ifs for my software version and loaded it onto the SD card with the delphi.sh file. Both in the root with nothing else on it. I loaded it and now my radio comes up to the VW screen then restarts. If i put the SD card back in it comes up with the blue screen that says updating then goes to the green screen saying successful. When I take the SD card out and restart it it then does the same thing, VW screen then restarts. I cannot find the 0890D firmware anywhere to download. Is there any way to fix this?
 

TEG

New member
Location
Buenos Aires, AR
Car(s)
MK7.5 1.4TSI
Ok so I did the Congo and Duke activator, it didn't remove CP. I have MST2_US_VW_P0890D software in the Radio. I found the patch delphiin.ifs for my software version and loaded it onto the SD card with the delphi.sh file. Both in the root with nothing else on it. I loaded it and now my radio comes up to the VW screen then restarts. If i put the SD card back in it comes up with the blue screen that says updating then goes to the green screen saying successful. When I take the SD card out and restart it it then does the same thing, VW screen then restarts. I cannot find the 0890D firmware anywhere to download. Is there any way to fix this?
I just used the unbroken version without any issue, I just updated VIN and VCRN to have the fecs as "original" but SportHMI was loaded from exception list.
You can download 0890D from (using guest / guest):
https://mibsolution.one/#/1/9/MST2 - DELPHI/Firmware/VW/US

Be sure your car is US version (I think so since you're at Dallas).
 

brentgti

Go Kart Champion
Location
North America
Car(s)
GTI
I just used the unbroken version without any issue, I just updated VIN and VCRN to have the fecs as "original" but SportHMI was loaded from exception list.
You can download 0890D from (using guest / guest):
https://mibsolution.one/#/1/9/MST2 - DELPHI/Firmware/VW/US

Be sure your car is US version (I think so since you're at Dallas).
For reference, it is generally not necessary to edit the VIN or VCRN and just run the activator. Should still work fine.

Additionally, the directory you linked does not contain MST2_US_VW_P0890D firmware.
 

Fortu

New member
Location
España
Car(s)
VW Tiguan
Hi all, I have a Tiguan 2016
This is my MIB2 Delphi unit:
- MST2_EU_VW_P0220D
- 3Q0035846
- it was not patched ever, just original firmware
I want to remove the sd card CID lock but i dont know to do it.
its to insert not original sd with maps
Thanks.
 
Last edited:

GTDinGermany

New member
Location
Stuttgart
Car(s)
2018 GTD
I activated via congo & duke v3.0, and everything worked to get carplay. Thanks for this great software, guys!

BUT - I have b201a error. I see how to fix it with the updated code - However, OBDeleven wants 69.99 EUR to update this one value.
I decided not to pay, and turned the car off and back on, and carplay and everything is still working.

Is it going to be a problem if I don't pay 70 EUR for the pro version of OBDEleven and update it with the correct value?
what symptom or issue would occur? Because so far I see no problem other than some codes when I am connected via OBD2.

I'm really dissapointed by the lowest price of this software to update a single value after already spending $70 on the OBDeleven reader.
 
Last edited:

Jafonso

New member
Location
Portugal
Car(s)
VW Passat 2016
Hi all,

Can I use Congo and duke activation on this unit:
MST2_EU_VW_E0220D
SW 0624
3Q0035846
VW Passat 2016
I cont nave acess to fec codes installed.
 

Attachments

  • IMG-20240526-WA0000.jpg
    IMG-20240526-WA0000.jpg
    176.9 KB · Views: 31
  • IMG-20240526-WA0001.jpg
    IMG-20240526-WA0001.jpg
    168.4 KB · Views: 33
  • IMG-20240526-WA0002.jpg
    IMG-20240526-WA0002.jpg
    186.4 KB · Views: 33
  • IMG-20240526-WA0003.jpg
    IMG-20240526-WA0003.jpg
    154.5 KB · Views: 34
  • IMG-20240526-WA0004.jpg
    IMG-20240526-WA0004.jpg
    233.8 KB · Views: 26
  • IMG-20240526-WA0005.jpg
    IMG-20240526-WA0005.jpg
    218 KB · Views: 27
  • IMG-20240526-WA0006.jpg
    IMG-20240526-WA0006.jpg
    161.7 KB · Views: 27
  • IMG-20240526-WA0007.jpg
    IMG-20240526-WA0007.jpg
    205.2 KB · Views: 27
  • IMG-20240526-WA0008.jpg
    IMG-20240526-WA0008.jpg
    142.3 KB · Views: 28
  • IMG-20240526-WA0009.jpg
    IMG-20240526-WA0009.jpg
    231.9 KB · Views: 38

jan123

New member
Location
Germany
Car(s)
Golf 7 2017
Hi Bro, I have a 2017 Golf 7. I want to do Android CarPlay, but I don’t know how. Can you help me?
 

Attachments

  • 20240526_194904.jpg
    20240526_194904.jpg
    1.6 MB · Views: 61

Jafonso

New member
Location
Portugal
Car(s)
VW Passat 2016
Hi all,

Can I use Congo and duke activation on this unit:
MST2_EU_VW_E0220D
SW 0624
3Q0035846
VW Passat 2016
I cont nave acess to fec codes installed.
So already patched successfully.
Android Auto
Hi Bro, I have a 2017 Golf 7. I want to do Android CarPlay, but I don’t know how. Can you help me?
Your unit is Technisat so you got to go Technisat threads.
 

Jafonso

New member
Location
Portugal
Car(s)
VW Passat 2016
Hi, I did the installation but carplay still did not work. What am I doing wrong? App-connect does not appear on the screen.
What I´ve read is that in some cases (like this units) you need to replace the usb port for another in order to apple carplay works.
I´ve only tested android auto and it did not work because of the cable that I used. I´ve to bought one better and then it works.
Buy another cable and test. A good one.
See
 
Top