GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Android Auto vs BT(Spotify sound quality)

mindonmatter

Ready to race!
Location
Houston Area
So, I never really listened to audio over BT until today. Much to my surprise, the sound quality of Spotify over BT blows away the SQ of Android Auto. The bass is twice as loud, so much clearer highs and mids. Now that I've compared the two back to back, I'll never be able to listen to AA again, which sucks because I love AA for Maps/Waze.

In my Spotify app settings, I have the highest sound quality selected. I'm wondering.....when using Spotify through AA, if maybe those settings are being bypassed?

Anyone else experience this? Any way to improve the SQ of AA/Spotify?

Also, does anyone have a list of compatible BT codecs for a 2019 MK7.5(base audio with Helix).

Thanks!
 

blaqsheep

Drag Racing Champion
Location
Canada
Car(s)
IS38 GTI
Louder does not always mean better. A wired connection should be superior to that of a compressed Bluetooth audio stream. I find the same issue present with my iPhone and CarPlay, however I listen to most of my music from an SD card (mix of MP3 and FLAC).

From what I remember, CarPlay/Android Auto uses LPCM and PCM over Bluetooth: https://en.wikipedia.org/wiki/Pulse-code_modulation

Also, on your Android, there should be an option to disable audio routing to USB (look for how to enable Developer options). This should keep audio on BT even when you connect to AA through USB.
 

mindonmatter

Ready to race!
Location
Houston Area
It's definitely not a case of louder is better. It's a night and day difference in SQ. I totally agree, a wired connection should be superior which is why I'm confused.

I just disabled the USB routing. Great little tip there. Thanks!
 

Wrath And Tears

Go Kart Champion
Location
Azusa, CA
My experience is the exact opposite. Quality over BT sucks terribly and drops out / studders. AA sounds much better. What phone do you have? It might just be my phone (S9). Although I think it was the same for my 6P, but my wifes iPhone sounds great over BT. Very confusing.
 

eXult

Ready to race!
Location
Online
Car(s)
'17 GTI SE 6MT
To me its the same. Quality over BT is better than via Android Auto. Though for me the answer is simple. I use ViPER4Android, a popular equalizer for rooted phones, and the app controls all devices (hardwired included), but it does not seem to work for me via Android Auto.

So quality is always better for me via Bluetooth because the equalizer actually makes a difference for it.
 

robmarktoo

Ready to race!
Location
Oregon
I listen to all my music from the SD card, I find it much more convenient than worrying about my phone for anything other than navigation.
 

El_bigote_AJ

Autocross Newbie
Location
Las Vegas
Car(s)
2019 GTI bunny
Same deal for me, Spotify was PURE trash over car play and much better over BT, I ended up canceling Spotify and paying for apple music because the quality is far superior through carplay… but even with apple music when the car switches to BT it is MUCH louder at the same volume level than when its wired.
 

mike-y

Passed Driver's Ed
Location
Los Angeles
I listen to all my music from the SD card, I find it much more convenient than worrying about my phone for anything other than navigation.
Same. I don't see the point of using my phone for music when I can have a 32gb SD card in there all the time.

I do use AA for streaming my audiobooks though.
 

2slowvw

Moderator
Location
VA
Car(s)
2016 GTI
There is a ton of reasons why bluetooth from phone to phone and head unit to head unit will sound different between compression, codecs, hardware etc... i don't care to get into this. Basically to help out OP try doing this:

1. Open the Settings app.
2. On Android 8.0 or higher, Select System.
3. Scroll to the bottom and select About phone.
4. Scroll to the bottom and tap Build number 7 times. This enables Developer mode.
5. Return to the previous screen to find Developer options near the bottom.
6. Go to Networking and set Bluetooth Audio Codec to your preference, i recommend checking out this: https://www.androidauthority.com/bluetooth-codecs-997074/
Basically it says chose aptX HD or aptX for android.
7. You can also mess with Bluetooth Audio Sample Range / Bluetooth Audio Bits Per sample.
8. Scroll down to Media and Disable USB audio routing. This should force Audio to BT.

Hopefully this helps.
 

mindonmatter

Ready to race!
Location
Houston Area
Okay, I have tried disabling the USB audio routing, but it doesn't seem to work. It still switches from BT when the cord is plugged in.

AptX codec works and sounds great, but it won't default to AptX when I reconnect. I have to manually connect to AptX each time I connect to BT. Any way to set the default to AptX?
 

geokilla

Ready to race!
Location
Toronto, Ontario, Canada
Car(s)
2018 VW GTI DSG
There is a ton of reasons why bluetooth from phone to phone and head unit to head unit will sound different between compression, codecs, hardware etc... i don't care to get into this. Basically to help out OP try doing this:

1. Open the Settings app.
2. On Android 8.0 or higher, Select System.
3. Scroll to the bottom and select About phone.
4. Scroll to the bottom and tap Build number 7 times. This enables Developer mode.
5. Return to the previous screen to find Developer options near the bottom.
6. Go to Networking and set Bluetooth Audio Codec to your preference, i recommend checking out this: https://www.androidauthority.com/bluetooth-codecs-997074/
Basically it says chose aptX HD or aptX for android.
7. You can also mess with Bluetooth Audio Sample Range / Bluetooth Audio Bits Per sample.
8. Scroll down to Media and Disable USB audio routing. This should force Audio to BT.

Hopefully this helps.

Can our cars play HD audio via BT though? In the Honda Clarity I get that option in the Bluetooth connection screen, but not with my GTI.
 

Chillout

Go Kart Newbie
Location
the Netherlands
Car(s)
Golf GTE
okay, let's see if we can improve the quality of AA sound :)


Here's the part of the gal.json config file in the MIB2 High:

Code:
"audio":{
        "source":{
            "dump":{
                # activate audio source dumping by setting "enabled" to "true", otherwise "false"
                #asodump !! don't remove that marker and always keep it before the "enabled":x, line!
                "enabled":false,
                "maxFiles":50,
                # maximum size per dump file in bytes (multiply by maxFiles for maximum dump space occupied)
                "maxFileSize":2097152
            },
            "samplingRate":16000,
            "bits":16,
            "channels":1,
            "nvaudio":{
                # options: "ENT1", "SSE_REC", "MIC"
                "device":"MIC3"
            },
            "asound":{
                "device":"mic1",
                "pluginAware":true,
                "startMode":1,
                "stopMode":1,
                "fragsMin":3,
                "fragsMax":5
            }
        },
        "sink":{
            "dump":{
                # activate audio sink dumping by setting "enabled" to "true", otherwise "false"
                #asidump !! don't remove that marker and always keep it before the "enabled":x, line!
                "enabled":false,
                "maxFiles":50,
                # maximum size per dump file in bytes (multiply by maxFiles for maximum dump space occupied)
                "maxFileSize":2097152
            },
            "media":{
                "freq":48000,
                "bits":16,
                "channels":2,
                # See enum MediaCodecType in protos.pb.h
                "codecType":1,
                "maxUnackedFrames":16,
                "nvaudio":{
                    # options: "MPL6", "MPL1", "MPL5"
                    "device":"MPL6"
                },
                "asound":{
                    "device":"mpl1_int_ent",
                    "pluginAware":true,
                    # DATA=1, FULL=2, GO=3
                    "startMode":1,
                    # STOP=1, ROLLOVER=2
                    "stopMode":1,
                    "fragsMin":3,
                    "fragsMax":5
                },
                "renderer":{
                    # Delay in microseconds until retry is performed if the route is unavailable
                    "retryDelay":50000,
                    # Max. number of retries if the route is unavailable (0 to disable the retry mechanism)
                    "retryCount":3,
                    # Number of frames to be buffered before the playback starts or 0 to disable buffering
                    "framesBufferedMin":4,
                    "framesBufferedMax":6
                }
            },
            # For an explanation of the parameters, see the "media" section
            "guidance":{
                "freq":16000,
                "bits":16,
                "channels":1,
                "codecType":1,
                "maxUnackedFrames":8,
                "nvaudio":{
                    # PIN assignment: UI: "ANN5", Guidance: "ANN6", Voice/Telephony: "ANN7"
                    "device":"ANN6"
                },
                "asound":{
                    "device":"ann1_int_nav",
                    "pluginAware":true,
                    "startMode":1,
                    "stopMode":1,
                    "fragsMin":3,
                    "fragsMax":5
                },
                "renderer":{
                    "retryDelay":50000,
                    "retryCount":3,
                    "framesBufferedMin":4,
                    "framesBufferedMax":6
                }
            },
            "decoder":{
                "decodeBufferSize":1048576
            }
        }
I think we can try to increase the sampling rates and frequencies? At least, switching to a depth of 24 bit could improve the sound a little, although I highly doubt Bluetooth audio has such a high dept.
 
Last edited:

2slowvw

Moderator
Location
VA
Car(s)
2016 GTI
Okay, I have tried disabling the USB audio routing, but it doesn't seem to work. It still switches from BT when the cord is plugged in.

AptX codec works and sounds great, but it won't default to AptX when I reconnect. I have to manually connect to AptX each time I connect to BT. Any way to set the default to AptX?
Are you sure, try toggling Bluetooth off when your song is playing. I tested it on my note 9 and it indeed will cut the audio.
 

Acadia18

Drag Racing Champion
Location
Rhode Island
If you're streaming through Spotify, you're only streaming at 160/320 kbps regardless. That's going to be the lowest common denominator in the quality equation.

Sent from my ONEPLUS A6013 using Tapatalk
 
Top