GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV
FORUM OPTIONS
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Go Back   GOLFMK7 - VW GTI MKVII Forum / VW Golf R Forum / VW Golf MKVII Forum > Volkswagen GTI / Golf MK7 General Topics > GTI & Golf MK7 General Discussions


Reply
 
Thread Tools Display Modes
Old 03-17-2019, 12:23 AM   #1
Sammie M
Junior Member
 
Drives: VW Golf GTI MK7
Location: Antrim
Join Date: Dec 2018
Posts: 29
No Horn after BCM upgrade.

Hi,
Recently bought a 2016 GTI with a headlight upgrade to mk7.5 LED headlights which didn't work to start with.
However after some help, I retrofitted a 4B module and changed up the BCM. Re-Coded the adaptations etc and got everything working...except the HORN!
When I plug the old BCM back in, the horn works! There are very few coding changes relating to the Signal Horn.
I've replaced the Steering Wheel J527 module to one from a 2017 golf which had the same upgraded BCM I'm now using..and still no joy.

Am I right in now thinking the new BCM must have a fault??

Old BCM 5Q0937084AS
New BCM 5Q0939084CF

Any and all help welcomed.

Thanks
Sam

Sent from my SM-J530F using Tapatalk
Sammie M is offline   Reply With Quote
Old 03-17-2019, 02:37 PM   #2
Agorina
Member
 

Join Date: Feb 2015
Posts: 60
It could be many different things. All the modules communicate with each other so the problem could be very difficult to locate. What if you tried changing the horn itself? That's the only cost effective thing I could think of right now.

Sent from my LYA-L0C using Tapatalk
Agorina is offline   Reply With Quote
Old 03-17-2019, 02:38 PM   #3
Sammie M
Junior Member
 
Drives: VW Golf GTI MK7
Location: Antrim
Join Date: Dec 2018
Posts: 29
The actual sounder from the engine bay?

Sent from my SM-J530F using Tapatalk
Sammie M is offline   Reply With Quote
Old 03-17-2019, 02:40 PM   #4
Sammie M
Junior Member
 
Drives: VW Golf GTI MK7
Location: Antrim
Join Date: Dec 2018
Posts: 29
It beeps (as opposed to the richer Honk) with the old BCM in place.

Sent from my SM-J530F using Tapatalk
Sammie M is offline   Reply With Quote
Old 03-17-2019, 05:36 PM   #5
Finglonga
Senior Member
 
Finglonga's Avatar
 
Drives: Mk7 Golf GTI Performance
Location: Staffs,Blighty
Join Date: Apr 2014
Posts: 2,557
Quote:
Originally Posted by Sammie M View Post
It beeps (as opposed to the richer Honk) with the old BCM in place.

Sent from my SM-J530F using Tapatalk

There are 2 horns, one on each side to give the tone. It sounds like one side has failed from what you are saying and could purely be coincidence.
__________________
..
Finglonga is offline   Reply With Quote
Old 03-17-2019, 06:06 PM   #6
Shane_Anigans
Senior Member
 
Shane_Anigans's Avatar
 
Drives: 2017 GTI Sport DSG
Location: SE MI
Join Date: Oct 2017
Posts: 977
Quote:
Originally Posted by Finglonga View Post
There are 2 horns, one on each side to give the tone. It sounds like one side has failed from what you are saying and could purely be coincidence.

I could be mistaken, but aren't there 2 different horn circuits? One for the high-tone horn only (locking/unlocking) and the other that activates both? In this case, I would tap the trigger to the horn that's working, and run a wire to the one that isn't, to determine if it's a faulty horn or a faulty circuit. Plus, if the low-tone horn is working, the problem is solved.
__________________
2017 GTI Sport DSG - Tornado Red | Ask me about new car incentives
Shane_Anigans is offline   Reply With Quote
Old 03-17-2019, 06:14 PM   #7
Sammie M
Junior Member
 
Drives: VW Golf GTI MK7
Location: Antrim
Join Date: Dec 2018
Posts: 29
A bit of an update.
I ran 3 'Live Data' tests.

1st on the Steering Column electronics, signal horn....when I press the horn, the status changes to 'activated' (no sound).

2nd on the BCM Activation of Signal Horn....when I press the horn, the status changes to 'operated' (no sound).

3rd on the Gateway module, Multi function Steering wheel.....under here it monitors a number of buttons including Signal horn....when I press the horn status stays at 'not activated'.

Given I've upgraded the BCM, and the Steering Electronics...J527 but not yet the CAN Gateway, do you think this could be the issue?
Although everything else is working.



Sent from my SM-J530F using Tapatalk
Sammie M is offline   Reply With Quote
Old 03-17-2019, 07:36 PM   #8
The Fed
Senior Member
 
The Fed's Avatar
 
Drives: 2016 Golf R
Location: Florida
Join Date: Dec 2012
Posts: 10,920
Quote:
Originally Posted by Shane_Anigans View Post
I could be mistaken, but aren't there 2 different horn circuits? One for the high-tone horn only (locking/unlocking) and the other that activates both? In this case, I would tap the trigger to the horn that's working, and run a wire to the one that isn't, to determine if it's a faulty horn or a faulty circuit. Plus, if the low-tone horn is working, the problem is solved.
There is a separate horn for the alarm/verification beep. The high/low service horns are on the other circuit.

Does a VCDS scan show any errors?
__________________
(Mostly) Posted by Josh/AWE. Flapper valves are open at idle, close after 1100 RPM during part throttle. Full throttle 1st-4th gear the valves open until throttle let off. 4th gear, 1500 RPM to full throttle closed, closed until 3500 RPM, then open until lift off throttle.
The Fed is offline   Reply With Quote
Old 03-17-2019, 10:08 PM   #9
Sammie M
Junior Member
 
Drives: VW Golf GTI MK7
Location: Antrim
Join Date: Dec 2018
Posts: 29
Hi, no errors on the horn at all.



Sent from my SM-J530F using Tapatalk
Sammie M is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.