GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV
  • Has your username changed as part of the site merger and want it changed back? If the other version of your username isn't being used, send Gulfer a PM and we can probably fix it for you

Woe is the DSG 7 speed

Rob_G

New member
Location
Regina, SK
I have never been more annoyed with the transmission in a car than with the DSG on my 2018 R. It's weird because there are a few times it will behave normally and it's really great then, but more often lately it's not behaving and it's annoying in its quirkiness.

1 - Constant jerking into first from a stop
2 - Random poor clutch engagement on first gear acceleration (it doesn't engage fully for 1 or 2 seconds) and then it jerks into gear.
3 - Almost constant 'rev-rev' shifting/clutch weirdness from 2 to 3.

I thought it would get better as the vehicle broke in more, but actually I think it's worse now at 10,000kms. I know there are A LOT of threads around the internet on the subject of DSG performance and some saying a 'tune' will help. I'm not looking to void my warranty at this time.

So I have decided to escalate to the dealer my concerns about the transmission and will see how it goes. I don't think the transmission operation falls into an acceptable category, but of course VW and the dealership will have their own opinion. I can probably live with it for a few years until warranty runs out, but I wouldn't keep the car past that point.

Sorry, I hope people don't lament another DSG thread, but I wanted to share my experience so far.

Rob
 

mattkosem1

Ready to race!
Location
OH, US
Good luck! That 2-3 (and 4-3) BS has annoyed the heck out of me since day one. There's a fix for 2-3 available ROW, but there apparently haven't been enough complaints for VW to get it certified here.

I have the APR tune, and it helps, but it doesn't really fix any of those issues (except, to some extent, the take off from a stop stuff). I'm convinced there's a problem with the clutch timing in all the odd numbered gears, and that it's just not very noticeable in 5/7 because of vehicle speed.
 

mattkosem1

Ready to race!
Location
OH, US
These problems aren't strictly cold weather problems. All 3 happen year round. The first is definitely more pronounced in the cold, I'll give you that, but the other two always happen. I'm on my second winter with my '18 R and the DSG behaviors are definitely the most frustrating aspects of this car.

Coming from driving manuals forever, driving the DSG strictly in manual mode, and being accustomed to driving dead smack in the sweet spots of the torque curve I see this irritating nonsense every time i drive the car.
 

flg2010

Passed Driver's Ed
Location
CT
I can compare the R DSG (which I drive and love) it to the WRX CVT (which I drove for just around 3 years) and I will:

- It's rev hang is much less of an issue
- It shifts much more fluidly
- The R is a bunch faster and is almost as fast as the STI.
 

JWTS

Ready to race!
Location
WA
My 2019 R exhibits none of these problems. When I test drove a used 2018 R, the programming on the transmission definitely seemed different and there was weirdness going on.

I wonder if there's a software update that the dealer can flash? The hard parts seem the same, but I don't recall seeing many complaints on the '19. Mine is way better than my TCU-tuned 6 speed DSG, in pretty much every regard.
 

mattkosem1

Ready to race!
Location
OH, US
I wonder if there's a software update that the dealer can flash? The hard parts seem the same, but I don't recall seeing many complaints on the '19. Mine is way better than my TCU-tuned 6 speed DSG, in pretty much every regard.
There's a software update that fixes the rough 4->3 that the dealer can't flash in the US. What is the software version on your 2019? I haven't heard of anything else so far, and I've looked a lot.


Mine looks like this:



--Matt
 

JWTS

Ready to race!
Location
WA
grrrrr

well, I'll try to find out for you--but this is where my own griping starts..

My vagcom cable is not compatible w/my '19, so I picked up an OBD11. I hate it more than you hate your DSG...

I'll plug it in tomorrow, and half an hour later I'll be able to report back (unless it won't connect the control module). Assuming I'm able to get it to work, I'll post up the software info on it.
 

mattkosem1

Ready to race!
Location
OH, US
grrrrr



well, I'll try to find out for you--but this is where my own griping starts..



My vagcom cable is not compatible w/my '19, so I picked up an OBD11. I hate it more than you hate your DSG...



I'll plug it in tomorrow, and half an hour later I'll be able to report back (unless it won't connect the control module). Assuming I'm able to get it to work, I'll post up the software info on it.
[emoji106] thanks
 

mattkosem1

Ready to race!
Location
OH, US
What mode are you driving it in? I don't have any of these issues if I have it in S and Race mode all the time. I find in Non S it is a little jerky.
M, only ever M. They happen in the race (higher idle, you get this if you jump to M from S or switch the drivetrain mode to race while in M) and non-race variants.
 

JWTS

Ready to race!
Location
WA
Here you go. It's definitely a different software profile. My '19 does not exhibit any of these problems.


Sent from my SM-G965U using Tapatalk
 

Rob_G

New member
Location
Regina, SK
This is your first time with the car in cold weather?
No, it's not the first time in cold weather driving. All of these issues present themselves in the summer as well. My cold weather driving is from late winter and early spring when the car was new and not exhibiting these quirks like it is now. The transmission was really very smooth when I first got the car. Now, not so much.

On a side note, I have already had both front control arm bushings replaced under warranty. That fixed the creaking front suspension.

Rob
 

Rob_G

New member
Location
Regina, SK
What mode are you driving it in? I don't have any of these issues if I have it in S and Race mode all the time. I find in Non S it is a little jerky.
I wish there was a sport mode that had the higher rpm gear changes of race mode, but still (eventually) shifted into a higher numbered gear when cruising speed was reached.

Rob
 

mattkosem1

Ready to race!
Location
OH, US
Here you go. It's definitely a different software profile. My '19 does not exhibit any of these problems.


Sent from my SM-G965U using Tapatalk
Wowzers, everything is newer. Newer hardware number, higher software number, much higher software version.
 

mattkosem1

Ready to race!
Location
OH, US
Yeah, these definitely seem to be dq381 quirks. Seems encouraging that the 2019s seem to have much newer software and none of these issues. APRs tune doesn't help any of these things. Totally worth it either way, but not on this stuff :)
 
Top