GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

What would you make of this? 2018 GSW electrical gremlin.

maxwell

Go Kart Champion
Location
Pitt
Car(s)
2018 GSW 6MT 4motion
2018 GSW 4motion 6mt. APR stage 1 91 octane and some misc bits. NOTHING CRAZY! Just a well loved stage 1 wagon. WTF.



So, i've had this issue happen to me 5 times now in the past 3 months. It went to my local dealer (who is APR authorized and who I have a good relationship with) and all they did was reset the codes and that was it. It's extremely intermittent, but when the car 'freaks out' the dash lights up like a 'Christmas tree,' and you can see below it cascades a TON of communication errors. no type of driving brings this out, dry, wet, i can't figure it out. When it freaks out though I get crazy issues on the dash... ABS, ESC, ASR errors, check engine light, brake warnings, speedo cuts out, fuel gauge fluctuates. It seems they all relate to the ABS sensor, is that wtf is causing this? Hoping for some extra eyes.

I have had enough problems with this car, that I am growing a bit frustrated with my experience. At 11k miles I had a rear window issue, see thread: https://www.golfmk7.com/forums/inde...ont-roll-down-child-safety-lock-fault.364861/

This is unrelated, but extremely frustrating. See OBD11 screen shots below. I have since reset the codes and the car has been fine for a few days now and about 10 ignition cycles. Now I am just waiting for it to come back, which is a terrible feeling.

60 errors in total. The only one that seems viable, and possibly cascading the rest of the communication codes is the ABS sensor. I captured them all via OBD11 for IOS, but I am admittedly new to the OBD11 for IOS platform. Any thoughts or advice here from anyone?





















 

swcrow

Autocross Champion
Location
Virginia
Car(s)
7.5
That *almost* looks like a massive ECU communication error...like the harness isn't fully plugged in.
 

maxwell

Go Kart Champion
Location
Pitt
Car(s)
2018 GSW 6MT 4motion
When I last brought it in, they 'checked all connections, cleaned and re-secured all grounds' and sent me on my way after clearing the codes. This has me sweating. I've had some problem cars in my day but this one has been a real bitch. The last 4 on my vin are '666' which I thought was cool, maybe it truly is evil. IDK.

After the previous issue (the door/window issue linked above) I gave it some time before APR stage 1. I hope I don't live to regret it.

This one gives me a sinking feeling. I am no mechanic, but I am BEYOND perplexed. It feels like a bad egg. Any other thoughts here? Is there a main harness plug I could double check @swcrow
 

jimlloyd40

Autocross Champion
Location
Phoenix
Car(s)
2018 SE DSG
I would ask the APR dealer to flash it back to stock and see if it happens
 

maxwell

Go Kart Champion
Location
Pitt
Car(s)
2018 GSW 6MT 4motion
I would ask the APR dealer to flash it back to stock and see if it happens

I've had an APR tune on the car since like 15k miles. I am at 34.5k miles now and this issue just presented itself. How could this be related to the tune? Plus, it's intermittent. Not doubting here, just confirming why I would want to do this.
 

golfdave

Autocross Champion
Location
Scotland (U.K.)
Car(s)
MK7 Golf GT Estate
I don't have OBD11, but do have VCDS

VCDS time stamps each & every fault code & how many times etc.....I'd look through the timestamps & see which one generated first..that's the culprit of the cascade..
 

jimlloyd40

Autocross Champion
Location
Phoenix
Car(s)
2018 SE DSG
I've had an APR tune on the car since like 15k miles. I am at 34.5k miles now and this issue just presented itself. How could this be related to the tune? Plus, it's intermittent. Not doubting here, just confirming why I would want to do this.
Well that's not likely the problem then.
 

maxwell

Go Kart Champion
Location
Pitt
Car(s)
2018 GSW 6MT 4motion
Battery was a strong contender at first but it doesnt make sense at this point, does it?
 

Strange Mud

Autocross Champion
Location
Small Town CT
Car(s)
2017 GTI (+3 more)
it is a guess but 11.9V is low. I see Pitt so temps may be coming in to play. some auto stores will test battery and the cost isn't stupid to try. If you have a decent multi-meter test voltage off and running.

12.5+ off

13.5+ running
 

swcrow

Autocross Champion
Location
Virginia
Car(s)
7.5
Wonder if this is related to condensation, massive downpour or something related.

For example...every time I have a massive downpour with wind, my adaptive headlight warning pops up as if there is something wrong, but then when the rain stops and I keep driving.....it mysteriously goes away.
 

maxwell

Go Kart Champion
Location
Pitt
Car(s)
2018 GSW 6MT 4motion
it is a guess but 11.9V is low. I see Pitt so temps may be coming in to play. some auto stores will test battery and the cost isn't stupid to try. If you have a decent multi-meter test voltage off and running.

12.5+ off

13.5+ running

Im seeing north of 14 while monitoring when the car is on. I am noticing the drop when the car if off, though. It'll start around 12.3, then slowly drop into the high 11's when scanning the car.

I feel like a battery issue would have presented itself more consistently by now, or at least the dealer would have indicated low voltage (LOL AT THE DEALER DOING THE RIGHT/COMPETENT THING HERE) but who TF knows.

Keep the thoughts coming. I hate this feeling, and it's making me hate the car at the moment.
 
Top