GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

What did you get in the mail or bring home for your MKVII today?

swcrow

Autocross Champion
Location
Virginia
Car(s)
7.5
Friggin pulled home a nail 😡
BDC5A385-A038-43F3-AB5A-9CBF7968AF01.jpeg

Discount tire, here I come
 

snobrdrdan

former GTI owner
You can buy them straight from Weathertech. Sometimes you can find them for less from 3rd party sellers.

ALTERNATIVELY....you can buy the VW parts "Muddy Buddy" floor liners....which are rebranded (for VW) WeatherTechs for less money from a VW discounted part site. For example:
https://www.bamwholesaleparts.com/oem-parts/volkswagen-muddybuddy-floor-liner-black-5g1061541dsp

That's not a dealer, but if it is/was....then you would also get the 15% mail in accessory rebate that's going on too!
 

Cuzoe

Autocross Champion
Location
Los Angeles
Let me know if you notice any heavy battery drain when using it please. It's the only thing holding me back on buying one.
Will do, probably looking at a couple weeks before I get to use it though. My MIB 2.5 (hacked unit) doesn't play well with Android Auto so I've ordered a new US spec one. Once I get it, and have all the activation/enablements done then I'll give AA wireless a try.
 

Acadia18

Autocross Champion
Location
Rhode Island
Car(s)
2016 GTI SE
Will do, probably looking at a couple weeks before I get to use it though. My MIB 2.5 (hacked unit) doesn't play well with Android Auto so I've ordered a new US spec one. Once I get it, and have all the activation/enablements done then I'll give AA wireless a try.

What issues do you have with it?
 

Cuzoe

Autocross Champion
Location
Los Angeles
Heavy battery drain chiming in. I'd imagine it's due to utilizing both cell and wifi data at once.
I'm curious to see how it goes. I recently picked up a Pixel 4a, wanted a small phone, and even though it has a correspondingly small battery I've been super impressed. Drive to Vegas, about 4 hours, Google maps navigating the entire time, streaming music for ~3 hours of that (small patches where service is poor, but poor service is normally worse for battery life) and I had 92% remaining when we got to the hotel. As with many phones the drop in percent won't be linear down to 0 but I've been comfortably using this phone for two days at a time without charging. I should also note for @Ghost GTI that my commute is less than 10 minutes and I rarely drive the car more than an hour at a time so my results may not give you much, haha.

What issues do you have with it?
I've done a lot of retrofits and I like them to be done as close to factory as possible. I had several issues, some unimportant, and some deal breakers really...
1) I didn't like that the unit didn't show up in scans unless you went into Green Engineering Menu and selected an option to allow diagnostics for the next 3 (or 10) power ups. I also didn't like that even when selected to show in diagnostic it had faults for incorrect coding and component protection. I know these aren't a big deal and on a hacked unit the component protection fault doesn't impact function, but I don't like seeing faults.

2) It's not a US spec unit although it was flashed to US software, so no SiriusXM... to be fair vendor told me XM might work... but it doesn't. The unit does not appear to have the hardware (XM receiver) or that hardware was broken somehow. I can select XM in the menu (US software) but I can't listen to the free preview channel or select Channel 0 to show me the XM ID if I wanted to subscribe.

3) On power-up it detects a fault for all speakers shorted to ground, which disables sound output. Through tedious troubleshooting I found that it only does this check at startup, like in the first 10 seconds. I have the Helix but I've had it for a while now, no issue on MIB I, MIB II non-nav or MIB II nav. I installed a time delay relay that switches the ground to the Helix ~20 seconds after receiving the power-on signal. Not a huge deal as it takes about that long for the system to be ready anyway (Bluetooth connected, maps pulled up, music chosen, etc.) but it's not an ideal solution. And without my background in electronics troubleshooting I'm not sure how I would have isolated and solved that problem.
- Since everything works fine if that fault is not detected on startup (because of my time delay relay) I'm confident there's no issue with my speakers/audio install. I don't know if the problem is poor isolation within the Helix, but vendor did say MIB 2.5 works fine in other cars with Helix (no reason it shouldn't). Or maybe my specific MIB 2.5 unit has an issue... who knows? But I don't like it.

4) Android Auto has never worked, for me, not once, ever with the MIB 2.5. It says it sees the phone and is available but when I go to start it repeatedly gives me connection failed faults and eventually goes back to the "available" screen. So the unit and the phone recognize each other but can't establish a good link. I know folks will say to check the cable, clean the port, etc....
- But this is what I did in troubleshooting: Re-flashed my phone (OnePlus 6T at the time to the stock ROM, ugghhh), no joy. Updated my previous phone to the latest software available for it (Android 10) and tried it, no joy. Tried the 4 cables I had on hand and bough a new one, no joy. Tried my sister's phone (Pixel 4) with her cable, which works for Android Auto in her car, a VW, no joy. Eventually got myself the Pixel 4a and tried, no joy. Used my Pixel 4a in my friends's Mk7 with my cable to make sure it was all good, it was.
- Keep in mind, I've been using Android Auto for 2+ years in my car, on multiple phones, using the same cable, across MIB II non-nav and then MIB II nav with no issue. In fact, when I installed the MIB 2.5 I didn't even unplug the cable I had been using earlier that day for Android Auto. But it didn't work on MIB 2.5. I even plugged the MIB II back in and verified the phone/cable combo was good.
- So I would say with 100% confidence the issue is with the MIB 2.5, again don't know if it's hardware or software but same-same as far as I'm concerned

5) Vendor did not provide the type of support I expected. I was given a person to contact on What's App and they were responsive for a couple days. From day one I had the problems with AndroidAuto and the speaker short to ground, and told them so. But once we were past the coding phase they stopped responding and left me out to dry. This vendor has long history, good reviews here and on other forums, so I do believe (hope) my experience was atypical, but it was absolute sh!t.
 
Top