GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

VW Golf 7 GTI 2014 Headlight programming / coding adaptations

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Hi,

I have a Golf 7 gti 2014 with bi xenon headlight reference 5G1941752 A (right) and 5G1941753 A (left) brand Valeo.

One of my headlights is correctly working but the other has an issue with the DRL.

The position light is working instead of the DRL light.

I think the issue is about coding because it seems that the headlight is brand new.

Does anyone can tell me coding adaptations to do? I have VCDS.

Thanks in advance.

BR.

(Sorry for my English I'm French).
 
Last edited:

golfdave

Autocross Champion
Location
Scotland (U.K.)
Car(s)
Mk7 Golf GT Estate
Best person to ask is @DV52
 

DV52

Drag Racing Champion
Location
Australia
Ok, thank you for your respons.

I'll contact him.
Thomas: Hi and thank you for the PM.

OK -before launching into solution-mode, my time-honored process for dealing with these matters is to get more information (because it minimizes incorrect assumptions -by me!).

So-let's start with a few questions (please answer ALL questions:
  1. Which car-side is the problematic headlight?
  2. Are the headlight fittings on both car sides the same - or is the problematic fitting NOT the factory installed headlight?
  3. Which diagnostic device do you use ?
  4. If you use OBDeleven - have you made a back-up of the 09 module? Or, if you use VCDS - have you made a "admap" of the 09 module?
  5. If answer to 4. above is "NO" - please create the file requested and include a copy in your next post
Don
 

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Hi Don, Thanks for your quick response.

1. See attached a picture of which car side is the problematic headlight. If I am in the car, it's the left head light. In the picture, I am in the position 0. If I change position in "side light" position or in "low beam" or "high beam" position, both drl are working with less intensity (normal way of working).
2. Yes headlights are the same with same reference.
3. I use VCDS.
4. Yesterday I've done an admap of all the 09 module. The file is a CSV. I converted it in Excel file.

See attached the 09 module admap (.zip).

Just to explain to you, I've past yesterday two hours to compare my 09 module with some others 09 modules that you have in your Excel file (that you've done to regroup a database of different Golf) and didn't find differences ...

See attached also the calculator information of my car.

Thanks in advance.

BR.
 

Attachments

  • adpmap-09-5Q0-937-084-AE.zip
    50.7 KB · Views: 37
  • IMG_8510.jpg
    IMG_8510.jpg
    2 MB · Views: 67
  • Screenshot 2023-08-17 074248.png
    Screenshot 2023-08-17 074248.png
    1.6 MB · Views: 66

DV52

Drag Racing Champion
Location
Australia
hmm......... I agree - the Leuchte-sets for the inside "angel eyes" on the headlights look OK.

Strange! Are there any errors on the SCAN report for this car?
What is the history of the car ?

Don
 

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
See attached a scan when I bought the car at 79894 km.

Here the detail for 09 module:

Adresse 09: Centrale Elec. (J519) Labels: 5Q0-937-08X-HV1.clb
No. pièce Log: 5Q0 937 084 AE Mat: 5Q0 937 084 AE
Pièce: BCM MQBAB H H16 0124
No. de série: 00011405301017
Codage: 00050A46C24122F30BA44080B11C07081800000000000000000000000000
No. Atelier: WSC 131071 1023 2097151
Jeu de données ASAM: EV_BCMCONTI 012001
ROD: EV_BCMBOSCH_AU37.rod
VCID: 7BF5A630F2F0FDE608-802E

Slave 1:
Sous-système 1 - No. pièce Log: 5G1 955 119 A Mat: 5G1 955 119 A Labels: 5QX-955-119-V1.CLB
Pièce: WWS 131218 042 0551
No. de série: 131221140146
Codage: 0E4DDD

Slave 2:
Sous-système 2 - No. pièce Log: 5Q0 955 547 Mat: 5Q0 955 547 Labels: 5Q0-955-547.CLB
Pièce: RLFS 024 0042
No. de série: Y13M12D27H22M09S06S7
Codage: 00A8DD

Sous-système 3 - No. pièce Log: 5Q0 951 172 Mat: 5Q0 951 172
Pièce: Sensor, DWA 005 0315
No. de série: 000000000ZY133361BJU

Sous-système 4 - No. pièce Log: 5Q0 951 605 Mat: 5Q0 951 605
Pièce: Sirene, DWA 004 0311
No. de série: 00000000000058437418

2 Codes défaut trouvés:

18698 - Module gauche de DEL pr feux de jour et position
B12EC F2 [008] - Alim coupure/court-circuit au pôle +
Intermittent - Confirmé - Testé depuis RàZ mémoire
Capture:
Etat du défaut: 00000001
Priorité du défaut: 2
Fréquence du défaut: 3
Compteur de RAZ: 184
Kilometrage: 76926 km
Date: 2021.10.01
Temps: 20:58:07


204290 - Clé avec radiocommande 1
B1479 18 [009] - Courant trop élevé
Confirmé - Testé depuis RàZ mémoire
Capture:
Etat du défaut: 00000001
Priorité du défaut: 4
Fréquence du défaut: 5
Compteur de RAZ: 143
Kilometrage: 76926 km
Date: 2021.09.24
Temps: 08:29:34


There was a fault for the left module DEL. See attached a picture to have it in English.

Just to explain to you, at this moment, when I bought the car, I did a first scan, I was a "noob" and didn't understand all these faults.
And by searching in the option in the multimedia screen (Discover) of the car, I've seen the option "Enable / Disable DRL", I've marked it and it's at this moment that I've seen that just the right DRL was working .... And when I bought the car I wasn't aware of this option.

Currently / Now I don't have fault when I am doing a scan (I can do one if you want to see). I was thinking, maybe it's because I always drive with the DRL disable so the fault never happens. I'll try to drive with DRL enable to see if the fault come again.

I know that I am the third owner. Always good maintenance but that's it.

Questions:
How is it possible that the side light (position light) is working instead of the DRL while the Leuchte-sets are good?!!
While in all other positions (low beam, high beam, etc. by the switch), the angel eyes (DRL) work correctly.
The led bar (U shape) for angel eyes (DRL) is the same led bar when changing position (by the switch), angel eyes (DRL) are just working at low intensity correct?
Is it possible that it's a wrong wiring?
Is it possible that it's a fault on the LED module? Is it using the same LED module between 0 position and light side / low beam / high beam positions? so there is just one LED module for all way of working?
Is it a security to light the side light if the DRL is not working?

I don't understand why in 0 position (on the switch), left DRL is not working and in any other position mode (light side / low beam / high beam) both DRL are working ..


Like I said in my first message, the left head light seems brand new compared to the right headlight, so I think it has been replaced (I bought the car like this).

I look forward to your response and hope we will find the solution together.

Thanks in advance.

BR.
 

Attachments

  • Log-WVWZZZAUZEW260490-79894km.zip
    4.8 KB · Views: 22
  • thumbnail_IMG_8522.jpg
    thumbnail_IMG_8522.jpg
    140 KB · Views: 29
Last edited:

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Here some pictures (3 first pictures) in side light mode (position light). The side light (position light) and the angel eyes (DRL) are working.

Also some pictures in low beam / high beam position. All is working well.

But in 0 position, the left side light (position light) is working instead the angel eyes (DRL).

BR.
 

Attachments

  • IMG_8533.jpg
    IMG_8533.jpg
    3 MB · Views: 27
  • IMG_8532.jpg
    IMG_8532.jpg
    3.4 MB · Views: 34
  • IMG_8536.jpg
    IMG_8536.jpg
    2.6 MB · Views: 29
  • IMG_8537.jpg
    IMG_8537.jpg
    2.8 MB · Views: 34
  • Capture.JPG
    Capture.JPG
    495.5 KB · Views: 35

DV52

Drag Racing Champion
Location
Australia
BR. OK........... your latest post contains new information (which is good)

My hunch is that the problem with this car is NOT a coding issue!!

I'm not sure that the fault will reappear when you re-activate the DRL function on the "multimedia screen" (let's call this the MIB)

This is the fault in English:
18698 - Left LED module for daytime running lights and parking lights
B12EC F2 [008] - Supply cut/short circuit to the + pole
Intermittent - Confirmed - Tested since memory reset
Capture:
Fault Status: 00000001
Fault priority: 2
Fault frequency: 3
Reset counter: 184
Mileage: 76926 km
Date: 2021.10.01
Time: 20:58:07

Look at the date - it's a long-time ago!!. Also notice that Fault Frequency =3 - this means that in the period from the fault Date to the date of your scan, the fault has re-occurred on only 3 occasions in a subsequent ignition cycle. This seems like a very old fault that has simply not been previously cleared - maybe? Nevertheless, the fault does also suggest that the left side headlight might be new!

Everything that you have said thus far (including your observation about "brand new" appearance of the left-side headlight fitting) suggests that this is either a wiring, or connector problem (assuming that the new left-side headlight is compatible - read my final paragraph below).

If this was my car - I would stop looking for a coding solution and I would instead investigate the apparent new headlight.

Look at the 14 x pin connector on the left-side headlight (again compare with the right-side fitting) - are there any obvious wiring modifications, or loose connections maybe?

The "Left LED module for daytime running lights and parking lights" is called J860 in the wiring diagram. If the error does reappear - here is it's location on the headlight housing:



Again, if the error reappears - a trick that can be used to test if the module is faulty is to swap the left-side and right-side LED modules. If the fault characteristics follow the swapped module - it's faulty

Finally - You said in your first post "I have a Golf 7 gti 2014 with bi xenon headlight reference 5G1941752 A (right) and 5G1941753 A (left) brand Valeo".

Notwithstanding my suggestions above, I suspect that the (new) left-side headlight fitting isn't correct for this car? If you look HERE -it seems that the equivalent left side fitting for 5G1941752 is 5G1941751. And If you look HERE, it appears that the mating component for 5G1941753 is 5G1941754. I've not done an extensive investigation - but I suggest that your consider this to be the actual cause of this problem and research this possibilty further
Don
 
Last edited:

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Thank you for your response Don.

Ok, I will try to check the wiring and swap LED module to be sure.

For information, I find explanations on a French Golf 7 forum, on the website ETKA (official spare parts catalog for the Volkswagen Group), it saids that reference 5G1 941 752 (right) has been replaced by 5G1 941 754 and that the reference 5G1 941 751 (left) has been replaced by 5G1 941 753.

5G1 941 752 (right) / 5G1 941 751 (left) => Old references, no longer available

5G1 941 754 (right) / 5G1 941 753 (left) => New references, last recent

So all is logical, on my car, the right head light is original with the first reference 5G1 941 752, it has never been replaced.
And the left head light has been replaced by the last recent part with reference 5G1 941 753.


I'll keep you informed. But if we are sure that it's not a coding problem, so it's a wiring or LED module problem.

BR.
 
Last edited:

ZERO815

Autocross Champion
Location
Köln Germany
Car(s)
2017 GTI SE DSG
To my knowledge left 751 and 753 [right 752 and 754] are interchangeable.

I don't think a wiring issue is reasonable here, since the same light channels are used for parking lights and DRL. As Don mentioned the module swap should tell you if the fault moves w/ the module.

On retrofits I've seen that sometimes changes to light channels coding are shown in obedeleven or VCDS as accepted, however they don't work. I know the likelyhood is low but you might want to re-code some lines as a test first:

- (4)-Leuchte2SL VLB10-Lichtfunktion A 2 set it to "not active" and then to "Feux de jour" again
- (4)-Leuchte4TFL LB4-Lichtfunktion A 4 set it to "not active" and then to "Feux de jour" again

Why does the little dot illuminate during DRL operation? It's a shot in the dark, maybe this is a replacement function that is hard coded to the J860 module as a safety function if the angle eye doesn't work. (On older BMWs you see that the turn signal bulbs light up in dimmed mode if the parkling light doesn't work on that side.) If that explains your fault it's mostlikely a bad J860 module. Swapping should show that easily.

Your little dot "Leuchte8" isn't coded as Feux de jour.
 

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Hi ZERO815, thanks for your response.

Ok, I will try to swap LED module to see if I have the same issue.

And try also to do the "coding" that you've send me.

I think you're right, it's a safety function.

I'll keep you informed.

BR.
 

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
I tried the coding « not active » then « Feux de jour » but nothing changes.

I will be in holiday for a period in France, so I will do the LED module swap between right and left at my come back.

I'll keep you informed of the result.

BR.
 

Toto-costaud

New member
Location
France
Car(s)
VW Golf 7 GTI 2014
Hi,

I’ve changed the LED DRL module of my left headlight, issue is always here.

I’ve swapped all headlight and the issue is always on the left side so it’s a wiring issue… always the side light (position light) and not the drl light.
See attached all pictures to correctly understand.

Could you help me ?

Thanks in advance.

BR.
 

Attachments

  • 368575186_852635813272851_1633915832473193810_n.jpg
    368575186_852635813272851_1633915832473193810_n.jpg
    392.5 KB · Views: 27
  • 370139642_658774879468797_7838699882429272275_n.jpg
    370139642_658774879468797_7838699882429272275_n.jpg
    362.2 KB · Views: 20
  • 370058113_326179793490386_4241924918229536510_n.jpg
    370058113_326179793490386_4241924918229536510_n.jpg
    414.9 KB · Views: 20
  • 370268658_871649714639930_3939391756913991620_n.jpg
    370268658_871649714639930_3939391756913991620_n.jpg
    420.3 KB · Views: 23
  • 367344972_395208829507579_1235479400421129957_n.jpg
    367344972_395208829507579_1235479400421129957_n.jpg
    450.6 KB · Views: 21
  • 370090522_2007257916317154_8153663395705967832_n.jpg
    370090522_2007257916317154_8153663395705967832_n.jpg
    392 KB · Views: 22
  • 368399305_356511490264684_3611645754334550083_n.jpg
    368399305_356511490264684_3611645754334550083_n.jpg
    587.6 KB · Views: 28

ZERO815

Autocross Champion
Location
Köln Germany
Car(s)
2017 GTI SE DSG
I would check GND wire in Pin7, and wires Pin10 = BCM B10 / Pin12 = BCM B04 of "J860 Left Daytime Running Lamp and Position Lamp Control Module". Continuity check w/ multimeter might not be enough. If multiple strands of one wire are really broken I would use a 21w halogen bulb and 12V battery to test the wire itself.
 
Top