GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

vland mk7.5 Sequential taillight

dtfd

Autocross Champion
Location
Massachusetts
Car(s)
MK7.5 GTI
Has anyone successfully installed one of these ZZ lights with the start-up animation?

https://www.aliexpress.us/item/3256802488967130.html

I'm somewhat interested but I have no idea what is going to be necessary to get it working correctly.

If they're ROW would a normal USDM 7.5 to ROW 7.5 convertor work or should I ask them specifically for their pin out on the 7.5 lights and try to get someone to create that for me to work with my 7.5? In terms of coding is it safe to assume the same coding for euro lights will work here since they don't mention needing to change coding if you're already ROW?
 

bbroecker37

Ready to race!
Location
Tampa Florida
Car(s)
2016 VW Golf GTI
I have the BMP replica taillights and I was also having issues. Also disappointed about the fitment as well but that's beside the point. I followed the BMP coding instructions exactly and used the harness that was included but the brake light squares stay on when the headlights are on. They do get brighter when the brake pedal is pressed but it's not operating how it should. The dimming values are set up correctly according to BMPs coding instructions. 100 for the brake light and 10 for the tail light.

I ended up cutting up the harness and wiring it like so.

Left Outer:
Pin 1: Coded BR20 as a Brake light with no other functions (Dimming value 100)
Pin 2: Ground
Pin 3: Left Turn signal - ran a wire from the inner taillight
Pin 4: Coded C6 as a Taillight (Dimming value set to 10)

Right Outer:
Pin 1: Coded BR21 as a Brake light with no other functions (Dimming value 100)
Pin 2: Ground
Pin 3: Right Turn signal - ran a wire from the inner taillight
Pin 4: This pin is also part of C6

The tail lights operate exactly like the euro tail lights but now when the headlights are off and the brake pedal is pressed. The tails flash for a split second before the brake light turns on. Doesn't happen when the headlights are on since the tails are already lit. I've been running the taillights like this for a while now but it's been bugging me. I'm going to try and use the guide in post 14 to see if this "Glitch" goes away.

Also, I think there is some weird stuff going on inside the taillights (like an IC that is controlling relays). For example, I was experimenting with my left taillight. I was making the changes under BR20. I tried to make the left brake light flash with the turn signal (to get the Audi turn signal). I got it to work but I noticed the taillight on the other side flashes. Keep in mind that it's supposed to be wired up to C6. I think it's back feeding through C6 from the left to the right. Could be the cause of the "Glitch"
 

EpicTech

Autocross Champion
Location
Houston
Car(s)
MK7 GTI 6sp w/PP
I have the BMP replica taillights and I was also having issues. Also disappointed about the fitment as well but that's beside the point. I followed the BMP coding instructions exactly and used the harness that was included but the brake light squares stay on when the headlights are on. They do get brighter when the brake pedal is pressed but it's not operating how it should. The dimming values are set up correctly according to BMPs coding instructions. 100 for the brake light and 10 for the tail light.

I ended up cutting up the harness and wiring it like so.

Left Outer:
Pin 1: Coded BR20 as a Brake light with no other functions (Dimming value 100)
Pin 2: Ground
Pin 3: Left Turn signal - ran a wire from the inner taillight
Pin 4: Coded C6 as a Taillight (Dimming value set to 10)

Right Outer:
Pin 1: Coded BR21 as a Brake light with no other functions (Dimming value 100)
Pin 2: Ground
Pin 3: Right Turn signal - ran a wire from the inner taillight
Pin 4: This pin is also part of C6

The tail lights operate exactly like the euro tail lights but now when the headlights are off and the brake pedal is pressed. The tails flash for a split second before the brake light turns on. Doesn't happen when the headlights are on since the tails are already lit. I've been running the taillights like this for a while now but it's been bugging me. I'm going to try and use the guide in post 14 to see if this "Glitch" goes away.

Also, I think there is some weird stuff going on inside the taillights (like an IC that is controlling relays). For example, I was experimenting with my left taillight. I was making the changes under BR20. I tried to make the left brake light flash with the turn signal (to get the Audi turn signal). I got it to work but I noticed the taillight on the other side flashes. Keep in mind that it's supposed to be wired up to C6. I think it's back feeding through C6 from the left to the right. Could be the cause of the "Glitch"
Man I feel your pain. Been talking to Zero about this. I hate the brake light portion lights up regardless of headlight switch position. My inner assemblies also light up with brake pedal. Uggh !!
 

7umberjackZac

Go Kart Newbie
Location
Pittsburgh, PA
Car(s)
Gti
Has anyone successfully installed one of these ZZ lights with the start-up animation?

https://www.aliexpress.us/item/3256802488967130.html

I'm somewhat interested but I have no idea what is going to be necessary to get it working correctly.

If they're ROW would a normal USDM 7.5 to ROW 7.5 convertor work or should I ask them specifically for their pin out on the 7.5 lights and try to get someone to create that for me to work with my 7.5? In terms of coding is it safe to assume the same coding for euro lights will work here since they don't mention needing to change coding if you're already ROW?
NAR and my AKD 7.5s are just about setup but I have the brake light delay when lights are off😕... Also my wiring needs corrected for RVC.

https://youtube.com/shorts/3T3xCeE5R68?feature=share
 

EpicTech

Autocross Champion
Location
Houston
Car(s)
MK7 GTI 6sp w/PP

Diopena1

New member
Location
Orlando Florida
Car(s)
2016 GTI
I have to tip my hat, and extend thanks to ZERO815.
I bought Vland tail lights on Amazon, and of course they claim it to be “plug and play”- which they are, except for the sequential lights…
I followed this man’s diagram to the T, and as uncomfortable as it felt, once I got the hang of the programming, it went pretty quick using OBDEleven pro.

Trust me when I say that this worked… I’m on a 2016 GTI S, which came with all halogens….. so if it worked for me, it should work for most, and yes, ZERO815 has made comments on the variances for the MK7 (seems like the earlier 2014-15 models have different parameters).
 

EpicTech

Autocross Champion
Location
Houston
Car(s)
MK7 GTI 6sp w/PP
I have to tip my hat, and extend thanks to ZERO815.
I bought Vland tail lights on Amazon, and of course they claim it to be “plug and play”- which they are, except for the sequential lights…
I followed this man’s diagram to the T, and as uncomfortable as it felt, once I got the hang of the programming, it went pretty quick using OBDEleven pro.

Trust me when I say that this worked… I’m on a 2016 GTI S, which came with all halogens….. so if it worked for me, it should work for most, and yes, ZERO815 has made comments on the variances for the MK7 (seems like the earlier 2014-15 models have different parameters).
I bought same tailights and he helped me as well. Mad respect.
 

bbroecker37

Ready to race!
Location
Tampa Florida
Car(s)
2016 VW Golf GTI
Hey guys, I had a lot of issues with the BMP taillights that I decided to sell them. I guess the quality was not up to my standards. The janky way you have to wire them up didn’t sit well with me so I decided to go OEM. I ordered a set of 7.5 facelift taillights from the UK for a good price. Wired them up the OEM way by running wires from the BCM to the back of the car. I removed the pins from the stock connectors and reinstalled them in the 7.5 connector housing. I basically just made my own harness and wrapped it in Tesa tape for a OEM look. I found the code for the 7.5 taillights in Europe and just copied it and applied it to my car. Everything is working perfectly and the light output from these taillights is much better. Turn signal has a smooth transition.
 

username205

Ready to race!
Location
GA
Thanks @ZERO815 for the detailed guide! I grabbed the Vland tail lights for just under $200 and did not have to purchase an additional harness to get these working in my 2017 Sport - just followed ZERO815's guide to swap pins and ran an additional wire to link the reverse lights together. I spent about 4hrs total, and removing panels to properly hide wires took much longer than the actual installation/coding. They look so much better than the halogen housings and are quite a bit brighter (i.e. safer) as well!
 

Attachments

  • IMG_3894.jpeg
    IMG_3894.jpeg
    1.1 MB · Views: 55
Last edited:

EpicTech

Autocross Champion
Location
Houston
Car(s)
MK7 GTI 6sp w/PP
Thanks @ZERO815 for the detailed guide! I grabbed the Vland tail lights for just under $200 and did not have to purchase an additional harness to get these working in my 2017 Sport - just followed ZERO815's guide to swap pins and ran an additional wire to link the reverse lights together. I spent about 4hrs total, and removing panels to properly hide wires took much longer than the actual installation/coding. They look so much better than the halogen housings and are quite a bit brighter (i.e. safer) as well!

View attachment 296853
Can you show a picture with them lit up please? I have the VLands as well.
 

username205

Ready to race!
Location
GA
Can you show a picture with them lit up please? I have the VLands as well.
1. Off
2. Brakes
3. Reverse
4. Turn
5. Running
6. Running + brakes
7. Running + brakes + turn
 

Attachments

  • IMG_3904.jpeg
    IMG_3904.jpeg
    1.2 MB · Views: 53
  • IMG_3905.jpeg
    2.4 MB · Views: 34
  • IMG_3906.jpeg
    IMG_3906.jpeg
    1.2 MB · Views: 62
  • IMG_3907.jpeg
    IMG_3907.jpeg
    1.1 MB · Views: 47
  • IMG_3908.jpeg
    IMG_3908.jpeg
    1.2 MB · Views: 56
  • IMG_3909.jpeg
    IMG_3909.jpeg
    1.2 MB · Views: 51
  • IMG_3910.jpeg
    IMG_3910.jpeg
    1.2 MB · Views: 70
Last edited:

Frag

New member
Location
Tennessee
Car(s)
2016 MK7 GTI
I've got a 2016 gti. Installed the tail lights today with the usp/rfb harness. It seems like everything is working except for the passenger tail inner and outer turn signals. Any ideas?
 

EpicTech

Autocross Champion
Location
Houston
Car(s)
MK7 GTI 6sp w/PP
I've got a 2016 gti. Installed the tail lights today with the usp/rfb harness. It seems like everything is working except for the passenger tail inner and outer turn signals. Any ideas?
check your harness and coding
 

CO_MK7R

New member
Location
Colorado
Car(s)
Mk7 R
What is everyone using for the jumper/repair wire? It’s listed as the yellow wire, part number 000979025E . VW sells it for $55 but I wasn’t sure if others were making this wire manually? Trying to avoid spending that much $ if possible.
 
Top