GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

vland mk7.5 Sequential taillight

Canecreekfreak

New member
Location
Boston
Car(s)
MK7 GTI sport
Thanks for posting all the info here y'all! Just got the vland tails delivered today, and was a little lost on what to do next. This post is a huge help, so thanks again!!!
 

Canecreekfreak

New member
Location
Boston
Car(s)
MK7 GTI sport
Hi All- I finally got the harness from Amazon, and got around to wiring up my VLand tails. All the lights are working now, but not really in the fashion that they should be. I first did the OBD11 "DAP wiring harness" coding, and that wasn't quite right. Then I used the instructions from post #5 on this thread, and that got me even closer, but not right. So I tried all the coding from the 4 page attachment from post #14, and that royally messed everything up. LOL. So I back-tracked those changes, and did the 15 changes from post #5 again, and that has me to the point as seen in the linked video below.

Basically, 1- the inner lights are working as brake lights, which I actually don't mind, even though it's not correct. And
2- the outer brake lights are always the brake lights, they just get brighter and dimmer. They don't do the change from the running lights to brake lights as they're supposed to. They actually did that before I did any coding, which is kinda funny.

So can anyone help me with the coding changes I need to make to get these 2 situations working correctly? More interested in fixing #2, but doing both would be nice. It's on a US 2017 VW GTI.

Thanks in advance!! -Lee
Link:
My tail lights aren't working correctly
 
Last edited:

ZERO815

Drag Racing Champion
Location
Köln Germany
Car(s)
2017 GTI SE DSG
I apologize if this sounds rude to you but here are your 2 issues:

1. "Amazon - Product description: Brand new adapter harnesses for the MK7 Golf/GTI Euro LED taillights! Give your vehicle amber turn signals and inner taillights with functioning brake/signal lights! Made with automotive grade wiring and OEM connectors! Comes with pre-labeled wires! Harnesses are Plug & Play, but coding with VCDS will be required for proper function! This listing is for (4) wiring harnesses only!"

Plug & Play but coding required for proper function, and it even comes w/o coding list? Unless you know what you are doing, how can you even send money to these guys?

2. Coding is always specific to the harness and application (lights, vehicle,...). IMO you should never use any OBDeleven apps. The general idea of apps isn't bad, but I've seen to many minor MY changes from the factory in the coding. If that's the case w/ your vehicle you're out of control.

Let's go back to topic. What are the current vehicle coding values for:
1. Leuchte20BR LA71-Dimmwert EF 20
2. Leuchte21BR RC8-Dimmwert EF 21 ?

I guess they are at 28 ish? Set them to 10 instead and report back.
 

Canecreekfreak

New member
Location
Boston
Car(s)
MK7 GTI sport
Hi Zero815- no offense taken- I'm happy that you replied and offered to help! I know I went the cheap route, and am obviously paying for it now. Another person said they went this route and it worked for them, so I thought I'd give it a shot.

Both of those Dimmwert EF's are currently set at 10. Here's pics of all the setting for Leuchte20/21/23/24... Hopefully it can explain why the inner lights are working as brake lights, which I actually don't mind, even though it's not correct.
And the outer brake lights are always the brake lights, they just get brighter and dimmer. They don't do the change from the running lights to brake lights as they're supposed to, and did before any wiring/coding.

Thanks again for offering to help.


Current Tail Settings 20BR small.jpg
Current Tail Settings 21 BR small.jpg
Current Tail Settings 23SL small.jpg
Current Tail Settings 24 SL small.jpg
 

ZERO815

Drag Racing Champion
Location
Köln Germany
Car(s)
2017 GTI SE DSG
Lee,
Thanks for sharing the coding of 20/21/23/24. I might be blind but I don't see an obvious mistake in 20/21. Because 23/24 activate the turn signals correctly there is almost only one suspicious light channel left: Leuchte27. Depending on the harness you've got it might be causing the issue. Search for "Leuchte27NSL RC6-Lichtfunktion A 27" and set it from "Standlicht..." to "not active".
 

Canecreekfreak

New member
Location
Boston
Car(s)
MK7 GTI sport
Ok, flipped that setting and it seems to have had no effect. Attached are the other settings for 27/28/29 (before I made the change to 27/A27/Not aktiv). And thanks again for your help!
 

Attachments

  • OBD 27 ALL.jpg
    OBD 27 ALL.jpg
    120.3 KB · Views: 12
  • OBD 28 ALL.jpg
    OBD 28 ALL.jpg
    120.6 KB · Views: 12
  • OBD 29 ALL.jpg
    OBD 29 ALL.jpg
    126 KB · Views: 11

ZERO815

Drag Racing Champion
Location
Köln Germany
Car(s)
2017 GTI SE DSG
You mentioned brake light and running light switching worked before you started wiring/coding. Does that include the new tail lights?

To my knowledge these tails come with some wiring between inner and outer tails. Did you install these wires and the harness? Harness should be enough IMO.

If I were in your shoes I would do the following:
1. Unplug the harness, revert coding back to factory, plug factory plugs into factory lights and confirm they work as NA MK7 halogen tails (shared brake/running/turn)
2. Replace factory tails with your new lights. Do they function as the factory tails (don‘t expect the amber turn signals to work)?
3. Plug the harness back in, no coding. What happens? I expect the tails to work as in 2. except for the amber section. It should turn on solid with running lights on.
4. If 3. = true change coding and you are good to go. Else: Something is wrong with the harness.
 

Canecreekfreak

New member
Location
Boston
Car(s)
MK7 GTI sport
Finally got around to checking things out, and the harness I got has wires going from inside to outside, weird splices, and all sorts of seemingly unnecessary changes. I printed out the attachment from post #14 in this thread which has instructions from Zero815 where you re-pin a drivers inner light, an outer passenger light, and remove one of the wires going to the outer drivers light. It had some coding instructions that went along with it, and that did the trick. Everything works as is should, after running a jumper wire from the inner passenger reverse light to the inner drivers side. So basically the harness was a waste of money as you don't need it to get the VLand lights working properly.

Shout out to Zero815 for answering posts on this thread, as well as having those other instructions available. :)(y)
 
Last edited:
Top