GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Turbo Acting Up...

tm978275

New member
Location
Boston
VWVortex ForumsIssues with heavy acceleration
Forum Home
VW Model-Specific Forums
Golf/GTI VII

tm978275
online

2h ago - #1
Issues with heavy acceleration

Hi, I need some advice on troubleshooting an issue I've been running into with my turbo under heavy acceleration. Basically, once I hit about 3k rpm the turbo doesn't spool smoothly, more often than not it makes this sputtering sound and definitely doesn't put out the same power it did before this issue arose. Seems to only happen in gears 3-6. The car isn't throwing any codes. Anyone ran into this issue before?

Only mods to the vehicle is a Neuspeed power module and an Injen cold air intake...car has about 15k on it, all maintenance up to date.

Any advice would be appreciated.
 

0bLiViOuS

Go Kart Champion
Location
Orange County
Sputtering sound? Does it sound like it's dumping boost? Easiest thing to do is remove NPM and intake and take it to the dealer.

Edit - can you take a sound clip or video of it?
 

Ton

Ready to race!
Location
U.S.
VWVortex ForumsIssues with heavy acceleration
Forum Home
VW Model-Specific Forums
Golf/GTI VII

tm978275
online

2h ago - #1
Issues with heavy acceleration

Hi, I need some advice on troubleshooting an issue I've been running into with my turbo under heavy acceleration. Basically, once I hit about 3k rpm the turbo doesn't spool smoothly, more often than not it makes this sputtering sound and definitely doesn't put out the same power it did before this issue arose. Seems to only happen in gears 3-6. The car isn't throwing any codes. Anyone ran into this issue before?

Only mods to the vehicle is a Neuspeed power module and an Injen cold air intake...car has about 15k on it, all maintenance up to date.

Any advice would be appreciated.
Some questions:
-how hot is it outside?
-Is the Injen intake open or closed type?
-Are you sure you have a good tank of gas?

First I would bypass the nuespeed power module and see how it runs. If you have a tank of 87 octane and it's also hot outside, the car will run terribly with the extra boost from the power module.

An acecdote. I had an ecoboost mustang as a rental car a few weeks back. It was 93 degrees all week and at full throttle you could feel the car struggling. Surging, pulling boost and timing. At about middle week the tank was empty and I filled it up with 93. It was a different car after that.

Being a rental, the likelihood it was filled with 87 octane was high I'm sure.
 

greggles

Go Kart Champion
Location
usa
+1 Ton.

If it is an injen SP intake, your boost temp is spiking to ridiculous levels. Remove it asap and put the stock intake back on.

If it is an evo intake, it might be so hot that the ecu is raising boost to hit your torque target, and running into issues with boost being that high (pulling timing like woah). Solution is to reduce the boost increase (don't know if NPM can do that), remove the NPM, or upgrade the intercooler.
 

FROSTYmk7.5

Passed Driver's Ed
Location
Denver Colorado
VWVortex ForumsIssues with heavy acceleration
Forum Home
VW Model-Specific Forums
Golf/GTI VII

tm978275
online

2h ago - #1
Issues with heavy acceleration

Hi, I need some advice on troubleshooting an issue I've been running into with my turbo under heavy acceleration. Basically, once I hit about 3k rpm the turbo doesn't spool smoothly, more often than not it makes this sputtering sound and definitely doesn't put out the same power it did before this issue arose. Seems to only happen in gears 3-6. The car isn't throwing any codes. Anyone ran into this issue before?

Only mods to the vehicle is a Neuspeed power module and an Injen cold air intake...car has about 15k on it, all maintenance up to date.

Any advice would be appreciated.
Did you ever figure this out? My car has been doing the same thing but only when it’s hot out
 

FROSTYmk7.5

Passed Driver's Ed
Location
Denver Colorado
He was last seen in the forum in March of 2018.
well darn. thanks for letting me know, and if you don't mind me asking for your opinion I have a question. I have been having the same issue with compressor surge, and I am starting to think it is because I live a 5,900 ft above sea level. The issue is also much more persistent during hot summer days. Do you think an intercooler would be a good option to have more consistent performance? and do you have any recommendations for a direct fit aftermarket intercooler for mk7/mk7.5? It is still stock tune btw
 
Top