GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Retrofitting Lane assist camera without changing windshield?

xabhax

Drag Racing Champion
Location
Manchester Township, New Jersey
Car(s)
15 GTI
Nope nevermind that, you gotta have something coded in A5 wrong. Status shows operational so the major work is done. Go bit by bit and check everything and make sure there isnt anything out of place
 
Last edited:

gjburg2

New member
Location
Netherlands
Car(s)
Skoda Karoq
Hi all i've browsed many website including all 63 pages of this interesting post..

And I'm trying to retrofit the A5 camera in my Karoq which almost succeeded. The coding went correct, mounted the camera on my rearview mirror and succeeded to calibrate. However, I've got now C1106 Limit Exceeded of the Dynamic Calibration
My dynamic pitch was 1.1 during calibration but after 5 minutes driving 3.008. All other dynamic angles are below 1.0 so I read somewhere in the forums that it must below 2.5 and this is cousing the error probably.

My camera is pretty high at 1.40m instead of A4, Golf etc but the Tiguan and T-Cross are also a around 1.4m, and I put the center of the black dots from the calibration board also on 1.4m.
Is there someone who can help me pointing in the right direction what the center height must be on a higher cars because all documentation is pointing to 1.20 or 1.25m. Do I have to put the board arond 1.4m or do I have to point the camera aggle a bit down?

Dynamic Yaw = -0.475
Dynamic Pitch 3.008
Dynamic Roll 0.000

Regards
Gert
 
Last edited:

Cuzoe

Autocross Champion
Location
Los Angeles
This is a guess, but I would try to point it down a bit, keeping in mind it needs to pick up the lines in front of you. You want it to see some way down the road but not out into the horizon. Being able to "see" the lines closer to the car is important.
 

Reaper1

Go Kart Newbie
Location
.
Hi all i've browsed many website including all 63 pages of this interesting post..

And I'm trying to retrofit the A5 camera in my Karoq which almost succeeded. The coding went correct, mounted the camera on my rearview mirror and succeeded to calibrate. However, I've got now C1106 Limit Exceeded of the Dynamic Calibration
My dynamic pitch was 1.1 during calibration but after 5 minutes driving 3.008. All other dynamic angles are below 1.0 so I read somewhere in the forums that it must below 2.5 and this is cousing the error probably.

My camera is pretty high at 1.40m instead of A4, Golf etc but the Tiguan and T-Cross are also a aroung 1.4m, and I put the center of the blackdots from the calibration board also on 1.4m.
Is there someone who can help me pointing in the right direction what the center height must be on a higher cars because all documentation is pointing to 1.20 or 1.25m. Do I have to put the board arond 1.4m or do I have to point the camera aggle a bit down?

Dynamic Yaw = -0.475
Dynamic Pitch 3.008
Dynamic Roll 0.000

Regards
Gert
Hey, only problem Is your camera Isn't aligned properly, as you can see it calculated yaw offset and then pitch, but pitch has exceeded the limit so it wont even calculate the roll offset.

The board should stay In the Default position no matter what, you should only change things on your car that aren't right, If the camera was too high it wouldn't let you even calibrate, you just need to realign it.
 

gjburg2

New member
Location
Netherlands
Car(s)
Skoda Karoq
Hey, only problem Is your camera Isn't aligned properly, as you can see it calculated yaw offset and then pitch, but pitch has exceeded the limit so it wont even calculate the roll offset.

The board should stay In the Default position no matter what, you should only change things on your car that aren't right, If the camera was too high it wouldn't let you even calibrate, you just need to realign it.

Thanks both, I will move the mounting of the lens a little bit down next week and redo the calibration, but one thing is still not clear for me.
Should the default position of the board match the lens height, or should this be always be centered at 1.25m?
 

Camarao69

Passed Driver's Ed
Location
Portugal
Hello 3 years after this retrofit my camera is not working, i have a camera malfunction error C110400, my camera is original (it has the original flat cable and was not chopped) . the strange thing is if i delete the error and not turn off the car it works flawless. Every time i start the car i have a error : dynamic road sign display.
do you guys think it might be the flat cable inside ?
 

Reaper1

Go Kart Newbie
Location
.
I would think the board shouldn't move. It basically simulates the road, which is where you want your camera pointed.
yes, very important, the board is the base for the camera, the dimensions of the board are made to be in a specific position from the car.

only adjust the camera, the camera will calculate its real height once dynamic calibration starts, if its too much it will fail.
 

Reaper1

Go Kart Newbie
Location
.
Hello 3 years after this retrofit my camera is not working, i have a camera malfunction error C110400, my camera is original (it has the original flat cable and was not chopped) . the strange thing is if i delete the error and not turn off the car it works flawless. Every time i start the car i have a error : dynamic road sign display.
do you guys think it might be the flat cable inside ?
Happened to me when I replaced the camera, ribbon cable was off by a tiny bit and nothing worked, needed to align it with a magnifying glass.

Dynamic road sign display error will be common if you don't have NAV, camera is looking for signs from NAV too but it is not installed, maybe your coding isn't right.
 

Camarao69

Passed Driver's Ed
Location
Portugal
It has been working since 2020 and i had no errors, it´s faulty probably i will have to replace it with another one. when i installed it i didn´t have nav but no errors either back then.Thinking about it my nav gps position has been failing more lately (I´m always off road).
 

dawcioral

New member
Location
PL
Car(s)
MK7.5
Nope nevermind that, you gotta have something coded in A5 wrong. Status shows operational so the major work is done. Go bit by bit and check everything and make sure there isnt anything out of place
Could you please share your coding with me so i can compare it? I don't know how else to check it, because I don't have descriptions of individual bits in ODB11.
 

xabhax

Drag Racing Champion
Location
Manchester Township, New Jersey
Car(s)
15 GTI
00030700000902010022225480418100D7000E00002000
 

gjburg2

New member
Location
Netherlands
Car(s)
Skoda Karoq
Hi,

I ‘ve calibrated the camera again (twice this week to see if there are differences) and both calibrations with the board centered at 1,20m.
This went fine and no errors, yaw, pitch, roll are below 0.9 after calibraition the A5 has no errors,

Other than the previous calibrations where the "exceed limit" appeared within 10km driving, the dynamic calibration still shows "No Values Stored" after more than 100km driving.
"Dynamic calibration: details Passive: no values stored"

I've driven with the laptop connected and the Dynamics calibration shows sometimes Active for a few minutes, but the Dynamic Calibration Distance is still 0km after many days and km's driving.
Anyone knows what I'm doing wrong?

See values in the attachments
 

Attachments

  • 66FCF245-ECC1-4825-B205-07330BACDD80.jpeg
    66FCF245-ECC1-4825-B205-07330BACDD80.jpeg
    2.2 MB · Views: 90
  • 7E2255BC-B3D4-4CFD-B66D-E2C3C5FF1551.jpeg
    7E2255BC-B3D4-4CFD-B66D-E2C3C5FF1551.jpeg
    3.8 MB · Views: 93
Last edited:

Camarao69

Passed Driver's Ed
Location
Portugal
View attachment 176034
Ok, now i have every thing working.
Obd11 calibration:
1 place VAS6430 in wall 1,30m (from floor to black center dots)
2 put car 1,5m away from board (from wall to the center of wheel ,measure in the floor .
3 measure 4 wheel arches .

All the next steps change search calibration target to Grundeinstellung

SEQUENCE IS IMPORTANT
OBD11:
4 - go to module A5 change type of diagnostic to vw
5 -go adaptation distance to calibration field 1500m confirm
6 -go adaptation body height wheel house edge
Type your measurments confirm
7 -go adaptation calibration target position
Just confirm
8 - go adaptation axel offset
Just confirm

9 - go basic configuration search calibration target

10 - go basic configuration initial online configuration

11 - go basic configuration Static calibration costumer service

12- change type of diagnostic to end of assembly line

13 - go basic configuration static calibration end of assembly line
O have to say this works flawless the only thing i forgot o mention is the position of the board has to be 1,30 from floor to center black dots.
Just replaced my broken camera today that had the malfunction error.
 
Top