GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Retrofitting Lane assist camera without changing windshield?

Sn00ky

Passed Driver's Ed
Location
Amsterdam
Car(s)
MK7 variant DSG
Thank you for your support...

But what is the malfunction camera due to? Since with obdeleven I have difficulty accessing the camera and carrying out a normal screening and dialogue ...
You probably flipped the flat wire, check the flatwire
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
You probably flipped the flat wire, check the flatwire
Sarei felice che fosse così .... ma la fotocamera è ancora nella sua custodia di metallo ... potrebbe essere difettosa di fabbrica ?? Sono stato costretto ad acquistare un'altra...
I was forced to buy another ...To try and verify. I hope it arrives soon. 😥
 

Luiz Henrique

Passed Driver's Ed
Location
Brasil
Good night in Brazil, what are the flaws that are appearing? are you trying to set the parameters with VCDS or OBDeleven? Have you done the camera calibration with Odis?
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Good night in Brazil, what are the flaws that are appearing? are you trying to set the parameters with VCDS or OBDeleven? Have you done the camera calibration with Odis?
Hi Luiz, good morning from Italy, thanks for your help.

The malfunctions that appear are a series of errors in the modules that must communicate with each other (databus missing in the module 13,44).

But these errors don't bother me, as I've read in various discussions that they disappear after calibration.

I entrusted the calibration to the company that changed the windshield and we will do it on Monday. However, I have always read online, that I have to show up for calibration with only one error in the a5 module (no Basic setting error).

Unfortunately I don't have vcds and odis. I am working with obd11. But to get an encoding or adaptation I have to retry 10 times. And this is strange. Then I often have this message ... I attach photos.

Grazie

Strange..
 

Attachments

  • Screenshot_20210219-130142_OBDeleven.jpg
    Screenshot_20210219-130142_OBDeleven.jpg
    442.9 KB · Views: 14

Reaper1

Go Kart Newbie
Location
.
Thank you for your support...

But what is the malfunction camera due to? Since with obdeleven I have difficulty accessing the camera and carrying out a normal screening and dialogue ...

Malfunction Shouldn't be there if its a windshield replacement and everything is new. The only Time I Had that error is when the ribbon cable wasnt plugged in correctly, You Shouldn't have that problem.
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Malfunction Shouldn't be there if its a windshield replacement and everything is new. The only Time I Had that error is when the ribbon cable wasnt plugged in correctly, You Shouldn't have that problem.
Thank you so much for your support...
I have an update. I managed to try another camera.
I think this is better.
What do you think? I enclose the results.

It's truth that we don't have to worry about databus errors before calibration ??
Thank you to all
 

Attachments

  • Screenshot_20210225-161508_OBDeleven.jpg
    Screenshot_20210225-161508_OBDeleven.jpg
    702.9 KB · Views: 21
  • Screenshot_20210225-161424_OBDeleven.jpg
    Screenshot_20210225-161424_OBDeleven.jpg
    676.8 KB · Views: 18
  • Screenshot_20210225-161403_OBDeleven.jpg
    Screenshot_20210225-161403_OBDeleven.jpg
    478.6 KB · Views: 19
  • Screenshot_20210225-161341_OBDeleven.jpg
    Screenshot_20210225-161341_OBDeleven.jpg
    635.4 KB · Views: 22

Reaper1

Go Kart Newbie
Location
.
Thank you so much for your support...
I have an update. I managed to try another camera.
I think this is better.
What do you think? I enclose the results.

It's truth that we don't have to worry about databus errors before calibration ??
Thank you to all

Yep, this camera is good, the previous one is most likely faulty.

You Didn't code anything so Its normal to have databus error, You can code before calibration, and get rid of the databus ones.
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Yep, this camera is good, the previous one is most likely faulty.

You Didn't code anything so Its normal to have databus error, You can code before calibration, and get rid of the databus ones.
Hi Reaper, thank you... yesterday I had already coded all the modules following a guide,
what will I have forgotten? ...

The databus is always present ...
Damn😥
 

Reaper1

Go Kart Newbie
Location
.
Hi Reaper, thank you... yesterday I had already coded all the modules following a guide,
what will I have forgotten? ...

The databus is always present ...
Damn😥

1. You May have forgotten to Code something, Or Didn't Code properly, which keeps the errors.

2. You didn't clear the codes so it wont just go away on its own.
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
The errors are present and do not disappear, do you have a list of encodings to compare with mine?
Maybe I did something wrong ...

Here are my changes:

Module: A5 (Front Sensors Driver Assistance System)

Coding → Byte: 16 → Bit: 7 → active ("lane departure warning (HCA) active/installed")

Adaptation → HCA_On_State > Set value to "menu"
Adaptation → HCA_Warning_Intensity > Set value to "menu"
Adaptation → BAP_Personalisierung > Set value to "not activated"
Adaptation → Intervention moment > Set value to "late (setting via menu)"
__________________________________________________________________________________
Module: 17 (Instruments Cluster)
Coding → Long Coding → Byte: 04 → Bit: 6 → active ("Lane Assist fitted")
Coding → Long Coding → Byte: 11 → Bit: 1 → active ("Lane Departure Warning / Lane Assist Information (BAP)
_____________________________________________
Module: 44 (Power Steering)
Security Access → Code: 19249
Coding → Long Coding → Byte: 00 → Bit: 4 → active ("Lane Assist fitted")
_________________________________________
Module: 5F (Information electronics)

Security

Adaptation → Car Function List BAP Gen2 - LDW_HCA_0x19 > Set value to "enabled"
Adaptation → Car Function List BAP Gen2 - Expansion LDW_HCA_0x19_msg_bus > Set value to "Extended bus"
Adaptation → Car Function Adaptat Gen2-Menu_display_Lane_Departure_Warning > Set value to "enabled"
Adaptation → Car Function Adaptat Gen2 - Menu_display_Lane_Departure_Warning_over_threshold _high > Set value to "activated"

Coding reloaded to the Acc and A5 front sensor
Module 13 byte 3 bit 6 enable (front camera installed)
Module A5 byte 11 bit 2 enable (acc coded)
Module A5 byte 14 bit 0 enable (radar interface coded)
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Hi friends, I'm here with some updates.

All databus errors removed. It was hard but in the end I'm happy ..
But this looks like a cursed project.

Calibration performed by the glass center. On the way back after 5 minutes the lane assist was disabled.

😫
New error in a5 module:
Dynamic Calibration
C1106 F0 [009] - Limit Exceeded

Do you know if I can and if there is a way to revive or restart the dynamic calibration?

I have obdeleven. And damn I came home.


Grazie
Marco
 

Sn00ky

Passed Driver's Ed
Location
Amsterdam
Car(s)
MK7 variant DSG
Hi friends, I'm here with some updates.

All databus errors removed. It was hard but in the end I'm happy ..
But this looks like a cursed project.

Calibration performed by the glass center. On the way back after 5 minutes the lane assist was disabled.

😫
New error in a5 module:
Dynamic Calibration
C1106 F0 [009] - Limit Exceeded

Do you know if I can and if there is a way to revive or restart the dynamic calibration?

I have obdeleven. And damn I came home.


Grazie
Marco

Did you check your offset? Mine was off by 0,006 (max offset = 2,5) so we need to adjust the offset off the camera.

as from what i heard from @Reaper1 is that we have to run calibration again via OBDELEVEN or in your case paid the windshield corp again.
 

Attachments

  • A03F65C3-0235-4C44-96BB-193BD4A994FB.png
    A03F65C3-0235-4C44-96BB-193BD4A994FB.png
    392.3 KB · Views: 19
Last edited:

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Did you check your offset? Mine was off by 0,006 (max offset = 2,5) so we need to adjust the offset off the camera.

as from what i heard from @Reaper1 is that we have to run calibration again via OBDELEVEN or in your case paid the windshield corp again.
Thank you so much....
Well...
I performed static calibration with poster and obdeleven. At first it went ok. I went out on the road and drove for 20km. Error-free ... How long does dynamic calibration last?
 

Sn00ky

Passed Driver's Ed
Location
Amsterdam
Car(s)
MK7 variant DSG
Thank you so much....
Well...
I performed static calibration with poster and obdeleven. At first it went ok. I went out on the road and drove for 20km. Error-free ... How long does dynamic calibration last?
I was driving from 23 until 02:00 when it stopped calibration error for 60km

you can see the live feed on OBD when it starts calibration.
 
Top