GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Retrofitting Lane assist camera without changing windshield?

BlackandwhiteGTI

New member
Location
St. Louis, MO
Okay I have been working on getting TSR working on my 2016 GTI SE (no navi) it has the full DAP on it from the factory. I have been able to get it to display speed signs of the MFD, but it doesn't display any actual signs. I believe it is picking up signs indicating the highway/exits. It only shows signs on the highway as far as i know. There could be a few things that cause this issue, I don't have the ability to enable A5 - Byte 16 Bit 04, but it seems that is only necessary on some cars and there is some other threads that indicate A5 - Byte 01 Bit 00, which I did successfully, can be done if you can't do the coding. It seems If you are able to change A5 - Byte 01 Bit 00 and not A5 - Byte 16 Bit 04, then you need to change the value below.

I also was not able to change:

Control unit A5 (front / advance camera) - Adaptation - Select : channel numbers indicate end of speed limit - Importance to actively invest - Show Valid suffix View Channel Valid suffix - Corresponding value adjust default: 00100111

My car had 100111 on it and when i try to edit that number, it goes right back to 100111. This I believe may have an affect on what signs are shown.

Here is a source with the code for TSR
https://obdeleven.proboards.com/thread/167/coding-adaptations
https://www.autoinstruct.com.au/manufacturer/volkswagen/mk7-golf/mk7-golf-obdeleven-vcds-tweaks/

A source with the coding "A5 - Byte 16 Bit 04"
https://www.vwwatercooled.com.au/forums/f235/traffic-sign-camera-122112.html

P.S. I am on my Comfort CANBUS - I haven't really found much on which one I am supposed to use, (comfort or extended) but my car had extended by default and it seemed to like the comfort CANBUS. I may try the Extended version to see what my results are.

Also the second change I have made, I don't see anywhere. In 5F I believe (it could be in A5), I found in the long coding I could select my region. It was something like VZE_RSR_Region default - no information -> West Europe, which seemed to work for me.

I have tried most of the logical CANBUS (including Comfort) with no avail but I only tried the Comfort CANBUS with the West Europe edit, I am wondering if I could be missing something, but I am bringing this up in hopes that this could fill in a few gaps and maybe solve this issue.
 

Cuzoe

Autocross Newbie
Location
Los Angeles
I'm not sure what you mean by you are on the Comfort CAN bus... do you mean that is where you wired the camera? Your camera should be connected to Extended CAN bus, pins 7 (low) and 17 (high) of the gateway. You don't have to tap into them at the gateway, but it should be that bus. If you had the camera installed from factory I have to assume it was on Extended CAN. Did you re-pin something to Comfort CAN?
Capture 1.PNG
 

BlackandwhiteGTI

New member
Location
St. Louis, MO
I'm not sure what you mean by you are on the Comfort CAN bus... do you mean that is where you wired the camera? Your camera should be connected to Extended CAN bus, pins 7 (low) and 17 (high) of the gateway. You don't have to tap into them at the gateway, but it should be that bus. If you had the camera installed from factory I have to assume it was on Extended CAN. Did you re-pin something to Comfort CAN?
View attachment 199315
No, I haven't even taken the plastic cover off to see what all is behind there, but it is good to know that I am supposed to be on the Extended CAN bus. I will change and test it when I can. I think I read somewhere about a German mk7.5 GTI getting coded and they talked about changing the CAN bus to that, I don't remember the website though.

Anyways, do you know or think that it isn't an issue that my car doesn't set the code as 00100111, or could that stem from a wrong CAN bus issue?
Control unit A5 (front / advance camera) - Adaptation - Select : channel numbers indicate end of speed limit - Importance to actively invest - Show Valid suffix View Channel Valid suffix - Corresponding value adjust default: 00100111
 

IWMTom

Drag Racing Champion
No, I haven't even taken the plastic cover off to see what all is behind there, but it is good to know that I am supposed to be on the Extended CAN bus. I will change and test it when I can. I think I read somewhere about a German mk7.5 GTI getting coded and they talked about changing the CAN bus to that, I don't remember the website though.

Anyways, do you know or think that it isn't an issue that my car doesn't set the code as 00100111, or could that stem from a wrong CAN bus issue?
00100111 is equal to 100111.
 

BlackandwhiteGTI

New member
Location
St. Louis, MO
What exactly do you mean when you say you are on the Comfort CAN bus? Have you made wiring changes?
In 5F, with in the adaptation Car_Function_List_BAP_Gen2 I can change which messagebus aka databus it uses. It seemed like the Comfort databus was the correct way, but I can go and test what happens with it set to Databus Extended. I have underlined it, and the adaptation above it the one I changed.

Also, no I haven't made any changes to the wiring.
 

Attachments

  • InkedScreenshot_20210110-170827_OBDeleven_LI.jpg
    InkedScreenshot_20210110-170827_OBDeleven_LI.jpg
    1.2 MB · Views: 34
Last edited:

Cuzoe

Autocross Newbie
Location
Los Angeles
Oh, in adaptations, gotcha. Might try looking for adaptation map of an EU GTI/R on RT forums to see how that should be set. When I was following threads about enabling TSR I remember people setting the TSR to active (as you have) but I don't recall reading about people changing the bus... which only tells us they left how they found it, but doesn't say what that setting was.
 
Last edited:

Sn00ky

Passed Driver's Ed
Location
Amsterdam
Car(s)
MK7 variant DSG
Hello
did anyone manage to print this in a regular A4 printer with the pdf file that is in this tread?
My printer just printed 1 page and all of it:D
what settings must we do to printer a couple of A4 page so it also have the right size?
thank you
I can recall several members have printed it on a4 -> but which page?
 

o_a_ravi

Go Kart Newbie
Location
Phoenix
Hello
did anyone manage to print this in a regular A4 printer with the pdf file that is in this tread?
My printer just printed 1 page and all of it:D
what settings must we do to printer a couple of A4 page so it also have the right size?
thank you
Printing it all on A4 and putting all the puzzle piece together will be fun ;)

I actually used a local large format print shop at the fedex. Even he had to print it on two sheets, cut it and combined to one. Had to do this for cost reasons obviously.
 

neolamb

New member
Location
Barcelona Spain
Car(s)
Golf 7.5 GTE
Hey there, I've tried to go over all the pages but I'm looking for some info.

So I'm going to have the front windshield replaced with the right one, I have a 2018 Golf GTE, it already has the radar and I want to install the camera.

I've seen multiple models with similar part numbers but have a different end letter.

Is there a specific difference between them ? is one better than the other ?

3Q0980654G
3Q0980654H
3Q0980654L
3Q0980654F

It's a bit hard as H seems to be the right one, but I've found on Google by setting the G that's also fit for the Golf ?

I am in the search mainly of Active lane keeping and pACC at the same time. But I just want to be sure I purchase the right material.

If my logic is right, I see the L has H12 ( for me this would mean Hardware version 12, so the latest)?

Edit #1, as per some information, this seems to be firmware only related and it would affect stability, bein H the most stable firmware.

Thanks to all !!
 
Last edited:

Reaper1

Go Kart Newbie
Location
.
yes, I did get a fault code, lane assist is disabled at the moment (acc is still running). I can recall @Reaper1, that yours failed too, did you need to rerun static?

If the fault code is dynamic calibration offset too high then you need to recalibrate the camera
 

Reaper1

Go Kart Newbie
Location
.
In 5F, with in the adaptation Car_Function_List_BAP_Gen2 I can change which messagebus aka databus it uses. It seemed like the Comfort databus was the correct way, but I can go and test what happens with it set to Databus Extended. I have underlined it, and the adaptation above it the one I changed.

Also, no I haven't made any changes to the wiring.
You should connect it to the extended Can Bus, 7 and 17, There Is A Reason VW Does that from factory.
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Hi all friends. I'm new to the forum. Nice to meet all.
I have read this discussion throughout the all pages and i'm passionate about your work. Thanks for the great work done. User camarao69 reported this thread to me.

I retrofitted the lane assist on passat b8 from 2018. Wiring done through other guides on the web, but all in line with your experience. I bought a used camera 3q0980654h. Same provenance as my car. (They tell me)....

I state that I code with obdeleven.
All modules have fast reaction. And I managed to code by following a list of codes.
On module a5 is difficult to reach and code. To be clear, I have to press the green button 20 times to get executed. But i Cannot enter the calibration procedure. (The wizard with obd11 explained by camarao69)

I have several errors ... but what worries me most is camera malfunction c110400.
The acc has been disabled automatically but I think it's normal.

I changed the windshield and the camera is in its original housing.

Can you help me? Will I have to change and look for another camera? Or could the communication fault be related to my wiring? (Although I am very sure and all your instructions confirm the work I have done). Forgive my English. Indeed my google english.

Marco from italy
 

Attachments

  • Screenshot_20210216-225818_OBDeleven.jpg
    Screenshot_20210216-225818_OBDeleven.jpg
    731.1 KB · Views: 16

Sn00ky

Passed Driver's Ed
Location
Amsterdam
Car(s)
MK7 variant DSG
I have several errors ... but what worries me most is camera malfunction c110400.
The acc has been disabled automatically but I think it's normal.

I changed the windshield and the camera is in its original housing.

Can you help me? Will I have to change and look for another camera? Or could the communication fault be related to my wiring? (Although I am very sure and all your instructions confirm the work I have done). Forgive my English. Indeed my google english.

Marco from italy
Hi Marco,

welcome to the club. The error relates to no calibration of the camera -> no basic settings
 

mangio85

New member
Location
Italy
Car(s)
Passat b8 2015
Thank you for your support...

But what is the malfunction camera due to? Since with obdeleven I have difficulty accessing the camera and carrying out a normal screening and dialogue ...
 
Top