GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

PDC Retrofit Question

jacekk1986

New member
Location
Poland
Car(s)
GTI MK7
You have misscoding. All should be coded as in Xagico pdf.
Find all coding and check if its tha same as in PDF
I made it myself and all working properly.
 

Attachments

  • Park Pilot.pdf
    1.5 MB · Views: 63

Prefatcher

New member
Location
Slovenija
Car(s)
Golf 7
Everything coded as provided instructions except:
19 CAN-Gateway → Adaption →installation list; specified installationns-ParkingAssistance
1.JPG


I cant find this parameter.... Everything else coded but problem still insists...

I will add VCDS scan in attachment as well...but current state of my car:

IMG_3633.JPG

So a lot of faults present. This problem is driving me crazy...
 

Attachments

  • log.txt
    21.7 KB · Views: 23

jacekk1986

New member
Location
Poland
Car(s)
GTI MK7
First of all you need add module 10 Park assist to gateway installation list to make proper communication between all modules.
Module 10 should be with parametrization. Modul should know in which car working for (for example Passat is longer tham Golf).
If module had parametrization there is posibility to code it (without parametrization there is no posibility to code it).
Also I can help you via Anydesk.

Here is helpfull video:
 
Last edited:

ladookadoo

New member
Location
united kingdom
Car(s)
MK7.5 Golf GTE
Hello, does anyone have access to xagico pdf for park assist retrofit? All the links i've found are dead. Just ordered the aliexpress kit but getting my head around the wiring is driving me insane!
 

Cuzoe

Autocross Champion
Location
Los Angeles
Hello, does anyone have access to xagico pdf for park assist retrofit? All the links i've found are dead. Just ordered the aliexpress kit but getting my head around the wiring is driving me insane!
Also, since this thread is long and you may have missed it. If you're ordering a retrofit harness from AliExpress (or wherever, any place that's not OEM) the rear is probably wired as if you're running the harness down the left side of the car. Meaning the first sensor connector on the harness will be for the rear left sensor. It's no problem if you actually run it down the left side of the car.

But if you run it down the right side of the car (factory routing) the rear sensors will be wired in reverse.

Without getting into why the factory routing makes the most sense, just something to keep in mind.
 

ladookadoo

New member
Location
united kingdom
Car(s)
MK7.5 Golf GTE
Also, since this thread is long and you may have missed it. If you're ordering a retrofit harness from AliExpress (or wherever, any place that's not OEM) the rear is probably wired as if you're running the harness down the left side of the car. Meaning the first sensor connector on the harness will be for the rear left sensor. It's no problem if you actually run it down the left side of the car.

But if you run it down the right side of the car (factory routing) the rear sensors will be wired in reverse.

Without getting into why the factory routing makes the most sense, just something to keep in mind.
Thanks for this info, does this make a difference if my car is LHD or RHD? I'm based in the UK so have RHD. I would imagine wiring down the left side of the car would make more sense? since the connections for can/TIUL is (i'm pretty sure) on the left side of the car
 

Cuzoe

Autocross Champion
Location
Los Angeles
Thanks for this info, does this make a difference if my car is LHD or RHD? I'm based in the UK so have RHD. I would imagine wiring down the left side of the car would make more sense? since the connections for can/TIUL is (i'm pretty sure) on the left side of the car
I don't believe it makes a difference. None of the factory parking system wiring goes to/through TIUL anyway.
 

ladookadoo

New member
Location
united kingdom
Car(s)
MK7.5 Golf GTE
I don't believe it makes a difference. None of the factory parking system wiring goes to/through TIUL anyway.
oh awesome! sooo i can run it along the left side as intended without issue i guess. i must’ve got confused with a different retrofit been doing too much lately haha

whereabouts is the existing PDC module located? i assume i’ll just need to swap out the existing module with the new PLA 3.0 one dokiauto on aliexpress sent me and can continue with wiring from there right?
 

Cuzoe

Autocross Champion
Location
Los Angeles
On my LHD drive car the PDC module is under the steering wheel. The PLA 3 module is taller than the PLA 2 module so early mounts needed some modification. Later mounts would work with both PLA 2 and PLA 3 so your 7.5 likely has a later mount.

If your module is on the right side it would be easier, in my opinion, to run the harness on the right side (which is where VW intends).

Ultimately you need to check the wiring harness against the wiring diagram to make sure everything is correct for whichever side you choose.
 

ladookadoo

New member
Location
united kingdom
Car(s)
MK7.5 Golf GTE
On my LHD drive car the PDC module is under the steering wheel. The PLA 3 module is taller than the PLA 2 module so early mounts needed some modification. Later mounts would work with both PLA 2 and PLA 3 so your 7.5 likely has a later mount.

If your module is on the right side it would be easier, in my opinion, to run the harness on the right side (which is where VW intends).

Ultimately you need to check the wiring harness against the wiring diagram to make sure everything is correct for whichever side you choose.
appreciate the help, i have access to elsawin so will check on there which side its situated on for my car.

i pretty much understand all the wiring now thanks to the english instructions the seller sent as opposed to the chinese ones in the box apart from two things…

the singular wires that go from the PLA module to the switch - the chinese instructions show E581 at pin 4 and 7. The english ones however show EX22 at pins 4 and 9. Hopefully the pictures will help one to understand my terrible explanation better lol!

Not sure what the difference between both is, i wonder if it’s to do with my switch having the SET! button there too as opposed to others that have the top position blank. Not sure which instructions to follow for the pinouts as they’re both different.

Another thing that i’m unsure about is the two connectors i’ve circled in the images attached. Where do these go? or do they not plug into anything? I’ve attached an image of the connector(s) in hand too.

So sorry to put you guys through all this, i know it’s an old thread but would appreciate any help i can get 🙏
 

Attachments

  • IMG_0546.jpeg
    IMG_0546.jpeg
    2.1 MB · Views: 25
  • IMG_0547.jpeg
    IMG_0547.jpeg
    516.8 KB · Views: 24
  • IMG_0548.jpeg
    IMG_0548.jpeg
    759.3 KB · Views: 27
  • IMG_0549.jpeg
    IMG_0549.jpeg
    1.7 MB · Views: 27

Cuzoe

Autocross Champion
Location
Los Angeles
I don't know what EX22 is supposed to be. EX30 in my picture below is the center console switch module. Whatever you have there already will remain, but you will add whatever is necessary to match the diagram. E581 is the parallel park button (within) EX30. Pin 4 is for that LED and Pin 7 is for the button actuation. Doesn't matter that you have a SET! button there. The SET! button is part of EX30 but not shown on the parking system diagram. I'll have to check the circled items later this evening.

Are you going from 8 sensors to 12 sensors?
 

ladookadoo

New member
Location
united kingdom
Car(s)
MK7.5 Golf GTE
I don't know what EX22 is supposed to be. EX30 in my picture below is the center console switch module. Whatever you have there already will remain, but you will add whatever is necessary to match the diagram. E581 is the parallel park button (within) EX30. Pin 4 is for that LED and Pin 7 is for the button actuation. Doesn't matter that you have a SET! button there. The SET! button is part of EX30 but not shown on the parking system diagram. I'll have to check the circled items later this evening.

Are you going from 8 sensors to 12 sensors?
I see, thanks for taking the time to check

I guess i'll wire it to pin 4 and 7 and hope for the best, after all it's in the instructions for my supplied kit so it must be the right one

And yes, I've already got front and rear sensors from factory so i'll be going from 8 to 12
 

Kushdaiin

Go Kart Champion
Location
Connecticut
Car(s)
MK7 R, MK7 GSW SEL
I see, thanks for taking the time to check

I guess i'll wire it to pin 4 and 7 and hope for the best, after all it's in the instructions for my supplied kit so it must be the right one

And yes, I've already got front and rear sensors from factory so i'll be going from 8 to 12
Ah, So you're doing what I did a couple of years ago on my MK7 R. I went through the erwin diagrams to figure out the wiring, which the Chinese directions actually matched up to. The connectors they've provided are to allow you to connect the wiring from the kit to the OE wiring without having to physically splice. They are dovetails and they can make it easier, assuming you have the correct pins for the connector, which based upon my experience worked.
 
Top