GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

P0413 code

daconchslop

Autocross Champion
Location
South Carolina
As simple as it is, did you remember to reconnect the SAI hose after the cleanup? Otherwise I would guess it’s the combi valve, pretty good failure rate these days it seems.
 

tigeo

Autocross Champion
As simple as it is, did you remember to reconnect the SAI hose after the cleanup? Otherwise I would guess it’s the combi valve, pretty good failure rate these days it seems.
Yes, everything is hooked up correctly and functioning as far as I can tell. I agree that the combi needs to be swapped out or I can just keep clearing the code. Too bad I just can't delete it...with tune/downpipe why bother having this system. I know I can buy a delete plate but I wont' be able to code out the SAI unless Unitronic really was being nice....
 

daconchslop

Autocross Champion
Location
South Carolina
Yes, everything is hooked up correctly and functioning as far as I can tell. I agree that the combi needs to be swapped out or I can just keep clearing the code. Too bad I just can't delete it...with tune/downpipe why bother having this system. I know I can buy a delete plate but I wont' be able to code out the SAI unless Unitronic really was being nice..
Yea that’s a shame you can’t code it out. I don’t think the repair is too expensive and the install is very simple.
 

tigeo

Autocross Champion
Yea that’s a shame you can’t code it out. I don’t think the repair is too expensive and the install is very simple.
It's not hard but man, that valve is $200 which is a lot but I hate CELs....

I thought about pulling the pressure sensor and cleaning it off.
 

daconchslop

Autocross Champion
Location
South Carolina
Anything free you can do to troubleshoot and eliminate possible causes is smart. I also saw where those replaced also end up failing a short time later.
 

tigeo

Autocross Champion
Anything free you can do to troubleshoot and eliminate possible causes is smart. I also saw where those replaced also end up failing a short time later.
Which is strange - I suppose that valve has exhaust pressure on it all the time so is a high-wear item?
 

tigeo

Autocross Champion
Could be so, especially at tuned levels and much higher egts
Another good thought! I likely will jsut order one from FCP and at some point in the next few weeks suck it up and change it out.
 

tigeo

Autocross Champion
All sorted. Got it into the dealer and they replaced the combi valve under warranty. Interesting as I'm tuned etc. I just told them up front about it and requested a tech in our local VW FB group.
 

nkresho

suck, squish, bang, blow
Location
Pittsburgh
Car(s)
2016 GTI S DSG
Thought I was getting notifications on this thread but I guess not.

About a year in and the newer rev part is still not throwing the code for me.

And no, I never felt a difference in power when it was or wasn't.
 

tigeo

Autocross Champion
Thought I was getting notifications on this thread but I guess not.

About a year in and the newer rev part is still not throwing the code for me.

And no, I never felt a difference in power when it was or wasn't.
Same - didn't notice any difference in power etc. but thinking on it, if it was stuck open, exhaust gas should have been coming back through the SAI and I did note much more exhaust smell when I would get out (more than I get normally with the catted DP). I have to believe that a properly sealed SAI combi valve has to help with the turbo.
 

RecycledDonuts

Ready to race!
Location
Alabama
It's not hard but man, that valve is $200 which is a lot but I hate CELs....

I thought about pulling the pressure sensor and cleaning it off.
Which pressure sensor?
 

arob157

Go Kart Champion
Location
USA
Installed my PR SAI block off plate yesterday.

If anyone needs to do replace their solenoid/valve, I really hope you have upgraded discharge pipes haha. I had to remove my intake box, intake pipe (not turbo inlet btw), battery & battery tray, and my turbo muffler/discharge pipe hose. Thanks to EQT for designing their discharge pipes for easy access of the SAI valve on the block.

I had to code out P0413, P02431, and P02432 and reflash.

I am happy to report drivability has been greatly improved. I believe the valve being stuck open created some weird backflow to the SAI pump. I got odd chokes/hiccups and what felt to be compressor surge as the turbo started spooling around 2750rpms. Felt like boost creep. The hiccups felt like slight fuel cuts or lean spots, but nothing in my logs registered them.

Highly recommend deleting that crap if you can. Haha.
 
Top