GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

MK7 Climatronic upgrade with instructions and pictures.

UA TDI

Passed Driver's Ed
Location
Central PA
Car(s)
MK7 GTI
Definitely interested in this. Wondering if anyone knows the part number for the climatronic trim piece for MK7 gtis (with the honeycomb trim rather than piano black). Thanks in advance
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
My old version of Vag-Com doesn't recognise this clima unit, there's no '.ROD' file assosciated with it, which is a shame as you can't view/check the functions, and the stuff you have access to doesn't have any descriptions, long-coding DOES work but again there's no descriptions so you're sort of flying blind. If anyone has a solution to this I'd love to hear from you.

Replying to myself to feel less isolated during lockdown, nah seriously, for continuity.

As an experiment I copied the labels and ROD files from the latest install of VCDS (V20) into my old (V17 I think) copy, VCDS still doesn't recognise the controller correctly, but it DOES recognise the binary values in the long coding, which is useful as there are some changes you should make, such as setting the fuel type (petrol/diesel) and make sure that the installed sensors are turned on, and those not present are disabled.

There is an option to reduce fan speed in the long coding, Byte 12, bits 0-3, which I've changed as shown .
clima byte 12.png

Over the last few days of driving I've noted that the fan speed seems lower than it was, not 'obnoxious' but still annoying if you're just puttering around the doors. It would usually start around speed 4, now it's around 3 on start, which goes up to about 5 once the engine starts to warm up. Fortunately my usual daily drive is only a mile or so if town driving then 50-70mph roads, so the fan speed isn't an issue. I'd call that a win.

Also there's an option to change from LHD to RHD, which I thought would change the 'primary' control from left to right, but it doesn't. If you select 'sync' and move the right knob it de-syncs, whereas the left knob changes both.
 

matthewP

New member
Location
Charlotte NC
Car(s)
Golf 7
Thank you for writing this up. I've wanted to do this to my GTI since I bought it but everywhere I read made it seem "impossible". I ordered the same kit you bought and am waiting for it to arrive.

The only part that is not clear to me is how you attach the sensors to the harness. But I assume there will be a explanation in the directions.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
UPDATE: (Minor)

I'm going to have to call a bit of a pause to this "Success" at the minute for a few reasons.

Main issue (won't be an issue for many) the Start-Stop function doesn't work, even if you turn OFF A/C then the MFD display still shows A/C as active. I don't like S-S but I'd prefer to be able to use it if possible.

Supplimental;
1) My copy of VCDS can't find a ROD file for the chinese clima panel.
2) So I bought a Genuine used MK7 panel, fitted it, while it now finds the ROD file it can't list fault codes.
3) New panel adapts flaps fine, but won't perform A/C compressor run-in, either from VCDS or front panel.
4) Checked VCDS and found the RHS vent temperature sensor is reading 85*c.

I swapped sensors, no change in the reading. I buzzed out the cables from the plugs and found no change. I even checked the grounds in the back of the plugs, and the signal pins on the panel both have the same resistance etc. Everything seems to be wired right, but I'm just not getting the any temperature reading for the RHS sensor.

I'm going to continue to try and figure it out, once I find out more I'll put up another post.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Ok, so I've been tearing my hair out trying to figure out what's going on with this thing. I found the diagrams for the MK6 Climatronic system, which appears to have the same connectors and pinout as the MK7.

I checked the pin reassignments on the connector that adapts the MK7 climatic to Climatronic and learned the following.
1) Climatronic has 5 flap motors, Climatic has 3. The missing ones are Right temperature flap and 'Defroster flap'.
2) The climatronic has inputs for the left and right sunlight sensors but these are missing.
3) Neither the Aliexpress or Genuine used panels have pins 2 or 4 populated on main connector A, meaning they don't have inputs for 'high pressure sensor' or 'Air quality'.
4) Pin 16 on Connector A is populated on all panels and has a blue wire going to the harness, but this isn't marked on the diagrams, don't know what this wire is.
5) On the adapter harness that goes from 1x to 2x 16 pin plugs, the flying lead IS NOT AN UPPER VENT TEMPERATURE SENSOR, its in fact for the LEFT FOOTWELL VENT, even though it says on the diagram provided (in chinese, thanks google translate) that it is for the upper vent.
6) Because of 5), there will be error codes for missing RHS Footwell and RHS Vent temperature.

I'll continue to work on this.
 

anotero

Autocross Champion
Location
Hither and thither
Car(s)
Mk7 GTI
Ok, so I've been tearing my hair out trying to figure out what's going on with this thing. I found the diagrams for the MK6 Climatronic system, which appears to have the same connectors and pinout as the MK7.

I checked the pin reassignments on the connector that adapts the MK7 climatic to Climatronic and learned the following.
1) Climatronic has 5 flap motors, Climatic has 3. The missing ones are Right temperature flap and 'Defroster flap'.
2) The climatronic has inputs for the left and right sunlight sensors but these are missing.
3) Neither the Aliexpress or Genuine used panels have pins 2 or 4 populated on main connector A, meaning they don't have inputs for 'high pressure sensor' or 'Air quality'.
4) Pin 16 on Connector A is populated on all panels and has a blue wire going to the harness, but this isn't marked on the diagrams, don't know what this wire is.
5) On the adapter harness that goes from 1x to 2x 16 pin plugs, the flying lead IS NOT AN UPPER VENT TEMPERATURE SENSOR, its in fact for the LEFT FOOTWELL VENT, even though it says on the diagram provided (in chinese, thanks google translate) that it is for the upper vent.
6) Because of 5), there will be error codes for missing RHS Footwell and RHS Vent temperature.

I'll continue to work on this.

Dude, I'm be following closely. This is a great thread. Your efforts are very much appreciated.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Dude, I'm be following closely. This is a great thread. Your efforts are very much appreciated.

No worries at all, I'm ready to crack on with it but unfortunately what I could really do with finding is a few spare pins for the connectors with a couple of inches of wire on them so that I can patch in the missing temp sensors. There's none of these in scrap yards near me, other than one local VW only breaker who would probably charge me way more than I'm reasonably willing to pay for some bits of wire.

If anyone in the northeast england has a cut off plug then that would be a great help in trying to get to the bottom of this.

Cheers, Dave.
 

IWMTom

Autocross Newbie
UPDATE: (Minor)

I'm going to have to call a bit of a pause to this "Success" at the minute for a few reasons.

Main issue (won't be an issue for many) the Start-Stop function doesn't work, even if you turn OFF A/C then the MFD display still shows A/C as active. I don't like S-S but I'd prefer to be able to use it if possible.

Supplimental;
1) My copy of VCDS can't find a ROD file for the chinese clima panel.
2) So I bought a Genuine used MK7 panel, fitted it, while it now finds the ROD file it can't list fault codes.
3) New panel adapts flaps fine, but won't perform A/C compressor run-in, either from VCDS or front panel.
4) Checked VCDS and found the RHS vent temperature sensor is reading 85*c.

I swapped sensors, no change in the reading. I buzzed out the cables from the plugs and found no change. I even checked the grounds in the back of the plugs, and the signal pins on the panel both have the same resistance etc. Everything seems to be wired right, but I'm just not getting the any temperature reading for the RHS sensor.

I'm going to continue to try and figure it out, once I find out more I'll put up another post.

What's the part number of your panel? My stop/start is working fine with AC on (and off) with only the two upper vents connected.

Happy to compare my installation with yours to get to the bottom of the problem.
 

Tomukas888

New member
Location
Lithuania
Car(s)
VW e-Golf
Hi, i have general question about understanding wiring diagrams. Where goes those two wires on the right with numers 5 and 14 at the end? Thanks for help
 

Attachments

  • Capture.PNG
    Capture.PNG
    218.5 KB · Views: 314

StorableComa

Autocross Champion
Location
SoCal, USA
Car(s)
17 GSW S FWD
On Erwin? Once you pay for your subscription you should be able to pop in your VIN or select your car. From there you should be able to Print to PDF all the documentation. I downloaded all the manuals for the GSW/Variant this way, including full wiring diagrams.
 

Tomukas888

New member
Location
Lithuania
Car(s)
VW e-Golf
Im retrofiting Side assist and Lane assist, as my car doesn't have this my VIN is useless. I have cut outs of diagrams, but very little is missing.
 
Top