GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

MK7 Climatronic upgrade with instructions and pictures.

George Ab

Drag Racing Champion
Location
Pacific NW
So I have an 18 R, with the dual climate control knobs. Is this just a plug and play with slight coding for me? I "should" have all the sensors installed already correct?

Straight swap and then perform flap adaptation and AC run-in so new unit can learn how to properly interface with your HVAC. We have figured out how to do this with by pressing which buttons simultaneously with standard auto climatronic, but not sure if we have figured out how to do it manually with buttons for the capacitve controlled unit. As I recall Acadia18 performed with OBD11 and should be able to provide procedure. I could not find how to perform using Ross Tech's vagcom.
 

George Ab

Drag Racing Champion
Location
Pacific NW
With VAG China unit unable to access adaptations using Vagcom. To change adaptations you need to first enter security code which is 20103 for HVAC 08 Controller, but this unit does not accept that security code. I wanted to access in order to access adaptations to change the retention of drivers seat heater level from 10 min to active, so it keeps last setting when car is started. So that is another limitation.
 

gdrop

New member
Location
Maryland
Car(s)
2019 GTI SE 6M
Hi all,

I just completed this retrofit using a NAR climate unit (has the MAX A/C button) using the aliexpress wiring harness/temp sensors. Everything is working well in terms of temperature adjustment and A/C function.

The only thing that is concerning to me is that in VCDS the left vent sensor (G150 - straight sensor) is reporting 85.0C and says open or short to plus as a fault. I pinned it into the 20 pin connector with the green/yellow wire into pin 13 and the green/purple wire in pin 17 as according to the VW wiring diagram.

The footwell sensor (G192 - 90 degree sensor) is working correctly and reports a reasonable value based on the temperature setting on the climate control unit. I did also notice that there is an "internal temperature" setting in VCDS and again that reads a normal value, so I'm not sure if that could be related to the vent temp, but I doubt that.

Right now, my thought is that the temperature sensor from aliexpress is faulty, but I'm wondering if there is something else that could be the issue.

Edit: I bought an OEM sensor (1K0907543E) from FCP euro, and that fixed the issue. I have a correct temp for the left air vent!
 
Last edited:

George Ab

Drag Racing Champion
Location
Pacific NW
With VAG China unit unable to access adaptations using Vagcom. To change adaptations you need to first enter security code which is 20103 for HVAC 08 Controller, but this unit does not accept that security code. I wanted to access in order to access adaptations to change the retention of drivers seat heater level from 10 min to active, so it keeps last setting when car is started. So that is another limitation.
This bothered me enough to purchase a NAR Climatronic unit (max A/C). Did not have any problem accessing adaptations and changing retention of drivers seat.
 

carbon_gecko

Passed Driver's Ed
Location
texas
Car(s)
2016 GOLf tsi 'S'
I noticed the AliExpress variant has 'Clean Air' button on the right. Not sure what it does, but just so you know - when it comes from factory it comes with a 'Max A/C' button. Very useful for hot countries like mine (Israel).

Sets temperature to lowest setting and turns on fan to max.

View attachment 196353
The clean air is for the air quality sensor. If you get one and wire it up when you press the clean air it should allow you to pull air from out side until the quality sensor reacts to outside pollution and auto sets recirc.
 

davegsm82

Ready to race!
Location
Blyth
Car(s)
MK7 Golf and T3 Tdi
.... I did also notice that there is an "internal temperature" setting in VCDS and again that reads a normal value, so I'm not sure if that could be related to the vent temp, but I doubt that.
'Internal Temperature' is actually a sensor inside of the heater control panel, in the very middle of the fan speed knob there's a black circular thing about 5mm in diameter, that's the sensor. If you put your finger on it while monitoring the temperature you'll see it rise.
 

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
Can you enable additional settings in the MMI menu?

1611223353444.png


Mine came with climatronic from factory, but only shows an 'OFF' button and the visual air directional arrows.
 

carbon_gecko

Passed Driver's Ed
Location
texas
Car(s)
2016 GOLf tsi 'S'
Can you enable additional settings in the MMI menu?

View attachment 200749

Mine came with climatronic from factory, but only shows an 'OFF' button and the visual air directional arrows.
Mine also has a symbol to the left of sync for the defroster. But that it.
 

mlamaiz

New member
Location
Netherlands
Car(s)
Golf 7 2013
Nice! For the record, I know it’s been weeks since it was mentioned but the seller for my unit sent me instructions (first option did not work, but the second one he recommended did)
Adapting setting :

 Adapt the air flow direction (from air vent)

press AC button 8 and button 3 , the indicate light will blinking ,if the setting is done , the indicate light will illumination as normal .



 Adaptor air compressor

Press button 8 and 16 for a few seconds , the indicate light will illumination . and the setting is done .

If the compressor running in first time , press button 8 and 16 for five seconds . the indicate light will illumination at same time, the adapting setting is done . air condition AC can work as normal .



This time the indicate light will not blinking , you need press 30 seconds ,then switch off by “off” button , and switch on AC to check if the compressor is working . if the setting is not working , please try more time for operation of adaptor air compressor

1 use keys to open fire And hold the third button ‘3 ’above and AC key‘ 8 ’more than ten seconds, until the air conditioning automatically stop,

2 at the same time Hold down the after the wind hot keys ‘16 ’and of AC key‘ 8’, more than ten seconds, until the air conditioning automatically stops

Until the air conditioning automatically stop.According to the above two steps air conditioning reset is complete, function normal.



View attachment 194787



If the previous operation failed, use this instruction to reset the activation.

Step 1: the car starts, blow the face [3] and ac [8] simultaneously press and hold for 10 seconds ,to activate the compressor.

Step 2: Press the rear glass defrost key [16 key] and ac [8 key] simultaneously for 2 minutes. 【Uninterrupted time】

Step 3; After the ac light is on, turn on air conditioner, turn on ac, start the car travel few kilometers, solve the problem

View attachment 194788View attachment 194789

Assuming you’re referring to the first one(?)ebay listing said it was out of a Golf R
https://www.ebay.com/itm/MK7-VW-GTI...-/233492531382?_trksid=p2349624.m46890.l49292

Hi guys,

I finished this retrofit too. I used the original panel 5G0907044T (not the Chinese one). I performed the Flap resync by pressing the button 8 + button 3, like explained above and that seemed to work. However the compressor run-in (button 16 + button 8) did not work. I tried both the options described above and also tried button 17 + button 8, but no blinking or any other feedback from the panel. Even if that did not work, everything seems to work correctly, but when scanning the car with OBDeleven I get the errors bellow. Almost half of those errors show "No basic setting", is that related to the fact that the compressor run-in did not work? Is there another way to perform that? I tried using OBDeleven to reset to the basic settings, but it did not work, all the options in there are set to "not active" and you cannot change it to "active". Any help will be appreciated.

Code:
OBDeleven data log

Date: 2021-02-02 19:58

    VIN:
    Car: Volkswagen Golf
    Year: 2013
    Body type: 5-dr hatchback
    Engine: CJZA 77 kW (105 HP) 1.2 l
    Mileage: 70573 KM

---------------------------------------------------------------
08 Air Conditioning

    System description: Climatronic
    Software number: 5G0907044T
    Software version: 0705
    Hardware number: 5G0907044T
    Hardware version: H02
    ODX name: EV_ACClimaBHBVW37X
    ODX version: 003018
    Long coding: 00020004202100011000004000101020

    Trouble codes:
        B108D54 - Right temperature flap positioning motor No basic setting
            static
        B109515 - Potentiometer für Stellmotor der Temperaturklappe rechts Unterbrechung/Kurzschluss nach Plus
            static
        B109054 - Defroster flap motor No basic setting
            static
        B109815 - Potentiometer für Stellmotor der Defrostklappe Unterbrechung/Kurzschluss nach Plus
            static
        B109154 - Front air distribution door motor No basic setting
            static
        B108B54 - Fresh air, recirculation, air flow flap motor No basic setting
            static
        B109B15 - Position Sensor for Fresh air, recirculation, air flow flap Open circuit/short circuit to B+
            static
        B108815 - Right vent temperature sensor Open circuit/short circuit to B+
            static
        B10E815 - Sunlight photo sensor Open circuit/short circuit to B+
            static
        B10E815 - Sunlight photo sensor Open circuit/short circuit to B+
            static
 

George Ab

Drag Racing Champion
Location
Pacific NW
Hi guys,

I finished this retrofit too. I used the original panel 5G0907044T (not the Chinese one). I performed the Flap resync by pressing the button 8 + button 3, like explained above and that seemed to work. However the compressor run-in (button 16 + button 8) did not work. I tried both the options described above and also tried button 17 + button 8, but no blinking or any other feedback from the panel. Even if that did not work, everything seems to work correctly, but when scanning the car with OBDeleven I get the errors bellow. Almost half of those errors show "No basic setting", is that related to the fact that the compressor run-in did not work? Is there another way to perform that? I tried using OBDeleven to reset to the basic settings, but it did not work, all the options in there are set to "not active" and you cannot change it to "active". Any help will be appreciated.
When I performed compressor run-in, the only feedback I recall was AC light came on. Previous to performing compressor run in AC light and AC function did not work.
 

mlamaiz

New member
Location
Netherlands
Car(s)
Golf 7 2013
When I performed compressor run-in, the only feedback I recall was AC light came on. Previous to performing compressor run in AC light and AC function did not work.
Oke... mine worked right away. It actually does everything it should do. But I can't code the basic settings with ODIS or OBDeleven...
 

mariosmax

New member
Location
Cyprus
Car(s)
Golf 7 2015 1.2 TSI
Hello guys , i completed the retrofit today as well. I can confirm i have the same errors. My kit had the 2 straight sensors which i placed on right - left vents as described in OP. Flap sync with button combination worked, AC sync didn't but i will try again other combinations i read here. In the meantime i would like to clarify some questions:

1. I am interested to add a 3rd sensor for footwell (part number 5Q0907543) and route the cable to 16 pin connector 880/10 pin 8. Has anyone already did this modification and if yes has this improved the functionality of this retrofit?

2. My menu is also appearing without any coding but i am not able to perform any changes through the screen. Do you have similar issues? For example if i press SYNC on the panel i see the change in the monitor. But when i press SYNC on the monitor nothing happens.

3. On the RHD cars does the menu image have the steering wheel on the right hand side? I also have the issue with the sync button. Even after changing the option to RHD on the newly installed panel when the temperatures are different and i select SYNC the "master temp" is on the left side. Since i drive RHD car i would prefer the opposite.
 
Top