GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Misfire after Unitronic Stage 2 IS20

jeffdemara

Passed Driver's Ed
Location
Vancouver, BC
Well, I just got the car up to an E20 blend for fuel, and it took away ALL the timing corrections I was seeing on logs. BUT, the same issue is still persisting, this time Cylinder 2 misfire. (Before I was getting Cyl 1 and 3 pretty consistently...) Pretty much only happens during a shift while in boost during a pull. For this example, I've been doing pulls in 3rd gear (car feels great during the pull and I feel NO loss of power!), but when it goes to shift to 4th during the pull, it then displays the EPC light and goes into limp mode.
 

StorableComa

Autocross Champion
Location
Long Beach, USA
Car(s)
17 GSW S
Are you DSG or Manual?

Not Uni, but I have something similar happen in a non repeatable fashion on my Slush box. Shifting around 6.7k it seemed to hesitate from third, then bam EPC light and car runs like shit post shift. Have to stumble to the breakdown and restart the engine to get it to run.

Scanned codes, Misfire cyl 3 and 4 with a cylinder deactivation. A few tranny implausable codes, but the timestamp seems to suggest that popped from trying to limp over on two cylinders.
 

jeffdemara

Passed Driver's Ed
Location
Vancouver, BC
Are you DSG or Manual?

Not Uni, but I have something similar happen in a non repeatable fashion on my Slush box. Shifting around 6.7k it seemed to hesitate from third, then bam EPC light and car runs like shit post shift. Have to stumble to the breakdown and restart the engine to get it to run.

Scanned codes, Misfire cyl 3 and 4 with a cylinder deactivation. A few tranny implausable codes, but the timestamp seems to suggest that popped from trying to limp over on two cylinders.
I'm regular 6spd auto slushbox.
 

jeffdemara

Passed Driver's Ed
Location
Vancouver, BC
This may or may not provide any insight as it's just a still photo of the log, but wanted to post it up anyways. Made a few notes, arrows, and circles for some things I found interesting.

Guessing the green dip I have circled is when the transmission shifts and there's a temporary reduction in torque/output.
E20 EPC Log Feb 28 2021-2.JPG
 

TwinDad

Drag Racing Champion
Location
Fort Lee, NJ
This is in the tune then. It's something with the post shift boost and afr. I would have Uni revise it
 

8055WAGEN

Go Kart Newbie
Location
MICHIGAN
Just for some solidarity, I had similar troubles with the IS20 Unitronic tune, I would regularly get a P0234 Overboost error. Now I am IS38.
 

tigeo

Autocross Champion
Just for some solidarity, I had similar troubles with the IS20 Unitronic tune, I would regularly get a P0234 Overboost error. Now I am IS38.
That is a different issue that I had as well and a revised tune sorted it. He's got something else going on. I've had misfires with both my IS20 and 38 tunes related to crappy fuel quality and using a few gallons of E85 fully sorts it.
 

8055WAGEN

Go Kart Newbie
Location
MICHIGAN
That is a different issue that I had as well and a revised tune sorted it. He's got something else going on. I've had misfires with both my IS20 and 38 tunes related to crappy fuel quality and using a few gallons of E85 fully sorts it.
Agreed. Also have experienced the wonders that E does for us.
 

Scanner

New member
Location
Whitby, ON
I have the same combo Uni Stage 2 IS20 + 6sp auto. I had misfires earlier when Stage 1+, random, the same way as you've mentioned when shifting 3rd to 4th gear. All solved by new OEM Golf plugs with a shorter gap + APR coils. My car has been smooth, with zero misfires, for more than 40k km. Here in Ontario, I've been using the Petro Canada Ultra 94, no E pumps.
 

jeffdemara

Passed Driver's Ed
Location
Vancouver, BC
I have the same combo Uni Stage 2 IS20 + 6sp auto. I had misfires earlier when Stage 1+, random, the same way as you've mentioned when shifting 3rd to 4th gear. All solved by new OEM Golf plugs with a shorter gap + APR coils. My car has been smooth, with zero misfires, for more than 40k km. Here in Ontario, I've been using the Petro Canada Ultra 94, no E pumps.
So your car would misfire during the shift, throw an EPC light, and go into limp mode? And you changed plugs and coils and it solved it for you?

I've changed my plugs so far, but not coils yet. Car only has 44,000kms.. but maybe it's time?
 

Mk7tsi3door

Go Kart Newbie
Location
Nova Scotia
I have the same combo Uni Stage 2 IS20 + 6sp auto. I had misfires earlier when Stage 1+, random, the same way as you've mentioned when shifting 3rd to 4th gear. All solved by new OEM Golf plugs with a shorter gap + APR coils. My car has been smooth, with zero misfires, for more than 40k km. Here in Ontario, I've been using the Petro Canada Ultra 94, no E pumps.
What gap? 25?
 

GTI Jake

Autocross Champion
Location
Charlotte, NC
So your car would misfire during the shift, throw an EPC light, and go into limp mode? And you changed plugs and coils and it solved it for you?

I've changed my plugs so far, but not coils yet. Car only has 44,000kms.. but maybe it's time?

It’s going to be an issue with something you just changed.

-tune

-DV on the is20 (is it a known good part?)

-fuel

It’s highly unlikely coil packs just so happened to go bad out of nowhere the day you slapped a new turbo on. I’d start with double checking the tune and Dv
 

jeffdemara

Passed Driver's Ed
Location
Vancouver, BC
It’s going to be an issue with something you just changed.

-tune

-DV on the is20 (is it a known good part?)

-fuel

It’s highly unlikely coil packs just so happened to go bad out of nowhere the day you slapped a new turbo on. I’d start with double checking the tune and Dv
I can swap the known to be good diverter valve from my original is12 on to my is20 pretty easily. Will give it a try just to be sure and eliminate the possibility.
 

ZuMBLe

Autocross Champion
Location
NY
Car(s)
Alltrack 6MT
I'm just gonna say. You should not need to mix ethanol in to the tank to get rid of misfires or excessive knock in a OTS tune. This is crazy.

@jeffdemara
The lean area after the shift could be because the ECU is not reverting to the full load table after the shift. My car exhibits this problem also, but I just tune around it by making the the last row in my part throttle fuel table match what I want a full load.

What are you using to log and display the log?
 
Top