GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

MIB2 Infotainment firmware update question

DoomWolf

New member
Location
Wolves
Car(s)
Golf
I believe that's 5G0 035 020. It's MIB1 High (MHIG), Discover Pro, 8-inch touch display 800x480 pixels.

It's too old for native CarPlay/AndroidAuto support. You can:
1. replace the main unit in the glovebox with OEM MIB2 main unit
or
2. add an CarPlayBox like this or similar behind the dashboard.

If you go with OEM MIB2, you will have original CarPlay/Android auto integration. But replacing the main unit requires: removing component protection from the new unit, performing coding & adaptations to match you cars equipment, patching and injecting license codes for FEC/SWaP protected features (including navigation and CarPlay/AndroidAuto), changing the USB port.

If you go with the box, you keep you original main unit, installation is plug&play. Depending on the box that you get, you can have wireless CarPlay/AndroidAuto, HDMI input, and other cool features.

Thank you. I will probably go with the carplay box. I like the idea of plug and play and I am more than happy to have a go myself.
 

smashedpotatoes

Go Kart Newbie
Location
Sacramento, CA
Car(s)
Golf 7 R
Just wanted to give my thanks to @mr-fix for the easy guides and videos. I was able to update from 0245 to 0253 software and clear the persistent code without any issues. Thank you very much for making these resources available!!
 

GolfR75

New member
Location
California USA
Car(s)
2019 Golf R
Hi, I installed a firmware update on my car. Everything worked, but I ended up with two fault codes stored 1555 (check software version management) and 1556. I was able to clear the 1555 error via the help of the ross-tech forums, but I am unable to figure out how to clear the 1556 error. This is the fault code stored:
Code:
1556 - Internal Control Module Memory Check Sum Error
B2000 87 [009] - Missing Message
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 6
Fault Frequency: 1
Reset counter: 47
Mileage: 59212 km
Date: 2023.03.09
Time: 10:42:42

My previous sw version was:
Train: MHI2_US_VWG13_P3662_1
MU: 1418
PN: 5NA035026E

My version is now:
Train: MHI2_US_VWG13_P3659_2
MU: 1126
PN: 5NA035026C

I think the fault is because I went backwards in software versions, but I can't find my original software version on the MIB solution website to revert it back to. It doesn't cause any functional issue with the infotainment, and I didn't lose any features, but I would like to clear the fault and/or get my original SW version back. Preferably just clear the error if possible, as I don't want to risk damaging the unit from another update. Anyone have any insight?
 
Last edited:

Raudix11

New member
Location
Philippines
Car(s)
GTI Mk7
Go to hidden menu and check if FEC/SWaP code 00030000 is installed and valid.
Finally, my OBDeleven arrived and I was able to check the FEC/SWaP codes. As you can see in the attached photo that 00030000 is Valid. I'm not sure on what to do next. I was able to activate the Apple CarPlay function thanks to Congo and Duke's Activation update so I can still connect my iPhone and play my music but I would still like to be able to use the Media function in my MIB2 for convenience since I can just connect via Bluetooth. Any suggestions would be most appreciated.
 

Attachments

  • IMG_3696.jpeg
    IMG_3696.jpeg
    1.7 MB · Views: 164
  • IMG_3697.jpeg
    IMG_3697.jpeg
    1.8 MB · Views: 174

mr-fix

Drag Racing Champion
Location
Poland
Car(s)
MK7 2.0TDI Variant
@Raudix11 any fault codes in module 5F?
Maybe you have corrupted SD card with MP3 that blocks the MEDIA app? Try removing card from the port and rebooting the unit.

One last thing that comes to my mind is to perform full SWDL on the unit. I'm not sure how safe it is to do it, but if you want to risk it:
Prepare SD with P0231D update, place in SD1 port, go to hidden menu (10 seconds hold, not 3 seconds hold), select SWDL manual, go to update menu, press "Select All" and run the update. This will take much longer than the usual update, since now it will overwrite every system component. This includes system patch, so you will have to patch it again.

⚠️ Do it at your own risk.

 

Raudix11

New member
Location
Philippines
Car(s)
GTI Mk7
@Raudix11 any fault codes in module 5F?
Maybe you have corrupted SD card with MP3 that blocks the MEDIA app? Try removing card from the port and rebooting the unit.

One last thing that comes to my mind is to perform full SWDL on the unit. I'm not sure how safe it is to do it, but if you want to risk it:
Prepare SD with P0231D update, place in SD1 port, go to hidden menu (10 seconds hold, not 3 seconds hold), select SWDL manual, go to update menu, press "Select All" and run the update. This will take much longer than the usual update, since now it will overwrite every system component. This includes system patch, so you will have to patch it again.

⚠️ Do it at your own risk.

@mr-fix Thank you for replying. The only fault code is B201A00 (please see screen shot). I only started to use the SD card port to update because of the issue. Also, I always keep the SD port empty when not in use, so I doubt it’s a corrupted SD card issue.

Anyway, I will try to update the unit using SWDL. Do you think it’s safer if I tried the SWDL method but instead of P02031D, I will use the original firmware P0216D? Just a thought.

Again thank you for your valuable input. I’ll inform my friends to subscribe to your channel so they can also benefit from your videos.
 

Attachments

  • 475499B1-BA92-43D1-B1CE-81E7594E86F4.png
    475499B1-BA92-43D1-B1CE-81E7594E86F4.png
    1.4 MB · Views: 64

Raudix11

New member
Location
Philippines
Car(s)
GTI Mk7
)This is normal after update.


I would use P0231D.
Hi @mr-fix. I finally had the time to perform the SWDL method but sadly it did not work :(. I'm starting to think that I might be having a hardware problem. I really appreciate all the suggestions you gave to help with my issue. I was really optimistic about this last suggestion but it failed. On the bright side, I did learn a lot from this experience and from your videos. Also, purchasing the OBDeleven provided me access to features on my car that I wouldn't have been able to unlock.

Again, thank you for all your help. Your videos and suggestions were truly helpful and motivated me to find a solution on my own (in a manner of speaking :)).
 

Attachments

  • IMG_3721.jpeg
    IMG_3721.jpeg
    1.8 MB · Views: 123

DenverTech99

New member
Location
Denver, CO
Car(s)
MK 7 Golf R
I have been to my VW dealership twice and asked about software updates for MIB, they tell me nothing available - I took the TSB, because it doesn't state 2017 models, they say not applicable. So left researching and trying to fix this on my own.

I have the system reboot issue with NAV chip in. I know, everyone asks why do you want VW Nav - I go into the mountains frequently, I like to see the altitude which VW Nav provides real time. Google Maps/Waze do not, and NAV should work if I want it, not cause my system to reboot. I also have random issues that require to reset the radio, volume freezing, buttons won't activate other menus, just annoying.

My MIB2 system:
  • Installed software train version: MST2_US_VW_P0628D
  • Installed software MU Version: 0751
  • Part #: 3Q0035876A
Used http://mib-helper.com/index.php?train=MST2_US_VW_P0628D#firmware
  • Latest Available: MST2_US_VW_P0879D
  • MU: 0879
  • NOTE: I read another article stating that P0635 was highest I could go to.
The link I created from reading through the thread:
https://mibsolution.one/?module=fileman&section=do&page=download&paths[]=/ROOT/1/9/MST2 - DELPHI/Firmware/VW/US/MST2_US_VW_P0879D_MU0879.7z

To no avail, I can't reach mibsolution.one:
  • Disabled firewall. Excluded mibsolution.one from threat detection
  • Home ISP (1GB synchronous - no limits); Tried Mobile tethering (5G)
  • Used Free Download Manager desktop software & Firefox extension.
  • HTTP & HTTPS
  • Tracert fails
  • Results in Timeout or Network Error
  • Used a website checker - States mibsolution.one is offline
@mr-fix - Appreciate any suggestions to get the correct files.
 

Cuzoe

Autocross Champion
Location
Los Angeles
When I click your link on my cell phone it started downloading. So your link is good.

Also navigated as normal to mibsolution.one which also worked. The site isn't down.

Worked connected to my home Wi-Fi and then T-Mobile service. Home Wi-Fi is firewalled. Don't know what if anything T-Mobile is doing. I am using a private DNS cell phone side for ad blocking purposes but that didn't cause any issues.
 

mr-fix

Drag Racing Champion
Location
Poland
Car(s)
MK7 2.0TDI Variant
@DenverTech99 Get P0635D.
Your MIBs SWDL app will not allow installation of anything outside the P06xxD family. There are ways to force firmwares from higher families but those things are risky. Stick to 06xx.

Also added couple more US FWs to mib-helper.com (v0.8.9) database. Now you should see highest supported FW for your setup.
 
Last edited:

DenverTech99

New member
Location
Denver, CO
Car(s)
MK 7 Golf R
@mr-fix - Appreciate the timely response and details on file family limitations/rev. Updated my file URL request, Download Manager continues to give Network Error.

Any other options to get the necessary files?
 
Last edited:

philbeardmore

New member
Location
North East - UK
Hi, apologies for jumping on the back of an old post, but Ive been having issues with my display not picking up touch but its been getting worse over time to the point its unusable. The system is constantly picking up false touches and changing stations and in some cases dialling people so I'm hoping a firmware update may help. Ive read it works for some but not for others so worth a shot.

Ive looked on mibsolutions and I believe Ive found the right firmware, but I'm hoping someone can confirm.

My current "Installed SW train version" is MHI2_ER_VWG11_P20103 (Its Discovery Pro and the car is a 65 plate)

I believe the latest firmware is MHI2_ER_VWG11_P2125_MU0343.

Could some kind person confirm.

Also if the issue still persists I see some people have installed the Mk7.5 display which looks to be a straight swap. Does this screen suffer from the same issues? Its doing my head in. lol.

Thankyou for your time.
Cheers
 

mr-fix

Drag Racing Champion
Location
Poland
Car(s)
MK7 2.0TDI Variant
The 8" Discover Media MK7.5 display will work as it's using the same resolution (800x480) as MK7 Discover Pro display.
 

philbeardmore

New member
Location
North East - UK
Thanks for the reply Mr-Fix, good to know. Do you happen to know if this display suffers from the same issues (touch not working or being very erratic).

Also before I change the display I'd like to try a firmware update to see if it fixes the issues. I'm not holding out much hope but I'm wondering if firmware MHI2_ER_VWG11_P2125_MU0343 is the latest version for my unit.

My unit is currently running MHI2_ER_VWG11_P20103

Thanks again
 
Top