GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

MIB1 High Infotainment Issues

Squidgify

New member
Location
United Kingdom
Car(s)
2015 VW Golf GTD
Hello all,

I am new to this forum so apologies if this or similar issue has already been identified. I recently purchased myself a 2015 VW Golf GTD which I love to bit, however, since having it these past few days and getting familiar with it, I have noticed some oddities, namely when it comes to the navigation and updating.

My car has the MIB gen1 Discover Pro (High) with Dynaudio.
Part No. = 5G0035020D
SW Ver. = MHIG_EU_VW_K1540_1

The two main issues I face is the nav unit throwing the error "The navigation data in the infotainment system are not valid". The car didn't come with the original VW SD card, however reading up around this and other forums, the High units shouldn't require the original SD card, since it is all stored on an internal HDD (correct me if I'm wrong).

I have tried to update the maps via VW official download and while the unit recognised "Software download" and I could compare the changes going into individual "folders" (i.e. NavDB, etc), however the start button at the top right of the screen is greyed out, making me unable to start the update.

I have also tried to look for an firmware update, as I saw there was a section for my unit on mibsolution.one, however none of the files under "MHIG" are available anymore.

I'm kind of stumped with my options and I'd rather try everything else before I go down the route of calling my local VW dealer. Apologies for any misunderstanding and if this has already been resolved, however any help will be appreciated.

Thanks :)
 

Squidgify

New member
Location
United Kingdom
Car(s)
2015 VW Golf GTD
Small Update: I tried hard resetting the MIB by holding the power/volume knob and upon booting up, I accessed the Nav page. It started up and showed everything except my arrow was in the middle of blue nothingness. 15 seconds later, I get the original error message back so it looks like to me something has gone wrong with the navigation files stored on the MIB. I presume this could be fixed with an update but as I have mentioned above, I haven't been able to do that.
 

Squidgify

New member
Location
United Kingdom
Car(s)
2015 VW Golf GTD
Here are some photos of exactly what I mean. Everything appears to be fine but the system doesn't want to recognise the update, with the start option being greyed out, yet it can still recognise the different versions.

Any advice would really help
IMG_20220222_181418.jpg
IMG_20220222_181433.jpg
IMG_20220222_181502.jpg
IMG_20220222_181528.jpg
 
Top