GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Issue with nav on 2017 golf r?

MDLBC

Ready to race!
Location
NYB
I've been getting the 'Checking Navigation Data' problem on the Discover Media system in my 6 month old Golf SE Nav. Have a dealer visit booked in a few weeks time.

Would it have anything to do with the current maps in the car being out of date?
How often do VW release updates for the Sat Nav?



The issue is typically with the head unit in the glovebox, not the SD card itself. The dealer will apply a firmware update which typically solves the problem.
 

dchuee

Passed Driver's Ed
Location
Dodge City
Update: my system has been working reasonably well...no major glitches after changing my cell phone from ZTE to Huawei...the only glitches were a turning off and back on of the system...once back on, it functioned normally...this happened maybe 2-4 times...not enough to be a problem, it's just noticeable...hopefully, VW has gotten a handle on the 16/17 models' issues and avoided them all together on the 18 models
 

Barzini

New member
Location
UK
So... the dealer applied the Firmware update and SatNav now appears to start as normal when ignition is switch on, without 'Checking Navigation Data' error message.

Although, driving with the Sat Nav instructions on yesterday... system suddenly cut out and the 'Checking Navigation Data' error message came on, which never happened before. Solved issue by removing and re-inserting the SD card. If it happens again, dealer will be hearing from me again.

Managed to update the SD Card to latest maps, issue was that I had to slide the white lock switch on side of SD Card to allow formatting of SD Card.

Have to say, updating the maps on this system was a massive ballache. Why do VW have such a shitty Sat Nav system and update mechanism? Can they just strike a deal with TomTom or Garmin, have a professional company deal with future in-car Sat Navs?
With my old, stand alone TomTom unit, would take me 10 mins to update using their download manager. The VW unit literally took hours to download, backup, transfer. Really disappointed, spoils an otherwise excellent car.
 

filip75

New member
Location
San Antonio, TX
Hello,

A new caller here.

At 8,600 miles my Golf R shows the same signs. Navigation restarts on its own, it goes into checking mode and gets stuck there, or becomes completely responsive to any knobs or buttons. On Tuesday I will take it in, so they can assess. I didn’t quite catch, is the shortage of the units over and will a fix be quick or is this still a long process? I will update this as I get more news.

On another note, my car just was at the dealer for three months waiting for another back ordered part (front wheel bearing), so I wonder how long will they have to give me a loaner for this time?
 

MDLBC

Ready to race!
Location
NYB
Hello,

A new caller here.

At 8,600 miles my Golf R shows the same signs. Navigation restarts on its own, it goes into checking mode and gets stuck there, or becomes completely responsive to any knobs or buttons. On Tuesday I will take it in, so they can assess. I didn’t quite catch, is the shortage of the units over and will a fix be quick or is this still a long process? I will update this as I get more news.


They will start with a firmware/software update (I believe it is up to 757 now) to see if it fixes the issue. If not, they will replace the MIB unit in the glove box. Two days for me with the update. Never replaced the MIB.
 

pukemon

New member
Location
houston, tx
17 GTI owner here. I've had my MIBII replaced already because I had serious intermittent issues not long after I bought in March '17. I just started having the same issues last week. Just caught up on this thread and hopefully the SD card trick will work. All I need is the address card and CD player to work. If I lose nav no biggie and will pursue in the next 2 months.
 

Noize1

Ready to race!
Location
Nashville
Another one. 17R. Started yesterday, right at a year from purchase and just under 9k miles. Searching for Nav and rebooted every few minutes until I removed the card. Appointment this coming Monday. Wish me luck!
 

Mosquito

Ready to race!
Location
FL
Another one bites the dust.

At 29,000 miles my 17R NAVI is no longer loading maps, etc.
Crashes the rest of the operation and eventually either turns off the screen/system or reboots it.

I have an appointment with the dealer on Monday and we'll see how that goes. They initially already tried brushing me off when I initially inquired, but if they do so on Monday when I go in as scheduled, I will speak to the dealer manager who I know and sold me various cars. Hopefully it all goes through without further pushing. (and TD1 as I am APR ST2 FBO)
Thanks for the TSB info on previous posts though. At least I can something to reference.

Device: 3Q0035876A
HW: 840
SW: O/0 751

For now I've since removed the SD card and everything else works well. Seems the NAVI is held back by the SD card. I bet they are cheap and slow to save cost putting the stress on the system, among other things. Both the car and NAVI feel like it is off better without the SD card installed. Not to mention the amount of errors having it is actually generating. Reg 13 (ACC), Reg 17 (Instruments), 5F (as expected)

I've since taken on the challenge of trying to clone the SD card in hopes to move the data to a more appropriate SLC high speed SD. Easier said than done though as the process is quite involved, but it should prove to be fun, even if they change the 5F module and fix the problem. Both SD card slots work though.

Update:
System was updated to 0755 and all is working again.
I did loose some tweaks like Offroad display, etc so would advise to backup your vcds/obd11 settings prior to work being done.
 
Last edited:

jswihart

Passed Driver's Ed
Location
Owensboro, Kentucky
Car(s)
2017 GTI 6MT
Add me to the list... What module and part-number are you all replacing them? I have a 2017 autobahn with nav, carplay, and rear view camera.
 

jswihart

Passed Driver's Ed
Location
Owensboro, Kentucky
Car(s)
2017 GTI 6MT
Just installed my new (used) texhnisat unit (3Q0035876). I came from a Delphin 3Q0035876A unit that crashed on me. I installed the Technisat one and then took to dealer for programming. They got it unlocked, but the nav does not work. The unit has/had nav, will it not work with my SD card from my old unit? Will i have to get a new SD card made for the VIN the Technisat unit came out of? Also the app conect is saying it needs a code to work. Where and how do I get one? The dealer acted like they had no clue what was going on with that. Also I can not access blutooth. Keep in mind that the unit is playing radio and everything works accept those things. Any and all help appreciated.
 

simaservis1108

Go Kart Newbie
Location
Serbia,Belgrade
Car(s)
Seat Leon 5F FR
Its internal memory failure on Delphi units.
Bad batch of them.
I fix like 2 or 3 a week here.
 

PaleLB

New member
Location
New York
Car(s)
2017 GTI Autobahn
Hey I just joined this forum because I found this thread, though it’s a bit old. I am having the very common infotainment issue - system works fine with no nav SD card. When card is in, no nav data, and constant rebooting.

I’ve got a 3Q0035876A running 0753.

I have an appointment with the dealer Monday and I’d like to be prepared for any shenanigans! Will an upgrade of software from 0753 to 0755 cure this? Or am I in for a 5F replacement, which is not going to be fun?
 
Top