GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Golf R7.5 Highline reverse view camera retrofit.

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
OK, I'm starting a new thread to try and get to the bottom of my non-working camera issue.

I'm going to attach lots of pics to show what's been done so far - probably do that in sections to break it down a bit.

The car is a 2017 Golf R mk7.5 face-lift.

The unit was purchased as a highline reverse view camera. P/n 5G0827469R.
Not sure of the wiring harness p/n but pic attached, hoping to get part number confirmed ASAP.

I've attached pics of my infotainment system.

@Fraysa
@DV52
 

Attachments

Last edited:

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
I've attached pics of the wiring in the car.

All of the wiring at the camera unit was plug and play.

The mysterious yellow wire is currently connected to the reverse light wiring and does activate the boot latch/camera when reverse gear is selected. Nothing happens when it's disconnected.

The brown wire has been connected to the earth terminal on the tailgate.

The wiring harness has been fed through the car to the glove box and the connection made in the relevant places based on all the info I've read. Connections have been checked and seen to be good..
 

Attachments

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
I don't know about the yellow cable, but my kit came with sort of an extension to the circular plug at the bottom (the one that connects to the actual emblem locking mechanism.

My kit came with sort of an extension cable. I had to unplug the original circular plug from the old emblem, connect it to the kit's circular plug input, and then connect the other end to the emblem. I assume my kit was basically doing some extension to get rid of the ground/yellow wire.

Your connection looks good, but I still fail to understand the trouble you're dealing with right now. When you put the car in reverse gear, the emblem pops out as you said, but the screen does not switch to the camera's output?

What coding/adaptations did you enable and on what modules? Can you post the list so we can verify it's correct?
 

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
I've used an OBD11 Pro to make the coding changes with info gathered from various sources.

There is nothing in the 6C Reverse View Camera section.

Pic 1 - 76 Parking Assistance - long coding.

Pic 2 - 5F Multimedia - Adaptions.

Pic 3 - 5F Multimedia - long coding.

Pics 4,5,6 - 6C Rear View Camera - long coding.
 

Attachments

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
Oh, now you posted it. My bad.

It seems like your coding for 5F is correct but you're missing the coding for 6C. Go ahead and select the appropriate options for your vehicle (e.g. Brand - VW).

I will post the selections and coding I have from my car (2016 MK7 1.4TSI) and you can try that.
 

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
Cool. It would be good if you could 👍👍

I've had a look at the 6C menu and was sort of expecting drop down boxes to fill in the gaps. I've no idea what sort of format the info needs to be or where to get some of it from.

Have you got a part number / pics of the wiring harness you used please?
 

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
This is the coding my camera has:
0184020162002017000040
Feel free to try it now. The good thing about 6C is that it won't accept incorrect coding, so you can't be wrong with this. My coding is 100% applicable to MK7 with Highline reversing cameras, so you can be sure you're safe.

Please update once you tried it.
 

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
Unfortunately I cannot answer for all of them as the text is truncated. However, it seems like the error in 5F and 19 are due to the camera missing coding and will go away after you add coding, as currently it has no coding at all!
 

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
OK, coded 6C as per your instruction.

Progress - yay 😊👍

But still not 100%, can't upload a short video so I'll explain and post pics.

Select reverse gear, camera opens and image, with active yellow lines appear (pic1) 👍👍 However, this only last for 5 seconds then the 'media screen' comes back (pic2) Deselect reverse, the camera closes after about 10 seconds - as it did before.

Then randomly - car not in reverse - the screen reverts to pic3 - lines but no camera image? Press the illuminated park assist (?) button (to off) and the image disappears.

Got to pop out in the car now, will report back if any other odd things happen.

Getting there now 👍👍
 

Attachments

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
Glad to see we have some progress. The issue you’re describing sounds to me like a wiring issue. I feel like the random screen at #3 happened because something gave signal to the MIB unit that reverse was selected, but didn’t give the camera signal to open.

Besides the purple/brown & orange/brown & black/white cables you connected to the Quadlock connector, did you have any other cable? Perhaps a red one?
 

Matt.K

New member
Location
South Wales
Car(s)
Golf R 2017 mk7.5
Glad to see we have some progress. The issue you’re describing sounds to me like a wiring issue. I feel like the random screen at #3 happened because something gave signal to the MIB unit that reverse was selected, but didn’t give the camera signal to open.

Besides the purple/brown & orange/brown & black/white cables you connected to the Quadlock connector, did you have any other cable? Perhaps a red one?

OK, the only other wire that was (still) connected was the yellow one to the reverse light wire.

I've disconnected it - now the camera opens when reverse is selected (can bus? 👍) - and stays open with the camera image on screen - but stays open even when reverse is deselected and won't now close.

One step forward.............🙄
 

Fraysa

Go Kart Newbie
Location
Israel
Car(s)
2016 MK7 1.4TSI
This is actually a feature, not an issue. The camera stays open until you reach 15Km/h (9 Mp/h).

This is to make it easy when maneuvering out of a tight parking spot which requires a lot of gear switching between drive and reverse.
 
Top