GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Emmanuele springs loud after install - thoughts?

MiamiBourne

Go Kart Newbie
Location
New York
I got my Emmanuele Design springs installed today using the ECS spring install kit and its loud. Squeaks over speed bumps, rattles and clicks over any road surface that's not smooth.

Is this normal with spring upgrades? Is there a break-in period?

I was expecting a quiet car with this upgrade.

I may have to go back to stock if this is normal, the sounds are extremely annoying.

I too have ECS mounts/bearings... interesting

I just installed VWR springs with the same ECS HD kit and i'm getting similar noises. No clicks just creeking and noises over harsh bumps. Its fine 90% of the time. I did install them myself. So I don't think the springs are the problem.

Do anyone know which bolts/ nuts need to be torqued down with the car fully on the ground?

Edit: I also notice more noise when its cold in the mornings. Its been around 40- 45 degrees out here

So i installed ED Springs and the ECS Heavy Duty Strut mount kit and I have to say that I also get squeaking noises. I installed them last November and thought the cold could have something to do with it. I noticed before installed the ECS Heavy Duty Struts that they do seem hard (all metal?). I mean the OEM ones have rubber and i thought the material from the ECS Strut Mount might add noise or maybe a more harsh driving experience? I've installed springs and coilovers a few times on my old MKIV while replacing OEM bearings and struts mounts without any noise issues. I also followed the DAP and ED videos on youtube to make sure I oriented the strut mount and bearing appropriately. It's cold now so I can't check much. When it get's warmer I'll check to make sure everything is tight but there seems to be a few people with the ECS Heavy Duty Strut Mounts having the same issue...
 

SouthbayMK7

Ready to race!
Location
Pomona CA
So i installed ED Springs and the ECS Heavy Duty Strut mount kit and I have to say that I also get squeaking noises. When it get's warmer I'll check to make sure everything is tight but there seems to be a few people with the ECS Heavy Duty Strut Mounts having the same issue...

I would have to agree with you, I wonder how they compare to 034 Motorsports strut mounts? They just came out with a re-designed version so I wonder if they had similar problems in development.
 

nype

Drag Racing Champion
Location
Vancouver, B.C.
Well folks, I just had all the stock parts put back in, and it's quiet again. Silence is a thing of beauty when it comes to suspensions!

I'll probably be posting the ED springs and ECS kit for sale tomorrow if someone wants to snatch them up.

My wallet will be hurting from this this little adventure for a while.



Sorry about it. Sucks...

Wondering if you thought to try springs alone, without the ECS HD kit?
 

lokerola

Ready to race!
Location
Alexandria VA
So i installed ED Springs and the ECS Heavy Duty Strut mount kit and I have to say that I also get squeaking noises. I installed them last November and thought the cold could have something to do with it. I noticed before installed the ECS Heavy Duty Struts that they do seem hard (all metal?). I mean the OEM ones have rubber and i thought the material from the ECS Strut Mount might add noise or maybe a more harsh driving experience? I've installed springs and coilovers a few times on my old MKIV while replacing OEM bearings and struts mounts without any noise issues. I also followed the DAP and ED videos on youtube to make sure I oriented the strut mount and bearing appropriately. It's cold now so I can't check much. When it get's warmer I'll check to make sure everything is tight but there seems to be a few people with the ECS Heavy Duty Strut Mounts having the same issue...

I would have to agree with you, I wonder how they compare to 034 Motorsports strut mounts? They just came out with a re-designed version so I wonder if they had similar problems in development.

Ahhh so the problem might actually be the ECS Heavy Duty Strut mount kit. It does kinda makes sense if you think about it.

Sorry about it. Sucks...

Wondering if you thought to try springs alone, without the ECS HD kit?

I'm trying not to cry in my beer and think about the nice set of VMR V701's and Michelin Pilot's I could have bought for the same money I've dumped into the Great-Spring-Debacle-of-2016. But life goes on....

As many of you have commented, I'm wondering if the ECS HD kit was the source, or major contributor to the squeaking. If I had a garage and could take my time to swap out the ECS kit for the stock mounts, that's what I would have done. But I just couldn't cough up another $650 to test putting the stock mounts back in and leaving the ED springs installed. If it still squeaked, it would have cost $650 again to go totally stock. By that point I would have sunk enough money to have gone stage II APR with an intercooler and other goodies.

Anyway, my .02 to all of you is to carefully research the mount kits. Maybe stock is the way to go, or the revised 034's? I can't say I have confidence that the ECS HD kit, combined with the ED springs will lead to a quiet ride.

Good luck to all of you and raise a glass to the dollars burned in the Great-Spring-Debacle-of-2016! Damn you 2016!!!
 

Firstboost

Go Kart Champion
Location
East Bay Area
I purchased ed springs and received them today. I'll be sure to report if I have any odd noises. I'm at 5800 miles and will reuse my factory equipment.
 

MiamiBourne

Go Kart Newbie
Location
New York
I'm trying not to cry in my beer and think about the nice set of VMR V701's and Michelin Pilot's I could have bought for the same money I've dumped into the Great-Spring-Debacle-of-2016. But life goes on....

As many of you have commented, I'm wondering if the ECS HD kit was the source, or major contributor to the squeaking. If I had a garage and could take my time to swap out the ECS kit for the stock mounts, that's what I would have done. But I just couldn't cough up another $650 to test putting the stock mounts back in and leaving the ED springs installed. If it still squeaked, it would have cost $650 again to go totally stock. By that point I would have sunk enough money to have gone stage II APR with an intercooler and other goodies.

Anyway, my .02 to all of you is to carefully research the mount kits. Maybe stock is the way to go, or the revised 034's? I can't say I have confidence that the ECS HD kit, combined with the ED springs will lead to a quiet ride.

Good luck to all of you and raise a glass to the dollars burned in the Great-Spring-Debacle-of-2016! Damn you 2016!!!

Sorry to hear about your troubles. If I was close by I would help you do the install. Maybe someone local can help you out. I mean some people post on the regional forums for help and all you need is to provide beer and maybe pizza. That might help make up what you lost if you found it was just the ECS mounts. Just a thought.
 

MiamiBourne

Go Kart Newbie
Location
New York
So I email ECS Tuning to inquire about the noises I've had and some on the forum had. They gave me an rma number so I can return them but said they haven't heard of this issue. I'm not returning them yet since it's winter but when it's warmer I'm going to swap back in the OEM strut mounts and see if I have still have the noise.
 

xl1200r

Ready to race!
Location
Albany, NY
Interesting. Are you on stock wheels/tires?

I didn't think anyone was getting rubbing with just springs and spacers like the ECS flush kit (15mm spacers front, 20mm rear).

Maybe the ED springs sit lower or travel more than say the VWR springs?

I can confirm that I get a little rubbing on the fender screws with stock Austins, VWR springs and ECS's flush kit, but I am running snow tires right now which have a more squared edge on the tread. With the summer tires back on, I bet I'd be fine.


So I email ECS Tuning to inquire about the noises I've had and some on the forum had. They gave me an rma number so I can return them but said they haven't heard of this issue. I'm not returning them yet since it's winter but when it's warmer I'm going to swap back in the OEM strut mounts and see if I have still have the noise.

I call BS. This is not the first time someone has complained about strange noises after a spring install, and it always seems traceable to the ECS bearings/mounts.
 

SouthbayMK7

Ready to race!
Location
Pomona CA
So I email ECS Tuning to inquire about the noises I've had and some on the forum had. They gave me an rma number so I can return them but said they haven't heard of this issue. I'm not returning them yet since it's winter but when it's warmer I'm going to swap back in the OEM strut mounts and see if I have still have the noise.

Please let us know after you get the OEM mounts back in if the noise goes away. I'm having the same problem.
 

MiamiBourne

Go Kart Newbie
Location
New York
Please let us know after you get the OEM mounts back in if the noise goes away. I'm having the same problem.

I will, but it won't be until probably May or June.
 
The springs are not your issue. If you add a stiffer durometer rubber, it's unreasonable to expect it to feel and sound the same as stock. Typically you will notice more feedback over bumps (sometimes manifesting in a clunk) and the described squeaking/creaks. If you want noise free, you will need to put the stock upper mounts back on.
 

BxGTI

Go Kart Champion
Location
Bronx,NY
I will, but it won't be until probably May or June.



Maybe I'm wrong but chances are that the noise could be gone by then, getting warmer and all. I could be wrong but it's actually good that you leave them on and test them


Sent from my iPhone using Tapatalk
 

MiamiBourne

Go Kart Newbie
Location
New York
The springs are not your issue. If you add a stiffer durometer rubber, it's unreasonable to expect it to feel and sound the same as stock. Typically you will notice more feedback over bumps (sometimes manifesting in a clunk) and the described squeaking/creaks. If you want noise free, you will need to put the stock upper mounts back on.

This is what I thought when I felt the strut mount material so I agree with you there. I thought this might make the ride stiffer and noisier, but don't they advertise (ECS, 034, etc) these as being quiet and not having squeaks, noises associated with stock mounts going bad?

Oh well...thanks for you input. Love the springs.

Maybe I'm wrong but chances are that the noise could be gone by then, getting warmer and all. I could be wrong but it's actually good that you leave them on and test them


Sent from my iPhone using Tapatalk

I think you could be right...I mean I feel they are quieter and almost have no noise once it's warmer than the winter average and I've driven around a bit. I'm glad I DIY'd this...I'm only losing time and some effort. Lol.
 
Top