GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

DIY MIB1 to MIB2 Infotainment Conversion (Part 1)

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
And if you're a struggling artist down on their luck, you can always try this. You just need a USB to Ethernet adapter with the ASIX AX88772 chipset and the remote programmer guys can update the firmware remotely for you along with all the remote programming that you're getting them to do if you'd rather not do the firmware update yourself.
 

bmxdarcy

New member
Location
Alabama
Car(s)
2015 Sportwagen TDI
Hey guys, I had been trying to lurk my way through this swap but now I'm stuck. I think it may be either I purchased in-compatible part numbers for the screen and infotainment unit or because I haven't installed the USB yet and still have the MDI Cable installed, (although that seems unlikely to me). We have ODIS at work so CP was removed and for the most part everything seems to work but no sound. I have the same issue HawkAssault described a couple pages back where the turning the volume nob just shows a full red bar but no sound. Here's the info for reference, let me know if you want a scan. Can anyone guide me?

I have a 2015 Sportwagen TDI NAR which came with Fender audio.

Parts purchased: 3G0 035 043 C and 5G0 919 606

In VCDS - Module 47 Coding:
12000000AAAAAA0000

Module 5F Adaptations all confirmed exept:
IDE03471-ENG07590-Fahrzeugkonfiguration-Mirror_link,function_on_hmi_on: change to "on" - This adaptation option does not appear

Bluetooth and telephone functions are 'not available' at the moment as well.

Thanks in advance!
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
Sounds similar to what I went through and documented a few posts earlier here I had also suggested to @HawkeAssault to replace his Fender Amp here . I assume HawkeAssult went through with replacing the amp and was successful as no further posts on the matter since. I think you have the same issue but I find it interesting is that you have a European Discover Pro and it wasn't a hacked unit (or at least you haven't disclosed that you removed CP on a hacked unit). So far on the small sample size I had seen mainly the NAR Discover Pro headunits being the common link in units that cannot be made to work with the MIB1 Fender amp.
 

HawkeAssault

Go Kart Newbie
Location
Arizona Tucson/Phoenix
Car(s)
'15 GTI, '92 Corrado
Sounds similar to what I went through and documented a few posts earlier here I had also suggested to @HawkeAssault to replace his Fender Amp here . I assume HawkeAssult went through with replacing the amp and was successful as no further posts on the matter since. I think you have the same issue but I find it interesting is that you have a European Discover Pro and it wasn't a hacked unit (or at least you haven't disclosed that you removed CP on a hacked unit). So far on the small sample size I had seen mainly the NAR Discover Pro headunits being the common link in units that cannot be made to work with the MIB1 Fender amp.
I haven't got the new amp in yet. I do have an amp out of a 2017 GTI buuuuuuuut I've not gotten around to scheduling an appointment with my dealer to remove CP.
 

George Ab

Drag Racing Champion
Location
Pacific NW
Hey guys, I had been trying to lurk my way through this swap but now I'm stuck. I think it may be either I purchased in-compatible part numbers for the screen and infotainment unit or because I haven't installed the USB yet and still have the MDI Cable installed, (although that seems unlikely to me). We have ODIS at work so CP was removed and for the most part everything seems to work but no sound. I have the same issue HawkAssault described a couple pages back where the turning the volume nob just shows a full red bar but no sound. Here's the info for reference, let me know if you want a scan. Can anyone guide me?

I have a 2015 Sportwagen TDI NAR which came with Fender audio.

Parts purchased: 3G0 035 043 C and 5G0 919 606

In VCDS - Module 47 Coding:
12000000AAAAAA0000

Module 5F Adaptations all confirmed exept:
IDE03471-ENG07590-Fahrzeugkonfiguration-Mirror_link,function_on_hmi_on: change to "on" - This adaptation option does not appear

Bluetooth and telephone functions are 'not available' at the moment as well.

Thanks in advance!

Verify that you made the coding changes to the 5F head unit is set to work with Fender Amp. Bytes 01-07, byte 11, and byte 19 (MOST on): https://www.golfmk7.com/forums/index.php?threads/recoding-the-radio-to-eliminate-fender-amp.341803/ You mentioned adaptations, but not coding; the unit pulled may not have come from a non-Fender configuration so they would have to be changed. The thread I pointed to shows how to perform with both VCDS and OBD11.

Maybe the Fender amp, but my understanding is the MIB1 Fender amp works with MIB2 head unit with the code change you made. It has been recently found that MIB2.5 head units and now the MIB2 3G0 035 047 (thanks for info madwazzabi (I will update original thread)) do not play well with the MIB1 Fender amps. The MIB2 amp does sound better than the MIB1 amp, so you may consider that.

For blue tooth, CarPlay, drive modes you will need FeC's installed. To install you will need the USB cable.
 
Last edited:

Blade3562

Autocross Newbie
Location
Earth
Car(s)
None
Does anyone have the part number for the USB/Aux cable? I have located all the parts aside from that for my install in my 2015!
 

Cuzoe

Autocross Champion
Location
Los Angeles
I don't know that I've ever seen the part number for the cable, only for the USB port itself; 5G0035222E, somewhere around $50 from the dealer. Many just ordered the cable/port from AliExpress. I believe EZT sells the cable/port or just the cable by itself. I would assume they have US stock so might be worth the premium if you're in a hurry.
 
Top