GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

DIY MIB1 to MIB2 Infotainment Conversion (Part 1)

Cuzoe

Autocross Champion
Location
Los Angeles
...And the by the way these forum semms to dead to me , I had did some research on going through a million webpages of information and analyzing and filtering what I need...
You didn't use any question marks, :ROFLMAO:. Only poking fun, but I might recommend putting your questions at the top of the post and the copy/paste of the faults after.
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
It's been a long journey but I'm almost done my MIB2 retrofit on my Canadian NAR 2015 GTI Autobahn. Either opportune timing, or just plain luck (ebay seller sold it to someone in WA, USA who sold his GTI before being able to install it and got us in touch, thanks @rrador I believe), I had a chance to get a Hacked 3G0 035 047 head unit to stick to NAR parts for radio compatibility and Discover pro for future AID install (maps on dash and center console).

So what I've learned, yes there is indeed a unit that will not work with the MIB1 fender amp. It seems to be the NAR Discover Pro unit. Not sure why, possibly the files used to do the Hack are from files from ROW units and the slight differences in the units causes it not to recognize the MIB1 fender amp? Just thoughts floating in my head but ROW Harman 3G0 035 0## units have worked with success since EZT retrofit kits uses these. MIB2_STD (3G0 035 8##) units for sure work with the MIB1 fender amp as far as all the retrofits members have shared seem to state.

Major thanks to @simaservis1108 for troubleshooting and confirming amp could not be made to work from what we currently know.

Maybe it will be figured out before the last '15 GTI retrofit gets completed... but not for me. But thank goodness for Aliexpress, brand new OEM 5Q0 035 456A for $322 CAD shipped and it came in 14 days.

So one thing that might be of interest for anyone who still has MDI connectors doing this retrofit. I opted not to abandon the old cable nor did I pull the harness that came with new USB/Aux port. The green connector can be reused, and if you have a de-pinning tool, you can reuse the can-bus cables associated to the MDI port by popping out the cables from the TE 1534101-1 connector that plugged into your old 5G0 035 222A. You can save money by not buying the harness but you still need to buy a 2pin and 4 pin connector. The yellow and green highlights are the individual cables needed to make the USB/AUX work. The rest can be abandoned.

2021-07-21 13_08_10-Book1.xlsx - Excel.png
CAN BUS.jpg
MDI.jpg


For the two pin connector for USB power (red & shiny black) above the green connector, I used Audi part 4B0 972 623 and shaved off the surround to fit. Accepts the same size pin terminals extracted from the TE 1534101-1 connector.

4B0 972 623.jpg
4B0 972 623 - cut.jpg
4B0 972 623 - fit.jpg


Your wiring to the AUX in port (brown, yellow, green, dull black) will need to either reuse the connector that came with your USB/Aux harness or bought separately (connector PN TBD)

HTB1onMfkyQnBKNjSZFmq6AApVXad.jpg


I am almost done, just need to get the CP removed from the Amp and I'm good to go.

For those who planning to buy all the remote tools:
- D-Link DUB-E100 you can find these days won't work because they use the Realtek 8152B modem. Finding one with an ASIX chipset is essentially impossible.
- But shopping for ASIX AX88772 you'll find other compatible USB ethernet adapters. I was recommended the uGreen USB ethernet adapter P/N:20254 which you can get from Amazon quite quickly. Edit2: As is, the uGreen adapter will not work, some changes to the firmware will need to be done. Sima will do it remotely.
- The 5054A clone that I bought from Aliexpress is still active for those who want to buy your own unit. Aliexpress 5054A. Mine will soon be going up for sale once all is done or for rent if there is still a demand in Canada for this. (shipping from our friends in the USA is not really cost effective and the losses on exchange rates for exchanging deposits is just a waste).

After all that... I finally got what I was looking for... keeping the radio/bluetooth on after shutting off the ignition!!! I truly find it weird that Kessy ALL (EDIT: just read the owners manual, there's no accessory position on the ignition switch??? really???) models do not have a true accessory mode. Pressing Start/Stop without brake should have cycled through accessory-->systems on-->off. Running the car stalled, or hitting the radio power button in which the radio stays off until you manually turn it on on the next ignition just seems like a half baked solution. Oh, and that Android auto stuff is nice too I guess 😆.

(EDIT: as a teenager I drove my dad's 1989 Mercury Sable (Ford Taurus equivalent) and as a poor grad a 2004 Toyota Echo, Ford did the notch behind off for accessory, while the Echo used the notch between Off and On for accessory. I guess VW with MIB1 figured you should get your ass out as soon as you're finish driving. :ROFLMAO:. I liked the Toyota implementation best since you could turn off the engine into accessory mode without interruption to what you were listening to)

EDIT2: Finished the upgrade, shoutout again to @simaservis1108 another happy customer. Got everything in order super quick. A few things to make sure things go as smoothly. Unless your wifi is great all the way to your garage/driveway, in addition to TeamViewer, download latest version of VMWare workstation Pro, and debian-live-10.10.0-amd64-gnome ISO operating system. definitely want to get 3GB of downloads out of the way with as good of a network connection as possible.
 
Last edited:

Cuzoe

Autocross Champion
Location
Los Angeles
@madwazzabi Have you tried a phone call on bluetooth with the engine off? In my car, which was also retrofitted, the microphone turns off some time (maybe a minute) after turning off the engine. Bluetooth audio will continue to work however. My car does not have KESSY so I didn't have the same issue with no accessory mode. But it was initially a weird thing to be talking on the phone, get to my destination and turn the engine off (bluetooth audio still on, so I can hear the person talking) and then after some time they could no longer hear me.
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
I've not tested to that extent. The retrofit was done recently and the car in the garage due to Covid work from home, I've been doing only short tests to confirm my system is working. I'm trying to arrange with Sima in the next few days to get the last few items (Amp CP, fine tune the MIB2 coding to my car). Once done and all the speakers are back up and running I'll give it a try.
 

Cuzoe

Autocross Champion
Location
Los Angeles
Gotcha, not a concern for me, was just curious if it was the same on a car with KESSY... and to keep you from yelling at the person on the other line after you park.
 

Ioozz

New member
Location
United states
Car(s)
MK7 TDI
Hey everyone,

another MIB2 retrofitted into mk7! :)

First of all, thanks to @George Ab for renting out his equipment, and thanks to @simaservis1108 for his patience with semi-noobs like me. It's because of people like George and Sima we're still here on this planet!


Brief description of the process!

My car:

2015 Golf TDI with Mib1 and Fender Audio, no USB, 5 inch display

What I needed:

Parts:

Mib2 headunit
[Ebay, $140]
6.5 display [Ebay, $100]
USB+Aux Harness [Ebay, $40]
USB + Aux connector [made a mistake of ordering harness WITHOUT the connector, so had to buy a connector from an official stealereship for $60 - make sure to order yours on AliExpress or Amazon, since you'd save a lot of money, just do it in advance. I decided to spend this money, since I didn't want to wait any longer]

Tools:

Vas5054a
[rented from @George Ab ]
D-Link Dub e100 [rented from @George Ab ]
Dedicated trim keys to remove both MIB headunit and the screen [rented from @George Ab ]
Knife to adjust the harness to fit the new screen - though Dremel tool is preferable
SD Card
Windows-based laptop [
rented from local Rent-A-Center for $20 bucks for a whole week[
LAN cable
SD card reader [
my laptop didn't have an SD card port]
Another Ethernet USB adapter (brand doesn't matter for this one) [bought and returned to Best Buy]
Fiberglass Pull Rods to pull the new harness from the glovebox to the cubby [Harbor Freight, $7]


Process:

Once you got all the right parts and tools, the process is really fast. It's described in the article provided in the starting post of this thread. Just make sure to follow the instructions and don't skip any parts unless you know why you skip them. For example, you'll need to pull the old harness off a block connector in the head unit and replace it with the new one, so make sure you do so; your USB port part number must be one of those that support Carplay - even if you got USB port, you are not guaranteed to have CarPlay; you'll have to cut a few ridges off some of the cables so they fit - nothing crazy (just don't get frustrated if something won't fit - most probably it's just those ridges preventing this, so don't worry).

Like everyone else here says, fishing the cable from the glovebox to the cubby would be the most difficult (relatively) part, but having the fiberglass rods or any other tool would help immensely.

After the physical replacements are done, time to call @simaservis1108, who will do everything for you. Make sure the connection is good, install TeamViewer, and make sure to have ALL of the things I mentioned to avoid having to run back and forth.

DO NOT BUY ANY ACTIVATION CODES
DO NOT GO TO THE DEALERSHIP TO REMOVE CP
DO NOT BUY MIB2 AMP FOR YOUR FENDER - YOUR AMP WILL WORK JUST FINE (UNLESS YOU WANT TO HEAR SOME SEXY SOUND IMPROVEMENTS)
- you'll waste your money.

Just do the replacement and simaservis will take care of the rest.

I'm glad to answer any questions as I have the most recent information about the process as of today! :)
Do you have a link to the seller for your head unit? Not finding any less than $350
 

Blake1090

Go Kart Champion
Location
Bay Area, CA
Car(s)
MK7 R
Can 3Q0035880B headunit be used for retrofit? I see a lot of these available compared to 3Q0035876.
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
Gotcha, not a concern for me, was just curious if it was the same on a car with KESSY... and to keep you from yelling at the person on the other line after you park.
@Cuzoe just tested. for a full two minutes after turning off ignition microphone continued to work while connected to Bluetooth. I opened the door and then infotainment shut off and call continued from the phone itself. Confirmed by scratching the plastic by the sunglass holder/microphone during the test.
 

HawkeAssault

Go Kart Newbie
Location
Arizona Tucson/Phoenix
Car(s)
'15 GTI, '92 Corrado
Alright so I’ve just installed my MIB2.5 unit and I can’t my sound to work. I’ve got a NAR 2015 GTI With Fender Audio and an Active Info Display. I had a EuroZoneTuning MIB2 in before this one.

I’ve been messing around in VCDS and looking things up but I can’t get my audio to come up.
 

George Ab

Drag Racing Champion
Location
Pacific NW
Alright so I’ve just installed my MIB2.5 unit and I can’t my sound to work. I’ve got a NAR 2015 GTI With Fender Audio and an Active Info Display. I had a EuroZoneTuning MIB2 in before this one.

I’ve been messing around in VCDS and looking things up but I can’t get my audio to come up.

Since the Fender amplifier worked with the previous MIB2 the Fender amplifier has been programmed to accept so I would think Fender amp is not the issue. I assume you verified that the new headunit's output is set to external vice internal amplifier as discussed in initial thread?

"Vag-Com changes: Since your unit is likely from salvage it is already coded with adaptations all sorted. However, you should check a couple of things in the 5F module. Check bytes 4 and 11 if you have a Fender System as the donor unit may not have come from an external amp unit. In my case I did have to change the values to the original values of byte 4 to 00 and byte 11 to 02. Also verify byte 19 is set for USB iPhone fully functionality."
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
Alright so I’ve just installed my MIB2.5 unit and I can’t my sound to work. I’ve got a NAR 2015 GTI With Fender Audio and an Active Info Display. I had a EuroZoneTuning MIB2 in before this one.

I’ve been messing around in VCDS and looking things up but I can’t get my audio to come up.
Would like to see if there is a pattern to this... what is your symptom? Turn the volume knob and volume pop up on screen is a solid red (like it is at max volume) with no adjustment no matter what direction you turn?

What part number for the MIB2.5 did you use? Would it happen to be the NAR unit 5NA 035 026? (or reprogrammed 3G0 035 047)

Hacked or reprogrammed from stock by one of the remote programmer guys like Sima or Jack?
 

HawkeAssault

Go Kart Newbie
Location
Arizona Tucson/Phoenix
Car(s)
'15 GTI, '92 Corrado
Would like to see if there is a pattern to this... what is your symptom? Turn the volume knob and volume pop up on screen is a solid red (like it is at max volume) with no adjustment no matter what direction you turn?

What part number for the MIB2.5 did you use? Would it happen to be the NAR unit 5NA 035 026? (or reprogrammed 3G0 035 047)

Hacked or reprogrammed from stock by one of the remote programmer guys like Sima or Jack?

This is the 9inch screen with no nob but yes, it’s the solid red and doesn’t produce any sound.

My MIB2 was a hacked European unit.

I don’t know the part number at the moment but ill get back to you.

This new one came from a guy on the forums. @rraddor
He said it came out of a RS3.




Since the Fender amplifier worked with the previous MIB2 the Fender amplifier has been programmed to accept so I would think Fender amp is not the issue. I assume you verified that the new headunit's output is set to external vice internal amplifier as discussed in initial thread?

"Vag-Com changes: Since your unit is likely from salvage it is already coded with adaptations all sorted. However, you should check a couple of things in the 5F module. Check bytes 4 and 11 if you have a Fender System as the donor unit may not have come from an external amp unit. In my case I did have to change the values to the original values of byte 4 to 00 and byte 11 to 02. Also verify byte 19 is set for USB iPhone fully functionality."
The only really difference with the MIB2 was in order to get the sound to work I had to change the sound system from Fender to Dynaudio.
I believe I checked those bytes in the system but I will have to go back and verify.
 

HawkeAssault

Go Kart Newbie
Location
Arizona Tucson/Phoenix
Car(s)
'15 GTI, '92 Corrado
Would like to see if there is a pattern to this... what is your symptom? Turn the volume knob and volume pop up on screen is a solid red (like it is at max volume) with no adjustment no matter what direction you turn?

What part number for the MIB2.5 did you use? Would it happen to be the NAR unit 5NA 035 026? (or reprogrammed 3G0 035 047)

Hacked or reprogrammed from stock by one of the remote programmer guys like Sima or Jack?
B2E922BC-C9E0-483F-ABEC-74C4B4390158.jpeg

this is the new unit
 

madwazzabi

Passed Driver's Ed
Location
Toronto, Canada
Car(s)
2015 GTI Atbhn PP
Considering it has SiriusXM I believe it is a NAR unit (I don't think they get SiriusXM across the pond) but interestingly enough I had the same problem with my NAR MIB2 headunit 3G0 035 047.

I bought it from a referral by an Ebay seller that I suspect is the same person as rrador on this forum. But still, quite a bit of parallels with the same problem... (is it due to NAR model MIB2/2.5 headunit vs is it due to the files used to unlock the hacked unit by rrador?)

But at this point, I can probably recommend you buy the MIB2 fender amp. You can try your luck to see if can have one of @simaservis1108 or Jack return the firmware and files to stock and then do the standard remote programming to get the FeCs applied. But by then you've likely spent enough on services to have bought the new amp which negates the point of seeing if you can get it to work with the MIB1 amp.

I can at least tell you that you can get a brand new one for $252USD shipping included from aliexpress https://www.aliexpress.com/item/1005002408498095.html?spm=a2g0s.12269583.0.0.73887798em5TOk

The link is the seller I bought from. Came in 14 days exactly. You'll still need to get someone to remove CP.
 

HawkeAssault

Go Kart Newbie
Location
Arizona Tucson/Phoenix
Car(s)
'15 GTI, '92 Corrado
Considering it has SiriusXM I believe it is a NAR unit (I don't think they get SiriusXM across the pond) but interestingly enough I had the same problem with my NAR MIB2 headunit 3G0 035 047.

I bought it from a referral by an Ebay seller that I suspect is the same person as rrador on this forum. But still, quite a bit of parallels with the same problem... (is it due to NAR model MIB2/2.5 headunit vs is it due to the files used to unlock the hacked unit by rrador?)

But at this point, I can probably recommend you buy the MIB2 fender amp. You can try your luck to see if can have one of @simaservis1108 or Jack return the firmware and files to stock and then do the standard remote programming to get the FeCs applied. But by then you've likely spent enough on services to have bought the new amp which negates the point of seeing if you can get it to work with the MIB1 amp.

I can at least tell you that you can get a brand new one for $252USD shipping included from aliexpress https://www.aliexpress.com/item/1005002408498095.html?spm=a2g0s.12269583.0.0.73887798em5TOk

The link is the seller I bought from. Came in 14 days exactly. You'll still need to get someone to remove CP.
Ughhhhhh why does everything turn out to be way more work than necessary. I’ll check out that 2nd Gen amp though.
Would a dealer be able to remove component protection on the amp or would I need someone to remotely preform that?
 
Top