GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

DIY MIB1 to MIB2 Infotainment Conversion (Part 1)

George Ab

Drag Racing Champion
Location
Pacific NW
Thanks for all the suggestions, I will try pulling it out and wiggling the cables that might actually be the problem because of how I routed the new usb harness to go to the Head Unit. And if it did end up being the Head Unit, then its possible to have the FeC transferred so I would not have to pay for App Connect activation again?

Correct, you should not have to pay a second time for the App Connect FeC based on my experience. I did not have to pay a second time for the app connect FeC. I went with the same person who assisted with the original MIB1 to MIB2 conversion when I did the MIB2 head unit replacement. I paid $50US for CP removal and FeC reinstall.
 

CollinK101

New member
Location
Wisconsin
Correct, you should not have to pay a second time for the App Connect FeC based on my experience. I did not have to pay a second time for the app connect FeC. I went with the same person who assisted with the original MIB1 to MIB2 conversion when I did the MIB2 head unit replacement. I paid $50US for CP removal and FeC reinstall.
Okay that's not bad for CP plus the reinstall. I will try messing with the harness when I have more time, hopefully that's the issue. If not, I'll be searching for a new head unit.
 

luckyluuk

New member
Location
Spain
Car(s)
Golf 7 1.2TSI 2015
Upgrade done!!

Last week @simaservis1108 did all the heavy programming work on my car remotely and all works like a charm 🙌

Last time I was waiting for a d-link that I ordered 2nd hand (new model). After switching the USB connector and harness it still wouldn't let it "talk" to the MIB. So either the d-link was faulty or my MIB was messed with...
I have used the old d-link and it worked well to install the FeC's. It sounds like you are almost there for the MIB2.5 and have all the hardware with the addition of a D-link simaservis will be able to remove CP and install FeC's.

As a last solution Sima recommended me to buy a "PL2303 USB to UART TTL Cable Module RS232 Serial 4-Pin PL2303HX Cable" that goes directly into the back of the MIB which I found on amazon Spain for €9,- and 1 day delivery. This worked :) so the d-link was broken and thank god not the MIB.

Off topic, I also let him program my virtual cockpit and a new CANBUS High. Unfortunately the new High CanBus series 5Q0.... was not that High so I had to find another one to get the full stuff out of the cockpit... a 3Q0 series that luckily I found here for just €30! It's being shipped as we speak!

Same goes for the MOST cable, I had to order a new one since the Y cable that I rebuild into a straight one was literally 2 inch too sort! This is an Aliexpress delivery which unfortunately takes another 2 weeks.
You only need the MOST Y cable if you also have the amp under the front seat (Fender, or Dynaudio). Otherwise you just need a straight MOST cable to go from the MIB 2.5 to the Digital Cockpit).

MOST does not connect to the screen though, so nothing to worry about there.

When all is in-house @simaservis1108 told me to contact him ones more to do the final setup. Awesome guy, super skilled, extremely helpful and even more patient! Highly recommended 👍

Photos will come soon!
 

krissjw

New member
Location
UK
Car(s)
Golf mk7
Got in touch with @simaservis1108 who helped me find the right parts to replace my MIB1 unit for MIB2 and larger screen. Super helpful and patient as we worked through issues as they popped up. Worked some magic on my USB controller as it wasn't functioning. I now have a 2013 golf with CarPlay/AndroidAuto which is great. Thanks for your help @simaservis1108

As a side note i now have all the cables / adaptors if anyone wants to get in touch to use them for some work. based in south London.
 

Amaster85

Passed Driver's Ed
Location
New York
Be careful which USB port and cables you buy from AliExpress. I purchased one back in April? And I was having trouble with CarPlay not working and was blaming everything else besides the USB port and the cables from that kit. After multiple phones and multiple charge cables I ordered a cable from the seller Aidu Auto and I put it in today and it works flawlessly. The last one must’ve had a loose connection and would lose it over bumps and rough roads and even when I closed the glove box. The new one I have no issues with when closing the glove box and banging on the plastic around it. And it appeared to be of much higher quality because the connectors actually have metal and aren’t all plastic.

I highly recommend this cable. I paid for fedex shipping and it was here in less than a week.


US $25.00 | FOR VW Golf MK7 CarPlay media AUX MIB2 PRO USB AMI Install Plug Socket Switch Button Harness 5G0 035 222 E 5G0035222E
https://a.aliexpress.com/_mKRkvN3
 

ericek565

Ready to race!
Location
Slovakia
Car(s)
Mk 7 Variant 2.0
Hi guys,
Does anyone know if the MIB 2.5 will work temporarily with the 8inch screen.
I have the unit and i want to try if it works. But the screen will arrive next week.
 

simaservis1108

Go Kart Newbie
Location
Serbia,Belgrade
Car(s)
Seat Leon 5F FR
No,it will not.
What was the original unit?
 

sdmcoupe

Ready to race!
Location
San Diego
Car(s)
2015 VW GTI SE
So I have a 2015 GTI and I went from MIB 1 to MIB 2, everything on it works but randomly my app connect will stop working / disconnect from my phone. I have a Oneplus 7 pro, but have tried with my friends iPhones and it was no different. It can happen twice in a 2 hour drive or every 2 minutes for my entire drive. Its at the point that I just switch over to bluetooth but the whole point of going to MIB 2 was for app connect.

Fixes I have tried:

I have given my head unit (3Q0035876A) to my electrical engineer friend and he looked through the board and had seen no issues.

My first USB/Aux and harness was from AliExpress, I just got an oem USB/Aux 5G0035222E from ecstuning and that still did not solve the issue.

The only thing left that I can think to try is get a new harness from Ali express, I haven't seen an oem harness on ecstuning.

Has anyone experience any issues like this?
I had the same problem and it was extremely annoying. I would constantly loose connection to my phone. Ended up being an issue with the connection on my phone. A common issue apparently on Samsung S9's. Took the phone to a phone repair shop and they fixed it. It's been working great ever since.
 

Mike5250

New member
Location
Philly
Car(s)
15 golf tdi sel
I have a 15 golf tdi sel. Has anyone figured out coding using obdeleven? Mib2 8” glass display, mib2 module coded for vehicle.
Volume stuck at zero. Thinking mib1 fender amp may need coding change. Any help appreciated!
 

simaservis1108

Go Kart Newbie
Location
Serbia,Belgrade
Car(s)
Seat Leon 5F FR
Coded for vehicle how?
That looks like component protection.
 

George Ab

Drag Racing Champion
Location
Pacific NW
Oem king/peter. He is good and sells the units all set up. Thinking its a coding issue for mib1 amp, or a bad fiber optic line.
What is an "OEM king/peter"?

I have a 15 golf tdi sel. Has anyone figured out coding using obdeleven? Mib2 8” glass display, mib2 module coded for vehicle.
Volume stuck at zero. Thinking mib1 fender amp may need coding change. Any help appreciated!

You mentioned MIB1 fender amp may need coding. Did you code per the instructions in the initial thread? I made it BOLD in all caps and stated IMPORTANT UPDATE.

"IMPORTANT UPDATE: Per this thread a MIB1 amplifier can be made to work with a MIB2 head unit. https://www.golfmk7.com/forums/showpost.php?p=806606&postcount=593 "

"Enabling sound on 2015 vehicles with MIB1 and Fender Audio:
In module 47 in VCDS
1. Plug in VCDS - choose Module 47
2. Choose CODING.
3. Change byte 0 to 0x12 (Probably you have 0x22)"

With OBD11 you go into long coding. I assume poster who posted meant "on 2015 vehicles with MIB2 and Fender Audio".
 
Last edited:
Top