GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV
  • Has your username changed as part of the site merger and want it changed back? If the other version of your username isn't being used, send Gulfer a PM and we can probably fix it for you

DIY MIB1 to MIB2 Infotainment Conversion (Part 1)

777-300ER

Ready to race!
Location
St Joesph Mi
Doubt it's possible.

Just wait a week and you'll get over the novelty of the performance monitor and want a real multi gauge [emoji23]


Other than that, how'd your retrofit end up?

Sent from my Pixel 3a using Tapatalk
Honestly, I want a more more accurate water temp display than what is provided on the dashboard and be able to run the lap timer in the cluster while still having oil temp displayed. It's theorized all I need is an ECM reflash and it'll work based on what I found on ross tech.

The retrofit went well. Voice does not work even with the FEC's loaded and MQBCARSRETROFIT theorizes that I have to connect a phone to AA and hold the voice button for 2 seconds. I don't believe that but I don't have the USB connector for the cubby yet so I can't try it. He also got drive select working 3rd time, which is nice. He was surprised I got my MIB1 amp working with MIB2 which I did with coding tweaks before I had him touch the unit. Would recommend but don't have him stay up until 3AM to get this done. I'm glad he did it though.
 

KyACRASH

Ready to race!
Honestly, I want a more more accurate water temp display than what is provided on the dashboard and be able to run the lap timer in the cluster while still having oil temp displayed. It's theorized all I need is an ECM reflash and it'll work based on what I found on ross tech.



The retrofit went well. Voice does not work even with the FEC's loaded and MQBCARSRETROFIT theorizes that I have to connect a phone to AA and hold the voice button for 2 seconds. I don't believe that but I don't have the USB connector for the cubby yet so I can't try it. He also got drive select working 3rd time, which is nice. He was surprised I got my MIB1 amp working with MIB2 which I did with coding tweaks before I had him touch the unit. Would recommend but don't have him stay up until 3AM to get this done. I'm glad he did it though.
Holding the voice button for 2 seconds will activate either Siri or Google when you have a phone connected. Works great with Android.

Pushing it once should be normal voice commands for VW. If you ask me it works pretty poorly, so if it doesn't work for some reason you're not really missing anything.

Sent from my Pixel 3a using Tapatalk
 

777-300ER

Ready to race!
Location
St Joesph Mi
Holding the voice button for 2 seconds will activate either Siri or Google when you have a phone connected. Works great with Android.

Pushing it once should be normal voice commands for VW. If you ask me it works pretty poorly, so if it doesn't work for some reason you're not really missing anything.

Sent from my Pixel 3a using Tapatalk
I just want everything to work correctly. Buttons are there. I played with it a little bit before I had the unit modified and I actually didn't mind it. Sucks having OCD sometimes.
 

zigrow

New member
Location
PA
I think after scanning this thread I have an idea of how it works but it's still mostly gibberish to me. But I'm confused in regards to post # 627 quoted above and where it relates to the process. What exactly will all 3 of those work to accomplish? Only the coding for MIB1 amp to work with MIB2? I have a VAGCOM already so I'm curious

I have a Nav unit now in my SEL with Fender audio. If I get an MIB2 NAV unit 3Q0035876 will Navigation be one of the functions that the Dealership can activate?

Am I restricted in any way on the MIB2 display part # I should get if I get the 3Q0035876?

Is it still accurate that the dealership can't activate App-Connect?
Anybody?
 

777-300ER

Ready to race!
Location
St Joesph Mi
Thanks. What about my questions on the nav and part number compatability?
If you get a non Pro unit get the 6.5 display. If you get a pro unit get an 8 inch display. They can work either way but the pro unit has more items displayed to work better with the larger screen. I'm not sure your current maps SD card will work on the new unit however.
 

Rmzhrb

New member
Location
NNJ
I just installed “3Q0035876” on my ‘15 GTI. I also had NAV and fender in my car. I personally bought a new AMP, which some people here say it’s no longer needed as you can simply code the existing amp. I also bought a version 4 map SD card on eBay for about $30. All that said, I had Jack do the activation for CarPlay and NAV earlier this month and couldn’t be happier with the turnout.

Note: I spent a good amount of money trying to get the dealer to do the activation and none of that worked. They were only able to remove CP and enable Bluetooth and sound. I suggest save your money and get in touch with Jack.
 

Cuzoe

Ready to race!
Location
Los Angeles
If you get a non Pro unit get the 6.5 display. If you get a pro unit get an 8 inch display. They can work either way but the pro unit has more items displayed to work better with the larger screen. I'm not sure your current maps SD card will work on the new unit however.
I have never heard that Discover Pro unit shows more icons on the display, consensus seems to be both screens have the same resolution. In any case if prices are similar get the larger screen... Makes everything easier to see but more importantly makes it easier to use the on-screen keyboard for built-in navigation/CarPlay/AndroidAuto. I think those of us that upgraded from the 6.5 to the 8 feel it was worth it. Even more so this is your initial purchase.

Sent from my ONEPLUS A6013 using Tapatalk
 

sprinks

Go Kart Champion
Location
United States
@Rmzhrb Yeah, way back when this thread was young, i had the dealership try as well. No dice. They even were going back and reading this thread (wave) looking for help. Sorry you didn't see the earlier warnings about that.
 

George Ab

Go Kart Champion
Location
Pacific NW
Rmzhrb, glad you got all sorted. I have tried to update the thread concerning all the things we have learned through this process such as buying App Connect from Jack and not online, use of MIB1 amp (updated the day it was confirmed in both parts section and process section), etc. I updated to make it clearer not to bother going to dealer as follows:

Have component protection (CP) removed and have App-Connect key implemented: Important Update: Do not go to dealer as no one has had a dealer successfully install App-Connect FeC. Find someone like Jack who has FAZIK connection and can remove CP, implement App-Connect FeC. Also DO NOT purchase AP connect separately. See IMPORTANT UPDATE https://www.golfmk7.com/forums/showp...&postcount=262 and reinstall existing FeC's (Driver Modes and Voice Commands) which are associated with your VIN in the VW database.
 
Last edited:

Rmzhrb

New member
Location
NNJ
I was aware that the dealership had not been successful with NAV and CarPlay. Main reason I took it in was to remove the CP and enable Bluetooth while I wait for the VAS cable from China (for Jack to do the activation). While I was there they asked if they can try to do the remaining items, but no luck. Kept hoping they would be able to figure it out. Long story short, Jack is the way to go!
 

777-300ER

Ready to race!
Location
St Joesph Mi
I was aware that the dealership had not been successful with NAV and CarPlay. Main reason I took it in was to remove the CP and enable Bluetooth while I wait for the VAS cable from China (for Jack to do the activation). While I was there they asked if they can try to do the remaining items, but no luck. Kept hoping they would be able to figure it out. Long story short, Jack is the way to go!
I have no idea why you would do that and not instead just put the MIB1 head and screen back in.

Sent from my SM-G960U1 using Tapatalk
 

Rmzhrb

New member
Location
NNJ
I have no idea why you would do that and not instead just put the MIB1 head and screen back in.

Sent from my SM-G960U1 using Tapatalk
Because I’m impatient and would rather have an 8” screen without NAV (that I never used) than a 5.8” with NAV.
 

mixolydian23

New member
Location
NYC
I just installed “3Q0035876” on my ‘15 GTI. I also had NAV and fender in my car. I personally bought a new AMP, which some people here say it’s no longer needed as you can simply code the existing amp. I also bought a version 4 map SD card on eBay for about $30. All that said, I had Jack do the activation for CarPlay and NAV earlier this month and couldn’t be happier with the turnout.

Note: I spent a good amount of money trying to get the dealer to do the activation and none of that worked. They were only able to remove CP and enable Bluetooth and sound. I suggest save your money and get in touch with Jack.
I’ve been lurking around this thread for a while—thanks for all the great info here. I have a couple of questions before I finish buying parts (sorry if they were previously answered):

1. Can Jack enable NAV in a 2015 SEL (it currently has factory NAV) assuming I buy a MIB2 unit with NAV (3Q0035876). I didn't think this was possible until Rmzhrb said he had this done recently.
2. My vehicle has Fender audio and I don't have experience with VCDS—can Jack perform the coding to use the existing MIB1 amp?
3. Do I need the donor VIN for just the glovebox unit or do I also need it for the screen?
 

KyACRASH

Ready to race!
I’ve been lurking around this thread for a while—thanks for all the great info here. I have a couple of questions before I finish buying parts (sorry if they were previously answered):

1. Can Jack enable NAV in a 2015 SEL (it currently has factory NAV) assuming I buy a MIB2 unit with NAV (3Q0035876). I didn't think this was possible until Rmzhrb said he had this done recently.
2. My vehicle has Fender audio and I don't have experience with VCDS—can Jack perform the coding to use the existing MIB1 amp?
3. Do I need the donor VIN for just the glovebox unit or do I also need it for the screen?
1. Yes, it will work
2. No, you have to do the coding
3. You don't need the VIN for either

Sent from my Pixel 3a using Tapatalk
 
Top