GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

DIY MIB1 to MIB2 Infotainment Conversion (Part 1)

Cuzoe

Autocross Champion
Location
Los Angeles
Excellent, thank you.

Anyone able to offer any advice on how to get my navigation database updated?

I've removed the CID lock using the toolbox, I've downloaded the 32gb update file from VW, placed the 2 folders and txt file directly on the root of the SD card, when I put the card into either of the slots on the main glovebox unit the display says "software update data is available". After that I've tried navigating to menu, system settings, system information, update software but then I get the error "no data available, please insert a source with software update data or check the source".

Additionally, the performance monitor which was already enabled on this unit doesn't work, the temperature stays at '---' and the G-force displays stay at '-.--' or '0.00', picture attached.

Something inside of me says that the original FECs/SwAPs are probably not enabled for the VIN of this car, and as such aren't working so would need to be cleared out and re-enabled using the code generator?
Performance Monitor swap only exists in the 5F - but whether or not it shows anything depends on your (engine) ECU software and Gateway software. I don't know of any comprehensive list (it would be hard to put together) of what software versions provide all the info for performance monitor.

Navigation swap, similarly, only exists in 5F. Sounds like you have a FEC problem though... what FECs are you showing as active?
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Performance Monitor swap only exists in the 5F - but whether or not it shows anything depends on your (engine) ECU software and Gateway software. I don't know of any comprehensive list (it would be hard to put together) of what software versions provide all the info for performance monitor.

Navigation swap, similarly, only exists in 5F. Sounds like you have a FEC problem though... what FECs are you showing as active?
As far as I can tell, all the available codes are enabled, see the attached pictures. Please note this was before I removed the CP with the toolbox.

Performance monitor isn't a huge loss, if it doesn't work then I don't really mind, the 2L TDi isn't quite blistering performance, but getting the native navigation working would be great.
 

Attachments

  • IMG20231115123200.jpg
    IMG20231115123200.jpg
    3.4 MB · Views: 53
  • IMG20231115123156.jpg
    IMG20231115123156.jpg
    3.7 MB · Views: 57

Cuzoe

Autocross Champion
Location
Los Angeles
As far as I can tell, all the available codes are enabled, see the attached pictures. Please note this was before I removed the CP with the toolbox.

Performance monitor isn't a huge loss, if it doesn't work then I don't really mind, the 2L TDi isn't quite blistering performance, but getting the native navigation working would be great.
Hmm, you've got 09400008 valid but may only be for maps up to 2018/2019. I don't know how the patching thing works but I would try to get 09400099 activated, which should be good for lifetime updates.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Hmm, you've got 09400008 valid but may only be for maps up to 2018/2019. I don't know how the patching thing works but I would try to get 09400099 activated, which should be good for lifetime updates.
Just as an update, I managed to get navigation working, I used the latest update for the 'EU - West' from the first post on the following link;

https://www.golfmk7.com/forums/inde...-media-mst2-and-discover-pro-mhig-mhi2.422268

I actually put the update onto my original MIB1 SD card because it was less than 8GB in size, when compared to the 32GB as downloaded directly from VW. I've not worked out if it's because it's in a different format* or if the CID lock is still causing an issue, but it's working with the latest maps (2022-2023 I think) as there's a few roads local to me which have changed recently and they are updated on my maps.

I'll try with another 8GB non-vw card and see how I get on when I get some spare time.

* - The download from VW has 2 folders, MIB1, MIB2 and a txt file. The download from the other link above contains a different file structure, a folder called 'maps' which contains other folders and files.

Regards, Dave.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Ok, question for the hive mind. Can anyone tell me what the differences are between the Preh unit I've bought and the ones fitted to say the MK3 Skoda Fabia (as an example).
Mine - 3Q0035874C
Fabia - 5Q0035874C

The only obvious external difference I can see is that the Fabia one has only 1x SD slot and any of the auctions that include the display screen don't have a Nav button, but both main units have /NAV in the model sticker so I assume the Fabia units would need FEC's enabling for Nav and a suitable display screen.
I know there may be internal differences other than the SD card, but the hardware noted on the stickers both say H41.
Have noticed the one I bought has 3x MAC addresses on the label, fabia only has 1, for BlueTooth.

If I was to take one of the fabia units and plug it into the VW display, would I be able to just enable the nav FEC and change the customisations etc to VW?

You'll hopefully humour me, and this is purely theoretical at the moment but I'm thinking along the lines of trying to retrofit one of these into my T3 Camper van. I know theres plenty of hurdles like canbus hacks etc but I do like a challenge (plus I already have a MK7 canbus hacking workbench set up from my Radar experiments).
 

George Ab

Drag Racing Champion
Location
Pacific NW
@davegsm82 The OP has been fantastic about updating the first two posts with new info. There have been updates to Post 2 with new findings that are deep, like 50+ pages, into the thread.

As far as the USB/Aux/MDI... if it works it works, don't mess with it, haha!

In my experience Android Auto has been more picky than CarPlay so if you've got Android Auto working I'd think you're good to go. I use a wireless Android Auto Dongle and almost never open the cubby anymore. Get in the car and my phone connects, it's great.

Thanks Cuzoe for the call out. You have become the subject matter expert so do hit me up if you think something needs to be added to the initial two posts and I will update.
 

Cuzoe

Autocross Champion
Location
Los Angeles
Thanks Cuzoe for the call out. You have become the subject matter expert so do hit me up if you think something needs to be added to the initial two posts and I will update.
Nowadays if people buy the right unit they can get around component protection and enable all the needed FECs with just an SD card 🤯. I don't have any expertise/experience in that method, but what a time to be alive!

I upgraded from MIB 1, to 2, to 2 with nav, to 2.5 all using the methods from your posts. I've got the latest and greatest, everything active, and zero faults in 5F. I wouldn't have it any other way.
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
Thanks Cuzoe for the call out. You have become the subject matter expert so do hit me up if you think something needs to be added to the initial two posts and I will update.
Nowadays if people buy the right unit they can get around component protection and enable all the needed FECs with just an SD card 🤯. I don't have any expertise/experience in that method, but what a time to be alive!

I upgraded from MIB 1, to 2, to 2 with nav, to 2.5 all using the methods from your posts. I've got the latest and greatest, everything active, and zero faults in 5F. I wouldn't have it any other way.

I think everyone who has contributed to this needs a massive pat on the back. Much like Cuzoe says, the fact anyone with an SD card and a bit of knowlege (ok, and VCDS/OBD11) can now remove CP and CID locks among other things completely for free, absolutely blows my mind. well done guys.
 

backcountry

Passed Driver's Ed
Location
Indiana
Car(s)
GTI
I think everyone who has contributed to this needs a massive pat on the back. Much like Cuzoe says, the fact anyone with an SD card and a bit of knowlege (ok, and VCDS/OBD11) can now remove CP and CID locks among other things completely for free, absolutely blows my mind. well done guys.
Exactly this
 

tripleS

Go Kart Newbie
Location
Las Vegas
Car(s)
15 GTI PP \ 16 GT4
I have a 3Q0035878B MIB2 (non-pro); MST2_US_VW_P0883D which the congo+duke SD patch does not deactivate Component Protection. Wish there was a way to downgrade the firmware to a version which it does work on to save myself the hassle...
Does anyone have a good or recent contact for remote component protection deactivation via ODIS? Jack is not online/responding via Skype :(
 

davegsm82

Go Kart Newbie
Location
Blyth, Northumberland - England
Car(s)
MK7 Golf and T3 Tdi
I have a 3Q0035878B MIB2 (non-pro); MST2_US_VW_P0883D which the congo+duke SD patch does not deactivate Component Protection. Wish there was a way to downgrade the firmware to a version which it does work on to save myself the hassle...
Does anyone have a good or recent contact for remote component protection deactivation via ODIS? Jack is not online/responding via Skype :(
Is that a Delphi unit? also (I know it's a really, really stupid question, but) have you reset the unit completely by holding the power switch until it power cycles? I thought my CP patch hadn't worked, but I was reading too quickly and didn't reset the unit.
 

brentgti

Go Kart Champion
Location
North America
Car(s)
GTI
Is that a Delphi unit? also (I know it's a really, really stupid question, but) have you reset the unit completely by holding the power switch until it power cycles? I thought my CP patch hadn't worked, but I was reading too quickly and didn't reset the unit.
It's a Delphi unit. The software train contains a reference to the manufacturer: MST2_US_VW_P0883D (D for Delphi; T for TechniSat). I suspect the issue is that there is not a patch available for the US 883 firmware for this specific unit's hardware.
I have a 3Q0035878B MIB2 (non-pro); MST2_US_VW_P0883D which the congo+duke SD patch does not deactivate Component Protection. Wish there was a way to downgrade the firmware to a version which it does work on to save myself the hassle...
Does anyone have a good or recent contact for remote component protection deactivation via ODIS? Jack is not online/responding via Skype :(
If you have a VAS or compatible passthrough device, you might be able to remove the component protection yourself using ODIS. I think it is technically possible to downgrade the software train but I am not sure how safe that operation is.
 
Last edited:

cowboykiller

New member
Location
Essex Vermont
Car(s)
2015 GTI MK7
So I have completely done my retrofit with an 8" touch screen sourced from a 2018-2022 Tiguan and a MIB2 unit sourced from an 2019 Tiguan. Everything powers on and have the dreaded CP removal process to figure out. Its my last step to enjoying my new retrofit.

Info
Software train: MST2_US_VW_P0890D
Part Number 3Q0035844B
USB mod installed and working(Android Auto pops up on screen when connected to usb-a to usb-c)
8" touch screen dual knobs and piano black trim.
Duke and Congo installed

There are 2 files in the Duke and Congo V3 called delphi.sh and delphibin.ifs. Are these the 2 files i need for CP removal with my setup?

OR-

I also have a usb-ethernet to possibly try the Putty method to remove CP. The green engineering menu is activated thanks to OBDeleven and when i plug in the adapter the IP address does in fact show up on the unit in the debug menu. SO i think I'm ready to try this. I am looking for the correct patch for my unit. Can anybody help me with my CP removal moving forward. I have done my due diligence and read multiple forums and guides, but i seem to be missing something. I already bricked one unit and the seller was happy to take the return. When i ran the Duke and Congo file one time the screen turned RED and said ABORTED on the screen and then went into a bootloop. I thought i had followed the directions to a T but apparently something went wrong.

I am looking for someone who might be willing to connect via teamviewer and help with the putty cp removal process(OBVIOUSLY THAT HAS DONE IT BEFORE AND WONT BRICK MY UNIT). I do not have access to a VAS5054(a) and cannot afford to buy one either as its approaching the holidays and money is tight. I am willing to make a deal/payment with/to someone for their time that can remote in and do the Putty CP removal.
 
Last edited:

cowboykiller

New member
Location
Essex Vermont
Car(s)
2015 GTI MK7
So is this thread dead?

Info
Software train: MST2_US_VW_P0890D
Part Number 3Q0035844B
USB mod installed and working(Android Auto pops up on screen when connected to usb-a to usb-c)
8" touch screen

Drive Mode button working in MIB

Car_Function_Gen2-menu_display_charisma Van not activated to activated
Car_Function_Gen2-menu_display_charisma_oer_treshold_high Van not activated to activated
Car_Function_Gen2-menu_display_charisma_0X17 Van not activated to activated
Car_Function_Gen2-menu_display_charisma,0x17_msg_bus Infotainment data bus

Ive managed to get my CP removed VIa ODIS from a local shop, only cost me an hour of labor for them to do it. Everything works EXCEPT my Drive mode button for Normal, Sport, Individual. It is currently stuck on orange and in Eco Mode as far as i can tell. I've done the OBDeleven long coding (above) following others recommendations and still, my drive profiles dont work via pushing the button and nothing popping up on the screen.

Any help getting my drive modes back would be amazing, or a link to get me further than i am
 

Acadia18

Autocross Champion
Location
The Greater Boston Metropolitan Area
Car(s)
2019 Golf R
So is this thread dead?

Info
Software train: MST2_US_VW_P0890D
Part Number 3Q0035844B
USB mod installed and working(Android Auto pops up on screen when connected to usb-a to usb-c)
8" touch screen

Drive Mode button working in MIB

Car_Function_Gen2-menu_display_charisma Van not activated to activated
Car_Function_Gen2-menu_display_charisma_oer_treshold_high Van not activated to activated
Car_Function_Gen2-menu_display_charisma_0X17 Van not activated to activated
Car_Function_Gen2-menu_display_charisma,0x17_msg_bus Infotainment data bus

Ive managed to get my CP removed VIa ODIS from a local shop, only cost me an hour of labor for them to do it. Everything works EXCEPT my Drive mode button for Normal, Sport, Individual. It is currently stuck on orange and in Eco Mode as far as i can tell. I've done the OBDeleven long coding (above) following others recommendations and still, my drive profiles dont work via pushing the button and nothing popping up on the screen.

Any help getting my drive modes back would be amazing, or a link to get me further than i am

I'm not very knowledgeable about this stuff. But this is what I had to change to get my drive mode button working. Few different parameters than what you have.

menu_display_charisma to activated
menu_display_charisma_after_disclaimer to not activated
menu_display_charisma_clamp_15_off to not activated
menu_display_charisma_over_threshold_high to activated
menu_display_charisma_standstill to activated
 
Top