GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV
  • Has your username changed as part of the site merger and want it changed back? If the other version of your username isn't being used, send Gulfer a PM and we can probably fix it for you

Discover Pro firmware

cbass99

New member
Location
Canada
Anyone know if there is an updated firmware available for North American Discover Pro MIBII Units

my current version:
Device P/N 3G0 035 047A
Hardware H42
Firmware 0344
 
Last edited:

Mk5Dom

Ready to race!
Location
UK
I was on a very very old version 0094 I think, had issues with DAB disappearing, not being able to change out of Eco driving mode etc.
Hi Simon.

I'm running HW H40 & SW 0095 and I too have issues with DAB disappearing and Mode Selector going awol.

What was the outcome in the end? I hope you managed to get it sorted out.

:(
 

res

New member
Location
Italy
Hi all, I installed the 0407 on my Discover Pro mib 1 and I've now a great problem. Sound doesn't work until I force the system to make an update, after that the sound is great and all work fine, better than 0095.
I think it is becouse I made it with engine running (and becouse I'm stupid to did this).
So: my service VW dosn't know what is it a FES reset (and maybe he doesn't want to inform about)... Is it possible to try reinstall the same firmware (without engine running this time)?

(sorry for my english)
 

Korni22

New member
Location
Germany
@res interestingly enough I have the same problem, you're not alone ♥

I've heard around the net there is currently no downgrade for the 0407, but I might be wrong/my info could be outdated.

Could you try another dealer to do a FES?
 

res

New member
Location
Italy
did you update the firmware with the engine running too?

I spoke by telephone with a kind of master of eprom from Rome :) He told me: go to another service, don't say anything about you did and ask simply "a recode to remove the protection of the navigator". It should be enough.
In the afternoon I'll try to do it. Stay tuned for answer.

I wrote to other two big VW services explaing the problem: no answer, I think anyone of them knows what does it mean...
 

res

New member
Location
Italy
I did it, I went to a service, they tried all the possible. My (and your problem) problem has not solution in an official way.
I'll try now with a third part solution (hacking, bypass, etc etc).
 

Chillout

Go Kart Newbie
Location
the Netherlands
Ride
Golf GTE
I did it, I went to a service, they tried all the possible. My (and your problem) problem has not solution in an official way.
I'll try now with a third part solution (hacking, bypass, etc etc).
You can try an emergency recovery, and reinstall the images of the firmware.
 

Chillout

Go Kart Newbie
Location
the Netherlands
Ride
Golf GTE
There isn't much. But I recovered a MIB1 once using this method...
You need to connect an FTDI interface to the RX/TX/GND interface at the back of the MIB unit (the one in the glovebox). Then connect to the device using a terminal emulator, speed 115200, flow control xon/xoff, stop bit 1. You should see some output there.
 

res

New member
Location
Italy
Oh, I thought that it will be possible via VCDS and OBD...

I'll give a sight but I think it is over my knowledge :(
 

res

New member
Location
Italy
finally solved!!!

I'dont know how he did, but someone made a downgrade of the discover pro, at the 0200. Really with that the discover was mute, absolutely mute. So I tried to install the 0388 one and now all the system works. I've still the known bug of the low quality sound after the 50% volume but know I switch on the car and the discover sounds, without searching update, simply sounds.
 

caRni

New member
Location
Germany
finally solved!!!

I'dont know how he did, but someone made a downgrade of the discover pro, at the 0200. Really with that the discover was mute, absolutely mute. So I tried to install the 0388 one and now all the system works. I've still the known bug of the low quality sound after the 50% volume but know I switch on the car and the discover sounds, without searching update, simply sounds.
Hey hey, can you explain how he downgraded the firmware. I am also able to connect it to an FTDI if that is required. I have knowledge in this segment but would need to know what I can feed the terminal to accept a downgrade.

Any tip is much appreciated. thanks
 

warpigroadkill

New member
Location
North Yorkshire
I have a Japanese mk7R in the UK and wanted to know how to change the software/firmware over to EU? I can't seem to find it online and the dealership won't touch the infotainment at my local one. I've been told it's just a software change to get the EU maps working. Any help would be awesome.
 
Top