GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Complete loss of power and ACC/Front assist error

Heathy

New member
Location
Hull, East Yorkshire
Car(s)
MK7 VW GTD
This has happened twice now, first time I was going 70mph on a dual carriageway (with no hard shoulder) so was pretty sketchy as I just heard a thud and then flashing glow plug light and a load of ACC/front assist errors, I managed to coast with no power and hazards on to 30mph where I managed to restart the car and carry on as normal like nothing happened.

I scanned with OBDeleven and even had it in the garage a few days later for an engine management light and MOT, the light turned out to be a faulty cable they fixed. Now around a month later the same thing has happened again, I was approaching a roundabout and had a complete loss of power again and the same lights popped up again, stopped restarted and drove fine again, no thud this time, just went to accelerate on to the roundabout and had no power.

Will scan again later but also had my engine management light pop up again not long ago, which I'm waiting to get looked at. I thought it might be the same faulty cable throwing it up but now wondering if it's something else, I scanned the car when it appeared again but all I got was these three blank codes under 01 engine :

Trouble codes:
null - Unknown
Intermittent
null - Unknown
Intermittent
null - Unknown
static

Anyone experienced anything similar? Could it maybe be faulty glow plugs and causing a misfire? Car is really getting on my nerves lately.
 

misor1994

Passed Driver's Ed
Location
Slovakia
Car(s)
Golf GTD Variant
Try another diagnostics...VCDS/ODIS/VCP. If the issue still persists and the light still does appear on the dashboard (even if it went off), there should be fault codes in the respective units.
 

GTI Jake

Autocross Champion
Location
Charlotte, NC
Most likely a Battery, positive or negative cable (ground) issue.

Could also be a ignition switch, but given its so intermittent and doesn’t show other signs of that issue I’d lean towards the former possibilities.
 

Heathy

New member
Location
Hull, East Yorkshire
Car(s)
MK7 VW GTD
Thanks for the responses, unfortunately I don't have a VCDS or anything available to me other than my OBDeleven just for personal use. I have had it back from the garage and think the light is from a faulty cable connection, the engine light is currently off so hopefully that doesn't return. I hate seeing those on my dash. They also said the error codes showed up as Glow Plug 2 and an unspecified Injector fault. They have cleared them so hopefully I don't experience anymore loss of power as that is pretty scary especially when going 70mph on an A-road with no where to pull up. Might try some fuel injector cleaner when I fill up for the next few weeks and hope it's just something as minor as a clogged injector causing a misfire or something. If it continues then may need further investigation.
 
Top