GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

A way to keep the rear view camera on for just a bit longer?

DP03

Ready to race!
Location
Maryland
My 16 S displays the RVC feed after switching back to drive until the camera physically retracts, so I have ~8-10 seconds before the display cuts out. I can understand how it would be frustrating for the RVC feed to cut off immediately after shifting out of reverse.

This is how mine works too, and I think that's the proper operation.
 

jimlloyd40

Autocross Champion
Location
Phoenix
Car(s)
2018 SE DSG
What's displayed on your infotainment system screen during those 8 seconds?

On my 18 Autobahn, the rear view camera physically closes at about 8 seconds after Reverse is deselected, or the vehicle reaches about 10 MPH, whichever comes first, but the infotainment system screen immediately switches to display PDC (not the rear view camera, which is what Tiguan does) after Reverse is deselected, and remains active until the vehicle reaches about 10 MPH.

The view from the rear camera.
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
anyone ever figure this out??

I’m having an interesting problem that is somewhat related. before I retrofitted a discover pro to my gti, my reverse camera would disappear as soon as I shifted from R to neutral/1st (would go to the sensor/trajectory view that takes up the whole screen).

now, with the discover pro, the camera view does not immediately go away when I shift out of R, which is a nice unexpected change. but.. at least half of the time now, the camera feed does not appear when I shift to R, I have to press the parking sensor/assist button twice and then it will show up (once to turn off the sensors then again to turn them on).

that is not the only issue - let’s say I reverse into a spot and then shut the car off, the MIB stays on the reverse camera screen even after the ignition is off and I open the drivers door, I have to press the “X” in the corner and then the screen goes blank like it should do automatically.

what did I do to my car? 😂 is it a coding or adaptation issue? dataset issue (i.e. VIM)? just curious if anyone’s run into this. it seems like it’s mis-configured somehow and not getting the right signals related to the camera and park assist system.
 

Kushdaiin

Go Kart Champion
Location
Connecticut
Car(s)
MK7 R, MK7 GSW SEL
You could try and check to see if your discover pro is programmed for a High-line RVC. Below is the 5F module coding to go from a low-line RVC to a high-line RVC (from @mr-fix).


Disable RVC-LOW and enable RVC-HIGH in MIB module
5F → Long Coding → Byte: 19 → Bit: 4 → disable
5F → adaptation → Car Function List BAP Gen2 → VPS_0x0B → activated
5F → adaptation → Car Function List BAP Gen2 → VPS_0x0B_msg_bus → Comfort data bus
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
You could try and check to see if your discover pro is programmed for a High-line RVC. Below is the 5F module coding to go from a low-line RVC to a high-line RVC (from @mr-fix).


Disable RVC-LOW and enable RVC-HIGH in MIB module
5F → Long Coding → Byte: 19 → Bit: 4 → disable
5F → adaptation → Car Function List BAP Gen2 → VPS_0x0B → activated
5F → adaptation → Car Function List BAP Gen2 → VPS_0x0B_msg_bus → Comfort data bus
thanks, I haven’t had time to try this out yet but I’m crossing my fingers. I think I have a combination of both of these codings, VPS is activated, msg_bus is terminal 15, and byte 19 bit 4 is enabled.
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
@Kushdaiin that was totally it, thank you. I wasn’t reading my adaptation backup properly because I went back and looked at it and it clearly says VPS is off (and msg_bus = databus infotainment). now the camera goes away immediately.
 

Kushdaiin

Go Kart Champion
Location
Connecticut
Car(s)
MK7 R, MK7 GSW SEL
@Kushdaiin that was totally it, thank you. I wasn’t reading my adaptation backup properly because I went back and looked at it and it clearly says VPS is off (and msg_bus = databus infotainment). now the camera goes away immediately.
Sweet! I was hoping it was that easy. I remember some of the discussion when I was upgrading to the highline camera. I'm just glad that worked. Still hoping to get that parking heater done this summer . . .
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
Sweet! I was hoping it was that easy. I remember some of the discussion when I was upgrading to the highline camera. I'm just glad that worked. Still hoping to get that parking heater done this summer . . .
in the process I added a highline reverse camera to my AliExpress cart in case, oh nooo, my camera’s broken, guess I have to get a new one now 🤷‍♂️ lol

oh the Webasto is a fun one 😅 but so worth it, I still think it’s the best mod I’ve managed to finish. I hope our (@xabhax and me) thread on it can be helpful, feel free to post if you run into anything.
 

Cuzoe

Autocross Champion
Location
Los Angeles
Ugghhh... I still really want to do the webasto. Although I suspect they are quite common in Europe, I'm having a really hard time sourcing the diesel fueled heater. Gas ones are a relative dime a dozen.
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
@Cuzoe interesting, I remember when I was ordering parts, I could find many more diesel ones than “Benzin”. are you looking on ebay? try “5Q0815005 diesel”. there are some brand new ones on there.
 

Cuzoe

Autocross Champion
Location
Los Angeles
@Cuzoe interesting, I remember when I was ordering parts, I could find many more diesel ones than “Benzin”. are you looking on ebay? try “5Q0815005 diesel”. there are some brand new ones on there.
Have you seen a parts breakdown that includes that part number for the TDIs? I could take a chance and order on eBay but if it it doesn't include everything I'm going to be stuck. Not a place I haven't been before but not a place I want to be, haha.

I see some stuff on ilcats but with a PN 5Q0898008A, C or F...
https://www.ilcats.ru/vw/?function=...&group=8&subgroup=819&part=819070&language=en

That being said, I do see some 5Q0815005J-s on eBay with different levels of complete-ness.
 

2018gti

Drag Racing Champion
Location
Massachusetts, USA
Car(s)
Golf GTI Autobahn MT
Have you seen a parts breakdown that includes that part number for the TDIs? I could take a chance and order on eBay but if it it doesn't include everything I'm going to be stuck. Not a place I haven't been before but not a place I want to be, haha.

I see some stuff on ilcats but with a PN 5Q0898008A, C or F...
https://www.ilcats.ru/vw/?function=...&group=8&subgroup=819&part=819070&language=en

That being said, I do see some 5Q0815005J-s on eBay with different levels of complete-ness.
tbh I've never seen that part #, the one written on the heater, listed anywhere for anything lol. it just doesn't exist on the parts sites, I don't really know why. I'm not sure what would show up if you ordered a 5Q0898008 from like cars245 or e-acca. I have a feeling that it may be the bare heater itself with absolutely nothing attached but who knows. I never found any actual list that had everything you need, I just had to piece it together from ilcats and CarProg2 and the service manuals (my final list is at the end of xabhax's webasto thread).

To me it looks like the only thing a lot of the listings are missing is the muffler + probably the nut that goes with that. Since you shouldn't run your heater with an open downpipe 😂 you can just find it separately. Looks like most are coming with the 2 coolant hoses though which is nice, mine had the muffler but no hoses.
 
Top